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This is the free online version of the textbook Learn Excel. This task-oriented textbook is
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Preface

This textbook is designed to be a comprehensive introduction to Microsoft Excel and is specifically
developed for students in higher education and users of Microsoft Excel. It is intended for those
who are new to Excel and want to learn how to use it effectively, as well as for those who have
some experience with the software but want to deepen their understanding of its features and
capabilities.

This textbook differs from other Excel textbooks in several ways:

• It is free and online, making it accessible to a broad audience.

• Topics are developed to accomplish a specific task and achieve mastery of that task, nothing
more and nothing less. This approach has resulted in concise, step-by-step tasks without
extraneous information that might cause distractions. In the chapters, these tasks are
clearly indicated by titles beginning with “Task:”, making it evident what action is required.

• The textbook includes interactive elements that students can use for self-directed learning.
This requires a browser with JavaScript support.

• Most chapters conclude with a series of exercises. The title of each exercise begins with a
unique code followed by a brief description.

• The content of the tasks and exercises is primarily determined by the competencies and
skills that higher education demands. Many of the problems are derived from students’
experiences in professional practice during internships and graduation projects.

Organization of the textbook

Content of the chapters.

• Chapter 1: Introduction to spreadsheets and Excel. If you are already familiar with Excel,
you can skip this chapter.

• Chapter 2: Using worksheets.

• Chapter 3: Entering data and the difference between content and formatting of cells.

• Chapter 4: Formatting worksheets and cells, including conditional formatting.

• Chapter 5: Formulas, absolute and relative cell references, copying and naming ranges, and
setting up calculation models.

• Chapter 6: Built-in functions.

• Chapter 7: Tables and operations.

• Chapter 8: Array formulas and dynamic arrays.

• Chapter 9: Creating charts.

• Chapter 10: Chart types.
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Software

• Chapter 11: Scenarios.

• Chapter 12: Data tables.

• Chapter 13: Pivot tables, pivot charts, slicers and timelines.

• Chapter 14: Goal Seek.

• Chapter 15: Solver.

• Chapter 16: Macros.

• Chapter 17: Processing measurement results and linear relationships.

Software

This textbook is written for Excel 365, a product that is constantly evolving, with new features
added in each release. A key feature is the introduction of dynamic arrays and functions in the
July 2020 release. This update differentiates Excel 365 from other Excel versions, including the
2016 and 2019 versions. Dynamic arrays are not compatible with all other Excel versions.

Does this mean you cannot use this textbook with Excel 2016 and later? No. Only the array
chapter is unsuitable; all other chapters are compatible. This compatibility largely extends to
older Excel versions like 2010 and 2007.

4



1 Starting with Excel

OBJECTIVES

• What spreadsheets are.
• Starting and closing Excel.
• The layout of the Excel program window.
• Creating and saving a new workbook.
• File formats of Excel.

1.1 What is Excel?

Excel is part of the Microsoft Office suite. It allows you to perform calculations in spreadsheets.
This chapter provides an introduction to spreadsheets in general, with a specific focus on Excel.

A spreadsheet is a computer program that lets you enter data (text, numbers, etc.) into sheets
made up of rows and columns. Besides entering data, you can also perform various operations
on it. Microsoft Excel is one such program.

The term “spreadsheet” is also used to refer to a file created with such a program. In Excel, this
file is called a workbook. The standard file format is .xlsx, but Excel supports many other
formats for both reading and saving files.

A workbook can contain one or more worksheets. A worksheet is divided into rows and columns,
and their intersections are called cells. Cells are identified by a column letter and a row number
— for example, B3 refers to the cell in column B, row 3.

You can enter text, numbers, and formulas in cells. Formulas allow you to perform calculations
or manipulate text. They can reference other cells, making it possible to build large and complex
calculation models. Any change will automatically update all dependent values.

Spreadsheets are very useful for performing What-if analysis, where you modify input values to
see how they affect results. Excel also makes it easy to create clear and attractive charts.

1.2 Starting and Closing Excel

How you start Excel depends on your system setup. This course assumes a default installation
of Microsoft Office 365 on Windows 10. On most systems, Excel can be launched from the Start
menu. The easiest way is to use a shortcut on the desktop or taskbar.

Task 1.1.

1. Choose Start > Excel.
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1 Starting with Excel

The Excel start screen appears. On the left, you’ll see recently opened files; on the right, an
overview of available templates.

2. Click on the Blank workbook template. A new workbook opens named Book1 with a blank
worksheet named Sheet1.

INFO Note

Disabling the Start Screen
By default, Excel shows the start screen at launch. This includes recent documents and
templates. If preferred, you can start Excel with a blank workbook:
Go to File > Options > General tab and uncheck the option Show the Start screen when
this application starts.
Next time you launch Excel, it will open directly to a new workbook.

To exit Excel:

• Click the X button in the top right corner of the window.
• Or choose File > Close from the menu.

3. Close Excel.

INFO Note

If changes were made to the workbook, Excel will prompt you to save them before closing.

1.3 The Excel Window

The Excel interface includes three main areas: the application controls, the worksheet, and the
status bar. These are shown top to bottom in the image below.

Figure 1.1: Excel interface.

1 - File Opens a menu with basic commands such as New, Open, Save, Print, and Options. This
view is known as the Backstage.
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1 Starting with Excel

2 - Quick Access Toolbar A customizable toolbar with shortcuts for commonly used commands.
Default buttons include:

• Save
• Undo
• Redo
• Form

3 - Ribbon A wide toolbar at the top. Commands are grouped under tabs like Home, Insert,
Page Layout, ….

Some tabs, such as contextual tabs (e.g., Chart Tools), only appear when relevant. Commonly
used commands are on the left, specialized ones on the right.

INFO Note

You can’t remove the ribbon, but you can minimize it using CTRL + F1. Press it again to
restore.

4 - Tabs Located above the ribbon. Each tab contains groups of commands. Some tabs appear
only when needed.

5 - Groups Each tab has groups of related commands. To see more options, click the small
arrow in the bottom right of the group.

6 - Workbook Name Displays the name of the file.

7 - Command Button Click to execute a command. It may apply changes immediately or open
a menu or dialog box.

8 - Active Cell The selected cell is outlined in black. In Figure 1.1, the active cell is A1.

9 - Name Box Located next to the formula bar. It shows the reference of the active cell or its
assigned name. You can also assign names here.

10 - Formula Bar Displays the data or formula in the active cell. You can edit content here as
well.

11 - Worksheet A workbook can contain multiple worksheets. A new workbook starts with
Sheet1. Click the worksheet tab to switch sheets or click + to add one.

1.4 Creating a New Workbook

You can create a new workbook at any time. It can be blank or based on a template.

Task 1.2.

1. Click File > New. Templates will appear on the right.

2. Click Blank workbook. A new workbook with one worksheet is created.

7



1 Starting with Excel

1.5 Opening a Workbook

Ways to open an existing workbook:

• Double-click the Excel file in File Explorer.
• Select Open from the start screen.
• Choose File > Open from within Excel.

Figure 1.2: Dialog window Open to search for a file on a specific location.

Click This PC or Browse to locate the file. To open other formats, use the dropdown arrow next
to the file type list:

Figure 1.3: Choosing file format, the default choice is the file format of Excel.

Task 1.3. File: Weatherleather.xlsx

1. If necessary, start Excel.

2. Open the file.

1.6 Saving a Workbook

The most common ways to save a workbook:

• File > Save
• Quick Access Toolbar > Save button

When you save an existing workbook, the previous version is overwritten. For new files, the Save
As dialog appears.
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1 Starting with Excel

Task 1.4.

1. Save the workbook using one of the methods above.

If this is the first time saving the file, Excel will prompt you with the Save As dialog.

2. Select a location.

3. Enter a file name in the File name field and click Save.

1.7 Save As

To create multiple versions of a workbook or use a different format, choose Save As.

You can specify both the name and file format:

Figure 1.4: Choosing file format, the default choice is the file format of Excel.

Available file formats are listed in Figure 1.5:

Figure 1.5: Possible file formats.
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1 Starting with Excel

1.8 Excel File Formats

Formats for Excel 2007–2016

• XLSX: Default format (no macros).
• XLSM: Macro-enabled format.
• XLSB: Binary format for large workbooks.
• XLTX: Template format (no macros).
• XLTM: Macro-enabled template format.

Older formats

• XLS: Format used in Excel 2003 and earlier. Opens in Compatibility Mode.
• XLT: Template format from Excel 2003 and earlier.
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2 The Worksheet

OBJECTIVES

• Worksheet layout and usage.
• Activating a worksheet.
• Adding, deleting, moving and copying a worksheet.
• Renaming and modifying a worksheet.
• Selecting with the mouse.
• The important difference between the contents and format of a cell.
• Printing and print settings.

A workbook can contain one or more worksheets. Each worksheet has a tab at the bottom of the
workbook window. In the worksheet, you can enter data and formulas. This chapter covers how
and where to enter data in the worksheet, and how it is displayed.

2.1 What is a Worksheet?

An overview of worksheet design and usage.

A worksheet contains rows and columns. The intersection of a row and a column is a cell. You
can store data and formulas in the cell.

Figure 2.1: Worksheet with rows, columns and cells.

Rows are numbered 1, 2, 3, and so on, while columns are labeled A, B, C, and so on. After
Z, columns are labeled AA, AB, and so on. After ZZ, the labeling continues with AAA, AAB,
etc. A worksheet can contain 16,384 columns and 1,048,576 rows. This results in over 17 billion
cells.

Each cell is identified by a specific row and column. The combination of the column letter and
row number is called a cell address or cell reference. The first cell in the upper left corner is
A1. Cell addresses can be used in formulas to refer to cell content.

A cell is selected by clicking it with the mouse. This cell becomes the active cell, and it is
highlighted with a border.

A worksheet always has an active cell. You can activate a different cell by clicking it, or by using
the arrow keys on the keyboard to move the active cell. When you start typing, data is entered
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2 The Worksheet

into the active cell. Press the Enter key to complete data entry. By default, the active cell moves
down one cell.

INFO Note

You can change this direction in Excel Options: down, up, right, and left.

The content of a cell can be:

• text
• numbers
• formulas

References to other cells are allowed in the formulas. Formulas are automatically recalculated
when the content of referenced cells changes. This makes a spreadsheet very powerful.

2.2 Activating Worksheet

A workbook can contain multiple worksheets, each with its own tab at the bottom left of the
window. You must activate a worksheet before you can use it. If there’s only one worksheet, it’s
activated automatically. To activate a different worksheet, click its tab. The active worksheet’s
tab appears with a white background.

Task 2.1. File: Consolidation.xlsx

1. Open the file.

2. Click on different worksheet tabs to select them. The selected worksheet appears, and its tab
turns white.

2.3 Add a New Worksheet

Task 2.2.

1. Open a new blank workbook.

2. Click on the New sheet button .

A new worksheet is added to the end of the workbook and becomes the active sheet. The new
worksheet is automatically named “Sheet” followed by a number. You can rename it later (see
Section 2.5).

2.4 Deleting Worksheet

It’s good practice to keep only worksheets with content and delete empty ones. You can delete
any worksheet except the last one, as a workbook must contain at least one worksheet. If a
worksheet contains data, or if you’ve emptied it by removing all content, Excel will ask you to
confirm the deletion. Otherwise, the worksheet will be deleted immediately.

Task 2.3.
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2 The Worksheet

1. Right-click the worksheet’s tab, and then select Delete.

You’ll encounter one of two scenarios:

• The worksheet is deleted immediately. If this happens, no further action is needed.
• A dialog box will appear, asking you to confirm the deletion.

2. Click Delete.

2.5 Renaming Worksheet

It’s recommended to give worksheets descriptive names instead of the default names like Sheet1,
Sheet2, Sheet3, etc.

Task 2.4.

1. Rename a worksheet using one of these methods:

• Right-click the worksheet’s tab, and then select Rename.
• Double-click the worksheet’s tab.

2. Type the new name, and then press Enter.

2.6 Copying Worksheet

Task 2.5.

1. Right-click the worksheet’s tab and select Move or Copy ...

Figure 2.2: Move or Copy dialog box.

2. You can perform one or more of the following actions:

• To book - This option defaults to the current workbook. Use the drop-down arrow to select
a different open workbook. Selecting “new workbook” will create a new workbook.
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• Before sheet - Choose the destination workbook location.
• Create a copy - Select this option to create a copy of the worksheet. If you leave it unchecked,

the worksheet will be moved to the new location.

2.7 Mouse Selections

Often, you’ll want to apply a command to multiple cells at once. For example, you might want to
center the text in several cells or change their font. Therefore, it’s important to become proficient
at selecting multiple cells. Table 2.1 shows the most common selections.

Table 2.1: Common mouse selection methodss.

Desired selection Method

single cell Click the cell.
range of cells Click the first cell in the range, and then drag it to the last cell.
single column Click the column letter.
adjacent columns Click the first column letter and drag it to the last column

letter.
single row Click the row number.
adjacent rows Click the first row number and drag it to the last row number.
all cells in worksheet Click the button above row 1 and to the left of column A, or

use the shortcut CTRL-A

You can also use the Shift key or the CTRL key to modify selections:

SHIFT key

The Shift key allows you to select a contiguous range.

• To select a rectangular range, click one corner cell, hold down the Shift key, and then click
the diagonally opposite corner cell.

• To select adjacent columns, select the first column, hold down the Shift key, and then select
the last column.

• To select adjacent rows, select the first row, hold down the Shift key, and then select the
last row.

CTRL key

The Ctrl key allows you to select non-contiguous ranges. Select the first cell, range, row, or
column, hold down the Ctrl key, and then select the other cells, ranges, rows, or columns.

INFO Note

1. You can only make selections when the mouse pointer is a thick plus sign .

2. The selected area is highlighted, except for the first cell you clicked. This cell remains
the active cell and has a white background.

3. Dragging from bottom to top or right to left is generally easier than the reverse.

Indicating areas

You can use cell addresses to specify adjacent ranges. A few examples:
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• A2:C7 represents the rectangular range of cells from A2 to C7. Always start with the
cell address of the upper-left corner, followed by a colon, and then the address of the
bottom-right corner.

• B:E represents columns B through E.
• 3:9 represents rows 3 through 9.

2.8 Cell: Content and Format

A cell has content and a format. It’s crucial to understand the difference between these, as
confusion often leads to errors.

Example 2.1. Content - Format

Cells A1:A10 all contain the number 40299. Therefore, these cells have the same content but
appear different due to different formatting.

Figure 2.3: Cells with identical content and different formatting.

Looking at the figure it is difficult to see what the format and what the content is. Content and
formatting are two different things.

Exclamation Important

Make sure that you don’t type the formatting when entering data in a cell.
For example, if you type 40.299 hours in cell A9, then it is considered as text and not as
a number. And because it is a text you cannot calculate with the content.
It is possible to only enter the number and then format the cell so that it has the appearance
as shown. The content of the cell is then a number with which you can make calculations.
The preferred method is to first enter the content in the cell and give the cell
the desired format after that.

2.9 Printing worksheets

Things that must be done to make a good print of a worksheet.

Most worksheets with calculation models will be printed. When printing, you have many options
available to customize the page layout. For example, you can choose headers and footers, margins,
portrait or landscape orientation, the layout of the pages, etc.
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It is recommended that before you print, you should first take a look at the print preview on the
screen. From there you can then change several settings before the actual printing.

For making a print choose File > Print.

From here you can select what printer to use and what worksheets to print. By default, only the
selected worksheet will be printed. But you can also choose to print multiple worksheets and
even the entire workbook.

2.9.1 Print Preview

The preview shows you how the printed page will look like and gives you options to change
several settings.

To judge if a print will look good, it is recommended to look at the print preview first. From
there you can easily change some print settings.

Task 2.6. File: Personnel.xlsx

1. Open the file.

2. Choose File > Print.

A preview of the print and possibilities to change settings are displayed.

• If you want to see the margins, then click on the button Show Margins at the bottom right
corner of the window.

• By clicking on Page Setup you get a dialog box with tabs with a lot of print options.

2.9.2 Page Setup

The Page Setup dialog box contains four tabs with various print options. The most common
options are discussed here.

Page

Page orientation (Portrait or Landscape) is important.

The Scaling options are very useful. Adjust to allows manual customization of the number of
pages. Fit to lets Excel automatically scale the printout to a specified number of pages.

Margins

Here, you can set the top, bottom, left, and right margins, as well as the header and footer
distances from the page edges. These distances should be less than the corresponding margins to
avoid overlap.
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Figure 2.4: Print Preview.
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Figure 2.5: Settings for the page.
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Figure 2.6: Settings for the page margins.
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Figure 2.7: Settings for header and footer.

Figure 2.8: Content and format of header and footer.
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Header/Footer

Clicking the arrow in the header and footer boxes lets you select from predefined texts or choose
(none) to omit them. To create a custom header or footer, click the custom text button to open
a dialog box for typing and formatting text.

Headers and footers have left, center, and right sections. You can enter text in each section and
use the available buttons to insert predefined content, such as:

• Page Number
• Number of Pages
• Date and Time
• File Path, File Name, and Sheet Name

Sheet

Figure 2.9: Settings for the sheet.

Worksheets often have titles in the first row(s) or column(s). If the worksheet spans multiple
pages, you can specify how these rows and/or columns should appear on each page.

An interesting option is to print the worksheet’s gridlines.

INFO Note

Page Setup options are also accessible via Page Layout > group Page Setup.
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2.9.3 Page Breaks

Only a limited number of rows and columns fit on a printed page. Excel automatically inserts
horizontal and vertical page breaks based on factors like paper size, margins, row heights, column
widths, and font. You can also manually insert, move, or delete page breaks.

Page Preview

While you can work with page breaks in Normal view, Page Break Preview is recommended.
This view shows how page orientation and formatting changes affect automatic page breaks. For
example, you can see how changing row height or column width alters the placement of breaks.

Choose View > Page Break Preview (group Workbook Views).

This view also displays the page order, which defaults to down, then across. You can change this
order in Page Setup.

To move page breaks, drag them to a new location with the mouse.

To return to Normal view, choose View > Normal (Workbook Views group).

Inserting Page breaks

To insert page breaks manually:

• Horizontal page break: Select the row where the new page should begin.
• Vertical page break: Select the column where the new page should begin.

Then choose Page Layout > Breaks (Page Setup group) > Insert Page Break.

Deleting Page breaks

You cannot remove automatically generated page breaks. You can only remove manually inserted
breaks. To do this:

• Horizontal page break: Select the row below the page break.
• Vertical page break: Select the column to the right of the page break.

Then, choose Page Layout > Breaks (Page Setup group) > Remove Page Break.

2.10 Shortcuts cell movement

Table 2.2: Keyboard shortcuts for cell movement.

Shortcut Active cell becomes

Arrow Up One cell up
Arrow Right One cell right
Arrow Down One cell down
Arrow Left One cell left
CTRL arrow right Rightmost cell in the current data region, or the last cell in the

row
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Shortcut Active cell becomes

CTRL arrow left Leftmost cell in the current data region, or the first cell in the
row

CTRL arrow up Topmost cell in the current data region, or the first cell in the
column

CTRL arrow down Bottommost cell in the current data region, or the last cell in
the column

Home First cell in the row
CTRL Home First cell in sheet (A1)
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3 Data Entry and Editing

OBJECTIVES

• Entering data.
• Language dependent number separators.
• The difference between content and formatting of a cell.
• Inserting rows and columns.
• Copying data to other places
• Entering data conntaining a pattern.

Entering data (text, numbers, formulas) is one of the main activities in Excel. In short, it
involves:

1. Select a cell.
2. Start typing.
3. Press the Enter key.

Exclamation-Triangle Warning

Be aware that if the cell already contains content, this content will be overwritten.

After you press the Enter key, the cell cursor automatically moves down one cell.

3.1 Language-dependent number formats

Separators for decimals and thousands depend on the Windows language settings but can be
changed in Excel. By default, Excel uses the number formats defined in Windows, with these
characters:

English Decimal separator period (12.34)

Thousands separator comma (12,345)

Dutch Decimal separator comma (12,34)

Thousands separator period (12.345)

To change these settings permanently, you must do so through the regional settings in the
Windows Control Panel.

INFO Note

You can temporarily change these settings in Excel. To do this:

1. Click File > Options > Advanced
2. In the “Editing options” section , uncheck Use system separators.
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3. Enter the new separator in the Decimal separator and Thousands separator boxes.

To revert to the system separators, check the Use system separators box again.

3.2 Data entry examples

A simple exercise in data entry.

Task 3.1.

1. Select cell A1.

2. Type home and press Enter.

The word “home” is left-aligned in the cell and the active cell moves down to A2.

3. Type Sales 1e quarter and press Enter.

The text is left-aligned and appears to extend beyond the cell boundaries. However, the text is
fully contained in cell A2; it only appears to overlap cell B2 because B2 is empty. The active
cell is now A3.

4. Type 89 and press Enter.

The number is right-aligned in cell A3. The active cell is now A4.

5. Type 12.34 and press Enter.

The number is right-aligned in cell A4. The active cell is now A5.

6. Type 5,6 and press Enter.

The content of cell A5 is left-aligned. The comma causes Excel to interpret the entry as text,
which is why it’s left-aligned. The active cell is A6.

7. Type 1/2/2011 and press Enter.

The date is right-aligned. Excel interprets dates as numbers and applies a special date format.
The active cell is now A7.

8. Type =2+3 and press Enter.

The cell displays the number 5. Excel interprets entries starting with = as formulas, calculates
the result, and displays it. The cell’s content is the formula, not the result. The active cell is
now A8.

9. Select cell B2, type 10% and press Enter.

The content in cell B2 is right-aligned. The percent sign tells Excel to interpret the data as a
number. The actual content of this cell is 0.1, which is formatted and displayed as a percentage.
Because cell B2 is no longer empty, the full text in cell A2 is now truncated in the display.

10. Select cell A2.
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3 Data Entry and Editing

Figure 3.1: The active cell is A2 and the formula bar shows the entire content of this cell.

The formula bar shows the complete text entered in the cell.

You can adjust the column width to display all the text in cell A2.

Summary

• Text is left-aligned by default.
• Numbers are right-aligned by default.
• Commas and periods have different meanings in numbers.
• Formulas always begin with the = character.
• Dates are treated as numbers and formatted as dates.
• Numbers with a percent sign are treated as numbers and formatted as percentages. The

cell content is the numerical equivalent (e.g., 10% is stored as 0.1).
• A cell has content and a format. What you see isn’t always the actual content.

3.3 Editing cell content

You can edit cell data in one of these ways:

• Double-click the cell. The cursor appears in the cell, allowing you to edit the content
directly.

• Select the cell and press F2. The cursor moves to the end of the cell content for editing.
• Select the cell and click in the formula bar to position the cursor for editing.

When a cell is in edit mode, the status bar (bottom left) changes from “Ready” to “Edit.” Three
icons also appear to the left of the formula bar:

These icons allow you to undo, confirm, or insert a function.

You must presse Enter to finalize changes and return to “Ready” mode.

3.4 Undoing changes

You can undo most actions in Excel using the Undo and Redo buttons on the Quick Access
Toolbar.

Undo Reverses the last action. Clicking it repeatedly undoes previous actions. The
dropdown arrow next to the button displays a list of recent actions. Clicking an action in
the list undoes all actions up to and including that one.
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Redo Reverses the effect of the Undo action. The dropdown arrow (if available) shows a
list of undone actions that can be redone.

3.5 Inserting rows and columns

You’ll often need to insert rows or columns within existing data. The process is the same for
both.

1. Right-click the row or column header.
2. Choose Insert.

To insert multiple rows or columns, select the desired number of rows/columns, right-click, and
select Insert. The new rows or columns are inserted before the first row or column of your
selection.

3.6 Copy and Paste

Copying cell content is a common task in Excel. You can copy a single cell or an entire range.
By default, Excel copies both the content and formatting of the cells. However, you can choose
to copy only the content or only the formatting. When you copy a formula with cell references,
the references adjust to the new location.

Task 3.2. File: Cellformat.xlsx

1. Open the file.
2. Select the range A1:B13.
3. Choose Home > Copy (Clipboard group).
4. Select the upper-left cell of the destination, for example, D20.
5. Choose Home > Past (Clipboard group.

3.7 Auto fill

How to quickly enter data that follows a pattern.

Excel provides several ways to quickly fill rows or columns with data that follows a pattern or is
based on a list. Excel has built-in lists for days of the week and months of the year, and you can
create custom lists in Excel’s options. You can also enter a pattern that Excel recognizes and
continues. Often, two values are enough for Excel to identify the pattern.

You can use the fill handle to quickly enter data series. The fill handle is the small black square
in the lower-right corner of a selected cell or range. When you hover the mouse pointer over the
fill handle, the pointer changes from to , and you can then drag to fill.

Figure 3.2: Fill handle.

The following exercise demonstrates using a built-in list and pattern recognition. The table that
follows provides examples for further experimentation.
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Task 3.3. Built-in list

1. Create a new worksheet.

2. Select cell A1 and type “January”.

3. Select cell A1 again. Position the mouse over the fill handle of cell A1. Press and hold the
left mouse button, drag down to cell A12, and then release the mouse button.

.

The range A1:A12 is filled with the months of the year. You can start with any month, and the
sequence will repeat if you continue dragging.

Pattern recognition

4. Select cell B1 and type the number 1.

5. Select cell B2 and type the number 2.

6. Select the range B1:B2 and drag the fill handle down several cells. .

The range is filled with the numbers 1, 2, 3, 4, 5, and so on.

Table 3.1 shows examples for you to experiment with.

Table 3.1: Examples of pattern recognition.

Starting values Auto fill series

1, 3 5, 7, 9, 11, …
2, 4 6, 8, 10, 12, …
3, 6 9, 12, 15, 18, …
2010, 2011 2012, 2013, 2014, …
09:00 10:00, 11:00, 12:00, 13:00, …
Jan Feb, Mar, …
Jan, Apr Jul, Oct, Jan, Apr, …
Monday Tuesday, Wednesday, …
Mon Tue, Wed, …
Q 1 Q 2, Q 3, Q 4, Q 5, …
1e period 2nd period, 3nd period, …
article 1 article 2, article 3, article 4, …
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4 Formatting Worksheet and Data

OBJECTIVES

• The importance of selecting fbefore formatting.
• Adjusting column width and row height.
• Formatting numbers and text.
• Predefined formatting styles.
• Copying cell formatting.
• Conditional formatting.

Excel provides many options to change the appearance of a worksheet and the data in its cells,
enhancing readability and presentation.

You can apply formatting (e.g. font type) to the entire worksheet, individual cells, or cell ranges.
The process is generally the same but depends on the selection.

Exclamation Important

Always select first, then apply the format.

To select the entire worksheet, click the button to the left of the first column and above the first

row:

4.1 Column Width

A column might be too narrow to display the entire cell content. If the content is text, you’ll
only see the portion that fits. If it’s a number, you’ll see hash marks: ####.

Column width can be set from 0 to 255, representing the number of characters that fit in a cell
with the default font. The default column width is 8.43, or about eight characters in the default
font. A width of 0 hides the column.

You can adjust column width in several ways:

• Double-click the right edge of the column header. The column width automatically adjusts
to the longest text in the column.

• Drag the column edge: Position the mouse pointer over the right edge of the column header,
press and hold the left mouse button, and drag the edge to the desired width. Excel
displays the current width in a small tooltip while dragging.

• Use the Column Width dialog box: Right-click the column header and select Column
Width from the context menu. Enter the desired width and click OK.
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Figure 4.1: Adjusting column width through dragging

Figure 4.2: Specifying column width

• Use the Home tab: Select a cell in the column you want to adjust Then, choose Home >
Format (group Cells) > Column Width…. This opens the same dialog box.

INFO Note

1. To adjust multiple columns simultaneously, select them using the SHIFT-key or
CTRL-key.

2. To change the width of all columns in the worksheet, use Home > Format (Cells
group) > Default Width...

4.2 Row Height

Row height usually adjusts automatically to fit the data. However, you might need to adjust it
for formatting purposes. Row height can range from 0 to 409, measured in points (1 point is
about 0.035 cm). The default row height is 12.75 points (about 0.4 cm). A row height of 0 hides
the row.

You can adjust row height in several ways:

• Double-click the bottom edge of the row header. The row height automatically adjusts to
fit the content.

• Drag the row edge: Position the mouse pointer over the bottom edge of the row header,
press and hold the left mouse button, and drag the edge to the desired height. Excel
displays the current height in a tooltip while dragging.

Figure 4.3: Adjusting row height through dragging

• Use the Row Height dialog box: Right-click the row header and select Row Height… from
the context menu. Enter the desired height and click OK.
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Figure 4.4: Specifying row height

• Use the Home tab: Select a cell in the row you want to adjust. Then, choose Home >
Format (Cells group) > Row Height…. This opens the same dialog box.

INFO Note

To adjust the height of multiple rows at once, select them using the SHIFT-key or CTRL-key
.

4.3 Font

The Font group (Home tab) provides commands to change the appearance of text in cells. To
apply these changes, first select the cell(s) and then use the command button. The options in
this group are:

• : A dropdown list to choose the font.

• : A dropdown list to choose the font size.

• : Increases or decreases the font size in 2-point increments.

• : Toggles Bold, Italic, or Underline. The underline style can be specified using the
dropdown arrow.

• : A dropdown palette to choose the font color.

• : A dropdown palette to choose the cell background color.

4.4 Cell Borders

Borders are often used to visually group cells, such as placing a line above a total. Borders
enhance the layout of a worksheet.

To add borders to cells:

1. Select the cell(s).

2. Choose Home > Borders dropdown arrow (Font group).

3. Choose the desired border style from the list.

If the desired border style isn’t in the list, click More Borders…. This opens the Format Cells
dialog box with the Border tab selected.
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Figure 4.5: List with border styles.
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4.5 Cell Alignment

Cell alignment controls how content is positioned within a cell, both horizontally and vertically.
By default, content is bottom-aligned vertically. Text is left-aligned, numbers are right-aligned,
and logical values (TRUE or FALSE) are center-aligned horizontally. You can change these
defaults, as shown in Figure 4.6.

Figure 4.6: Alignment examples.

To apply specific alignment, first select the cell(s) and then click an alignment button in the
Home > Alignment group.

Figure 4.7: Group alignment on the ribbon.

The buttons are self-explanatory; tooltips appear when you hover over them.

The example uses these options:

Vertical alignment Options are top, middle, and bottom (cells A1:A3).

Horizontal alignment Options are left, center, and right (cells A5:A7).

Indentation Options are increase indent and decrease indent (cells A10:A12).

Orientation Predefined rotation options (cells D13:F13 and B14).

Wrap Text Displays text on multiple lines within a cell, increasing row height and reducing
horizontal space (cells D3:F3).

INFO Note

If all wrapped text isn’t visible, the row might be set to a specific height. To allow the row
to adjust automatically, choose Home > Format (group Cells) > AutoFit Row Height.
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Merge & Center Combines selected cells into a single larger cell and centers the content. Often
used for titles that span multiple rows or columns. Cells can be merged horizontally and
vertically (cells B14:B16).

4.6 Formatting Numbers

Numbers can be displayed in various formats, including with or without decimal places, currency
symbols, and date or time separators. You can also create custom formats.

Excel automatically formats some numbers as you enter them:

• Typing 19% displays the number as 19% (right-aligned), but the cell content is 0.19.

• Typing €123,45 displays it as € 123,45 (right-aligned), and the cell content is 123,45.

• Typing 1/2 displays it as a date (e.g., 2-Jan).

INFO Note

Excel stores dates and times as serial numbers, starting with January 1, 1900, as 1. So, 1/2
becomes a date, and the cell content is a serial number representing that date (e.g., 41276).

To quickly format numbers, use the commands in the Number group (Home tab).

Figure 4.8: Number group on the ribbon.

Common formatting buttons include:

• : Accounting Number Format, adds a currency symbol (dropdown arrow for options).

• : Percent style, formats as a percentage

• : Comma style, adds a thousands separator.

• : Increase Decimal, adds decimal places.

• : Decrease Decimal, removes decimal places.

The current cell format is displayed at the top (e.g., “General”), with a dropdown arrow for
predefined styles.

For more control, click More Number Formats… to open the Format Cells dialog box with the
Number tab selected, where you can define custom formats.

This example shows various number formatting options:

Task 4.1. File: Numberformat.xlsx

1. Open the file.

2. Format the worksheet as shown, using the Number group (Home tab) options.
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Figure 4.9: List with styles for formatting numbers.

Figure 4.10: Example formatting numbers.
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4.7 Copying and clearing Formats

Cell format and content are stored separately, allowing you to copy or delete them independently.

Copying format

The fastest way to copy a cell’s format is using the Format Painter button.

To use it:

1. Select the cell with the desired format.
2. Choose Home > (Clipboard group). The mouse pointer changes to a brush

( ).
3. Select the destination cell(s).
4. Release the mouse button.

INFO Note

Double-clicking the Format painter button allows you to apply the format to multiple cells.
Press Esc or click the Format painter button again to cancel.

Clearing Formats

To remove cell formatting:

1. Select the cell(s).

2. Choose Home > Clear (group Editing) > Clear Formats.

Figure 4.11: Clear formats on the ribbon.

INFO Note

1. You can clear the format, content, or both.

2. The DELETE key only clears the cell’s content, not its formatting.
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4.8 Table Styles

To practice formatting a list using predefined styles:

Task 4.2. File: Personnel.xlsx

1. Open the file.

2. Select any cell within the data area.

3. Choose Home > Format as Table (Styles group).

4. Select a style, e.g. Table Style Medium 4.

Figure 4.12: Dialog box Format As Table.

5. Click OK.

Figure 4.13: Result table formatting.

4.9 Conditional Format

Conditional formatting applies formatting to cells based on specific conditions. For example, you
can highlight cells with values less than 6 in red. The formatting is applied when the condition(s)
are met; otherwise, the “regular” format is used.

Conditional formatting can use number formats, fonts, borders, and background colors.

Conditions can compare cell values to a fixed value, a range of values, or other criteria like
deviation from the average or the top/bottom values. You can apply multiple conditions.
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4.9.1 Formatting with One Condition

A teacher wants to highlight failing grades (less than 6) in light red.

Task 4.3. File: Marks.xlsx

1. Open the file.

2. Select all the grades.

3. Choose Home > Conditional Formatting (group Styles) > Highlight Cells Rules > Less
Than… and enter the condition and format.

Figure 4.14: Conditional Formatting dialog box for cells with a value less than a certain value.

4. Click OK.

Failing grades are now highlighted in light red.

Test the formatting by changing some grades; the background color should update accordingly.

4.9.2 Formatting with Two Conditions

A sales report tracks achieved and target turnover. The task is to color-code the turnover: green
if the target is met, red if not.

Task 4.4. File: Turnover-Q1.xlsx

1. Open the file.

2. Select all the turnover data.

3. Choose Home > Conditional Formatting (Styles group) > Manage Rules….

4. Click New Rule…. The New Formatting Rule dialog box appears.

5. Select Format only cells that contain, set Cell Value to less than =B2 and choose a red fill
color as the format.

6. Click OK. The Conditional Formatting Rules Manager reappears.

7. Click New Rule and create another rule:

8. Click OK. The manager now shows both rules:

9. Click OK.

The formatting is applied.

Test the formatting by changing values to ensure the colors update.
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Figure 4.15: Rules Manager for conditional formatting.

Figure 4.16: Dialog box New Formatting Rule.

Figure 4.17: The second rule. The specified fill color is green.
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Figure 4.18: The two rules for the conditional format.

4.9.3 Formatting Top/Bottom 10%

You can create conditions based on a range of values, such as the top/bottom 10% or top/bottom
3 values.

For a car dataset, the task is to highlight the 10% of cars with the lowest fuel consumption in
green.

Task 4.5. File: Car.xlsx

1. Open the file.

2. Select the fuel consumption values (column F).

3. Choose tab Home > Conditional Formatting (Styles group) > Top/Bottom Rules > Bottom
10%… and set the values in the dialog box.

Figure 4.19: Dialog box conditional format bottom 10%. Also a percentage other than 10 can be
set.

4. Click OK.
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4.9.4 Removing Conditional Formatting

To remove conditional formatting:

1. Select the cell(s).

2. Choose tab Home > Conditional Formatting (Styles group) > Clear Rules > Clear Rules
from Selected Cells.

4.9.5 Finding Conditional Formatting

To find cells with conditional formatting:

Choose tab Home > Find & Select (Editing group) > Conditional Formatting.

Excel selects all cells with conditional formatting or displays “No cells were found.”
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OBJECTIVES

• Create formulas.
• Set up a calculation model.
• Copy formulas and understand absolute and relative cell addresses.
• Create formulas that evaluate to TRUE or FALSE.
• Naming cells and use the names.

One of the most important aspects of working with Excel is performing calculations, which
requires using formulas. To work effectively and efficiently with formulas, it’s crucial to plan the
worksheet layout carefully. This can save significant time and effort.

Calculations are performed using formulas. Formulas contain numbers or references to cells
containing numbers. Operators, such as +, -, *, /, and ^, indicate the type of calculation.

Exclamation Important

A formula must always begin with the = character. While you can start a formula with a +,
Excel will automatically convert it to = after you enter the data.

To enter a formula, start by typing =, then enter the calculation as you would on a calculator.
Instead of numbers, you can use cell addresses or cell names that refer to cells containing numbers.
You can also select cell addresses with the mouse instead of typing them.

Table 5.1 shows the symbols (operators) used in calculations.

Table 5.1: Operators.

Symbol Meaning Example Result

+ Addition =4+5 9
- Subtraction =29-6 23
* Multiplication =7*8 56
/ Division =6/2 3
^ Exponentiation =2^3 8
() Parentheses for operator precedence =30-(4+6) 20

Task 5.1. Practice with these examples in a worksheet.

5.1 Your First Formulas

This exercise demonstrates a simple calculation, as shown in Figure 5.1. The worksheet contains
three input values:
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• C1: Purchase amount
• B2: Profit margin
• B5: VAT rate

Cells C2, C3, C5, and C6 contain formulas that automatically update when you change the
values in C1, B2, or B5.

Figure 5.1: Example calculation purchase, profit and selling.

Task 5.2. Calculate Sellings

1. Create a new worksheet in a new workbook.

2. Enter the text labels shown in column A. Don’t worry if some text extends beyond the
column width for now. You can adjust the column width later if desired.

3. Enter the following values:

• B2: 25%
• B5: 21%
• C1: 4000

4. In cell C2, enter the formula =B2*C1. After pressing Enter, the result (1000) appears in
C2 (the calculated profit).

5. In cell C3, enter the formula =C1+C2. The result (5000) appears in C3.

6. In cell C5, enter the formula =B5*C3. The result (1050) appears in C5.

7. In cell C6, enter the formula =C3+C5. The result (6050) appears in C6.

8. Experiment by entering different values for the purchase amount, profit margin, and VAT
rate.

Observe how all the calculated values update automatically.

5.2 More with Formulas

The worksheet in Figure 5.2 calculates wages by multiplying hours worked by an hourly rate.
The total wages are calculated by adding individual wages.

Task 5.3. File: Wages.xlsx Calculate Working Hours

1. Open the file.

2. Enter the correct formulas in the “Amount” column:

• D2: =B2*C2
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Figure 5.2: Example calculation hours, hour rate and totals.

• D3: =B3*C3
• D4: =B4*C4
• D5: =D2+D3+D4

5.3 Calculation Models

Excel can perform a wide variety of calculations. Designing effective calculation models, especially
for larger and more complex tasks, requires careful planning.

A calculation model typically involves three types of cells:

Input Cells where users enter variable values.

Calculations Cells containing formulas that perform calculations using the input values.

Output Cells that display the formatted results of the calculations.

The data flow in a model progresses from input to calculations and then to output. However,
it’s often best to plan the model in reverse: start with the desired output, then determine the
necessary calculations, and finally identify the required input.

Here are some guidelines for designing calculation models in Excel:

1. Separate Input, Calculations, and Output:

• For smaller models, you can use different sections within a single worksheet (e.g.,
input at the top).

• For larger models, use separate worksheets for each type of cell.

Figure 5.3: Design of a calculation model.At the left 1 worksheet, at the right 3 worksheets.

2. Organize Worksheets Logically:

• Design worksheets to be read from top to bottom and left to right, like a book.
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3. Identify Variables:

• Place changeable values (e.g., item prices) in individual cells. These values are the
model’s variables.

4. Use Cell References in Formulas:

• Minimize the use of direct numbers in formulas. Instead, refer to cells containing
those numbers. This also applies to values that change infrequently, such as a VAT
rate.

5. Label Cells Clearly:

• Provide explanatory text in adjacent cells (to the left or above) to describe the purpose
of cell content.

6. Use Headers:

• Include headers above columns and to the left of rows containing numbers.

7. Standardize Formulas:

• If possible, use similar formulas within a row or column to facilitate copying.

8. Break Down Complex Formulas:

• Divide complicated formulas into smaller parts to calculate and check intermediate
results (e.g., subtotals). This helps prevent errors.

9. Name Worksheets Appropriately:

• Use descriptive names for worksheets in models with multiple sheets.

10. Document Your Model:

• Include documentation, especially for larger models, in separate worksheets.

5.4 Copying Formulas

Copying formulas to other cells is very useful, especially when the formulas are similar. In
@fig-formula-copy, the formulas in A3, B3, C3, and D3 are nearly identical. You can enter the
formula once in A3 and then copy it to B3:D3.

A (cell)range is a group of cells that you can refer to in a formula. Ranges are typically rectangular
and defined by the cell in the upper-left corner, a colon, and the cell in the lower-right corner
(e.g., B2:E7, B3:E3, D2:D6).

Figure 5.4: Example with copyable formulas.

Since formulas often contain cell references, it’s important to understand how these references
behave when you copy a formula. There are two types of cell references:
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• Relative: Cell references adjust to their new location.

• Absolute: Cell references remain fixed.

Use dollar signs ($) to make a cell reference absolute. You can make the column letter, the row
number, or both absolute. Table 5.2 shows the different possibilities.

Table 5.2: Examples of cell addresses.

Type Example

Relative address B1
Absolute column and absolute row address $B$1
Absolute column and relative row address $B1
Relative column and absolute row address B$1

INFO Note

When you copy a formula, the absolute parts of cell references remain unchanged, while the
relative parts are adjusted.

You can change the type of cell reference in these ways:

• Type the dollar signs directly in the cell address.

• Place the cursor within the cell address and press the F4 key repeatedly to cycle through
the four reference types.

5.4.1 Copy Rules

When you copy formulas with cell references, Excel applies these rules:

• When copying to the left or right, the column letter changes.

• When copying up or down, the row number changes.

• Parts of the address with a dollar sign ($) remain unchanged.

Table 5.3: Examples of copy actions.

Formula Copy action Result

=A1+B2 1 cell to the right =B1+C2
1 cell down =A2+B3
1 cell to the right and 1 cell down =B2+C3

=A$1+B$2 1 cell to the right =B$1+C$2
1 cell down =A$1+B$2
1 cell to the right and 1 cell down =B$1+C$2

=$A1+$B2 1 cell to the right =$A1+$B2
1 cell down =$A2+$B3
1 cell to the right and 1 cell down =$A2+$B3

=$A$1+$B$2 Any copy action =$A$1+$B$2
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5.4.2 Premium Table

The worksheet in Figure 5.5 shows a list of car insurance premiums. The list starts with a value
of $10,000 and a premium of $675. Subsequent values increase in increments of $1,000, and the
premium increases by $45. Use formulas to create this list for rows 6 through 20.

Figure 5.5: Premium table.

Task 5.4. File: Premium-Table.xlsx

1. Open the file.

2. Format the values as currency using Home > button Accounting Number Format (group
Number). Adjust the column widths to display all content.

3. In cell A6, enter the formula =A5+$B$1.

4. In cell B6, enter the formula =B5+$D$1.

5. Select the range A6:B6 and drag the fill handle to row 20.

5.5 True/False Formulas

Some formulas don’t perform calculations but instead compare values or test conditions. These
formulas, also called Boolean expressions, return either TRUE or FALSE.

Table 5.4 lists the operators used in Boolean expressions.
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Table 5.4: Operators for comparing two items.

Operator Meaning

= Equal to
<> Not equal to
< Less than
<= Less than or equal to
> Greater than
>= Greater than or equal to

Table 5.5 provides examples of Boolean formulas. To understand how they work, you can enter
them into cells in a worksheet. The parentheses in the formulas are not strictly required but
improve readability, so it’s recommended to use them.

Table 5.5: Examples of TRUE/FALSE formulas.

Formula Result

=(1=1) TRUE
=(1=2) FALSE
=(1<>1) FALSE
=(1<>2) TRUE
=(1<1) FALSE
=(1<2) TRUE
=(1<=1) TRUE
=(1<=2) TRUE
=(1>2) FALSE
=("a"="b") FALSE
=("a"<>"b") TRUE

Exclamation Important

Always enclose text in double quotes in Boolean operations.

Using Boolean formulas directly in cells isn’t very practical. However, they are powerful within
calculations. Excel treats TRUE as 1 and FALSE as 0, allowing you to perform calculations based
on conditions.

In the following example, the shipping cost for an order depends on the order amount.

Example 5.1. Calculate Shipping Costs

An online shop offers free shipping for orders of $25 or more. The following figure shows how a
Boolean formula calculates the shipping cost. The formula (B5<$B$2) returns TRUE (1) if the
order total (B5) is less than $25 (B2) and FALSE (0) otherwise. This result is then multiplied by
$3.50, resulting in either $3.50 or $0.

Create this example and verify its functionality by entering different values in cells B1, B2, and
B5.
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Figure 5.6: Example with a true/false formula.

5.6 Cell Names

This section describes how to use meaningful names for cells and the rules for naming them.

Using cell addresses in formulas can make them confusing and difficult to read, obscuring the
formula’s purpose. Fortunately, you can assign descriptive names to cells and ranges, allowing
for more intuitive formulas like =Sales-Purchases.

Naming Rules:

• Names must begin with a letter or an underscore (_). Subsequent characters can be letters,
numbers, or underscores. Names cannot start with a number.

• Names cannot contain spaces. Use underscores to simulate spaces (e.g., Sales_2010).

• Most symbols (commas, colons, exclamation points, etc.) are not allowed.

5.6.1 Creating Names

You can assign names to cells in several ways. The preferred method often depends on user
preference and typing speed. This task presents two methods for assigning names and three
methods for using names in formulas. You can use the same methods to name cell ranges.

Task 5.5.

1. Create a new worksheet.

2. Enter 100 in cell A1 and 275 in cell A2.

3. Select A1 and choose Formulas > Define Name (Defined Names group).

In the Name text box, you can enter the desired name. Excel may suggest a name. The optional
Comment box allows you to provide a description for future reference (e.g., for audits or
documentation).

4. Enter Purchases as the name and click OK. The name box now displays “Purchases”
instead of the cell address.

An alternative and faster way to name a cell is to enter the name directly in the name box. The
next step demonstrates this for cell A2.

5. Select cell A2. Click in the Name box, replace A2 with Sales, and press Enter.
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Figure 5.7: Dialog box New Name.

Figure 5.8: Cell A1, now with the name Purchases in the name box instead of the address.

6. Select cell A3 and enter the formula to calculate profit using one of these methods:

• Type = Sales-Purchases and press Enter.

• Type =, select A2, type -, select cell A1 and press Enter.

• Type =, choose Formulas > Use in formula (group Defined Names) > Sales, type -,
choose Formulas > Use in Formula (Defined Names group) > Purchases and press
Enter.

Cell A3 will display 175. Selecting cell A3 will show =Sales-Purchases in the formula bar,
demonstrating the improved readability of formulas with names.

5.6.2 Using Names in Existing Formulas

When you assign a name to a cell or cell range, Excel automatically uses those names in new
formulas, but not in existing ones. For example, if cell B5 contains the formula =B2+B3+B4, and
you then assign names to cells B2, B3, and B4, the formula in B5 remains unchanged.

Figure 5.9: Formula with addresses instead of names.
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However, you can easily replace the cell addresses in existing formulas with the newly assigned
names. In the example file, the cells used in the formula already have names. The following steps
demonstrate how to replace the addresses in the formula with those names.

Task 5.6. File: Office-Expenses.xlsx

1. Open the file.

2. Select cell B5.

3. Choose Formulas, click the arrow on the Define Name (Defined Names group) button and
select Apply Names.

Figure 5.10: Dialog box apply names.

4. Select all names and click OK. The formula in cell B5 will change to =Inventory+Advertising+Officecosts.

INFO Note

To select multiple names, hold down the Ctrl key.

5.6.3 Managing Names

Excel provides tools for managing names, including viewing a list of all names in the workbook,
and changing or deleting names. These tools are essential for managing names, especially in
larger workbooks with many named cells and ranges.

Task 5.7. File: Expenses.xlsx

1. Open the file.

2. Choose Formulas > Name Manager (Defined Names group).
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Figure 5.11: Name Manager.

INFO Note

The Name Manager dialog box allows you to perform several operations:

• Deleting aname: Select the name and click Delete.

• Edit a name: Select the name and click Edit.

• Add or edit a comment: Select the name and click Edit.

• Create a new name: Click New.

5.6.4 Documenting Names

It’s helpful to create a list of all defined names and their corresponding cell addresses for
documentation purposes. Excel can generate this list on a worksheet, although the procedure is
not immediately obvious. It’s recommended to create the list on a new worksheet.

Task 5.8. File: Expenses.xlsx

1. Open the file.

2. Create a new sheet and select cell A1.

3. Choose Formulas > Use in formula (Defined Names group) > Paste Names > Paste List.

5.7 Case Study: Price Calculation for Items

This case study demonstrates creating a calculation model using formulas and copying formulas.
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Figure 5.12: List of cell names and addresses.

An airport shop sells items both tax-free and with 21% VAT. Tax-free prices are in U.S. dollars,
but customers can pay in euros. Prices with VAT are always in euros. Figure 5.13 shows a portion
of the price table. The item numbers and dollar prices are simplified for practice purposes. The
goal is to create this table efficiently. Only general guidance is provided, not detailed steps.

Figure 5.13: Price table
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OBJECTIVES

• Types of functions and the syntax of a function.
• Entering a function manually and with the Wizard.
• Nesting of functions.

Excel has more than 300 built-in functions to perform various operations. These functions are
organized into categories, such as:

• Database
• Date & Time
• Financial
• Information
• Logical
• Statistical
• Engineering
• Text
• Math & Trig
• Lookup & Reference

Categories can be helpful when searching for a specific function. For example, to find a function
that calculates loan repayments, you can look in the Financial category. Other categories include:
All, Most Recently Used, and User Defined.

Most functions require you to specify the values or cell contents they should use in the calculation.
These are called arguments.

All Excel functions follow the same structure (syntax), as shown in Figure 6.1.

Figure 6.1: The structure (syntax) of a function.

• They begin with an equal sign =.

• Followed by the function’s name.

• Then, parentheses enclose the arguments, separated by commas.

• Arguments can be numbers, text, operators, or even other functions.
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INFO Note

1. The argument separator (comma or semicolon) depends on your Windows regional
settings. English versions typically use a comma, while other language versions (e.g.,
Dutch) may use a semicolon. You can change this in the Windows Control Panel.

2. Function names and argument separators vary depending on the language version of
Microsoft Office.

This chapter discusses some commonly used functions through practical examples.

6.1 Entering Functions

You can enter functions using the Function Wizard or manually. The best method depends
on your experience level and whether you already know the function’s name and syntax. Both
methods are explained below. The Function Wizard is used in the examples, but you can also
enter functions manually.

6.1.1 Function Wizard

The Function Wizard is helpful for beginners and less experienced users. You can open it in two
ways:

• Click the 𝑓𝑥 Insert function button at the beginning of the formula bar.
• Go to Formulas > Insert Function (Function Library group)

The Insert Function dialog box will appear:

Figure 6.2: Dialog box insert function.
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To quickly find the right function, first select a function category from the drop-down list. If
you’re unsure which category to choose, select All.

Select the desired function, such as COUNTIF, and click OK. The Function Arguments dialog
box for the selected function will appear.

Figure 6.3: Function arguments for function COUNTIF.

In this dialog box, you can specify the function’s arguments. The required arguments depend on
the selected function. You can type the arguments directly, or for cell addresses, you can select
the cells in the worksheet using the mouse.

INFO Note

For detailed help on the function, click the Help on this function link.

6.1.2 Autocomplete Functions

If you are familiar with a particular function, its correct spelling, and the types of arguments it
requires, you can type the function and its arguments directly into the formula bar. This is often
the most efficient method.

Excel’s Autocomplete Functions feature is very useful for manual entry. When you type an =
sign and the first few letters of a function in a cell or the formula bar, Excel displays a drop-down
list of all valid entries that begin with those letters. Icons indicate the entry type, such as a
function or cell/table reference. A screen tip also provides a brief description of each function.

Continue typing the function name to narrow the list, or use the arrow keys to select the function
from the list. After selecting the desired function, press Tab to insert the function name and an
opening parenthesis into the cell.

Once you insert the function and the opening parenthesis, Excel displays another screen tip
showing the function’s arguments. The argument in bold is the one you are currently entering.
Arguments in parentheses are optional.

Example 6.1. Autocomplete
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Figure 6.4 illustrates an example. In the first image, the letter c has been entered. The list box
displays all functions that start with c.

In the second image, ou has been added. The list now shows all entries that start with cou. A
screen tip displays information for the selected function, COUNTIF.

Pressing Tab results in the third image. This function requires two arguments.

Figure 6.4: Example autocomplete function.

6.2 Autosum

Since addition is a frequently used operation, Excel provides the Autosum button on the ribbon
in the Editing group (Home tab) for quick entry. Using the Function Wizard for addition often
requires multiple mouse clicks, so Autosum can save time.

The arrow next to the Autosum button provides a drop-down list with quick access to the
Average, Count Numbers, Max, and Min functions.

Task 6.1.
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1. Start with a new worksheet.

2. Enter the following numbers in cells A1:A6: 120, 121, 122, 123, 124, and 125.

3. Select cell A7, and then click the Autosum button.

Figure 6.5: Selection borders around cells to sum.

Excel places a selection border around the cells that it assumes you want to sum. If this is not
the correct range, use the mouse to select the desired area.

4. Confirm the selection by doing one of the following:

• Click the Autosum button again.
• Click the Enter button, , in the formula bar.
• Press the Enter key on the keyboard.

Cell A7 will display the result 735. The formula in cell A7 is =SUM(A1:A6), which is shorter
and clearer than =A1+A2+A3+A4+A5+A6.

6.3 Mathematical Functions

The mathematical functions category is quite extensive. In addition to the common SUM
function for adding numbers, this category includes functions for various calculations, such as
exponentiation, square roots, PI, logarithms, and trigonometry.

Functions for rounding numbers are common. Excel provides thirteen rounding functions, which
can make it challenging to choose the appropriate function. For example, the ROUND function
rounds a number up or down to a specified number of decimal places. Other functions round to
the nearest multiple of a given number or to the nearest integer.

Task 6.2. File: Rounding.xlsx

Figure 6.6 shows the results of several rounding functions. Column C displays the formulas used
in column B.

1. Open the file.

2. Enter the appropriate formulas in cells B3:B9 using the Function Wizard.
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Figure 6.6: Examples of rounding functions.

6.4 Statistical Functions

The statistical category contains functions for statistical analysis, such as average, count, minimum,
and maximum.

Task 6.3. File: Statistics.xlsx

Figure 6.7: File Statistics.xlsx to practice statistical functions.

1. Open the file.

2. In cells B9 to B12, perform the calculations using the functions from the table below. These
functions are in the Statistical category.

• B9: AVERAGE
• B10: COUNT
• B11: MIN
• B12: MAX

INFO Note

The argument is always the range B1:B8. Although you can type this range in the Function
Arguments dialog box, it’s more convenient to place the cursor in the box for the first
argument and then select the range B1:B8 in the worksheet with the mouse.
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6.5 Date and Time Functions

The Date and Time category provides functions for working with dates and times. Because
Excel stores dates and times as numbers internally, you can perform calculations with them. The
American date format is Month/Day/Year.

Task 6.4. File: Date.xlsx

Figure 6.8: Calculation with dates and times..

1. Open the file.

First, extract the year, month, and day values from the start and end dates.

2. Use the YEAR, MONTH and DAY functions to determine the values in cells C2, D2, and E2.
The argument for these functions is cell B2.

3. Select C2:E2 and drag the fill handle one row down.

4. Select cell B4 and enter the formula =B3-B2. The result is 27.

The NETWORKDAYS function calculates the number of workdays between a start date and an end
date. It excludes weekends and dates specified as holidays. You can use an optional argument to
specify holidays.

5. Select cell B5, and calculate the number of workdays. Enter the cell addresses for the start
and end dates; leave the holidays box empty.

6. Similarly, calculate the hours, minutes, and seconds from the start and end dates using the
HOUR, MINUTE, and SECOND functions.

7. Calculate the time difference in B10 using a formula.

6.6 Logical Function IF

Logical functions work with the results TRUE or FALSE. The most common logical function is the
IF() function. In simple terms, this function works as follows:

=IF(condition, value_ if_true, value_if_false)

The condition is a logical test that evaluates to either TRUE or FALSE.
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INFO Note

For more than one condition, you can nest IF() functions. However, nested IF() functions
can become complex and difficult to read. Consider using the logical functions AND(), OR(),
and NOT() instead.

Task 6.5. Figure 6.9 shows marks with their corresponding pass/fail status. The status is
determined automatically based on the mark. A mark less than 5.5 is considered failing.

Figure 6.9: Marks with their results.

1. Start a new worksheet and enter the numbers shown in Figure 6.9.

2. Select cell B2 and use the Insert Function to insert the IF function.

3. Complete the dialog box as shown in Figure 6.10. You can type the quotation marks around
the text, but it is not required as Excel will add them automatically.

Figure 6.10: Dialog box function IF.

4. Click OK.

5. Select cell B2 and drag the fill handle to B6.

6.7 Text Functions

This section demonstrates splitting text into different parts using four text functions.
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Excel includes functions for manipulating text. For example, you can determine the length of a
text string or extract specific parts of a string.

Figure 6.11 shows full names in column A. The goal is to extract the first and last names into
separate columns. In this example, the first and last names are separated by a space, which can
be used as a delimiter. To extract the names, you need to find the position of the space and
know the total length of the text. The text before the space is the first name, and the text after
the space is the last name.

The results are shown in columns B to E in Figure 6.11. This exercise is divided into four parts,
each using a different function.

Figure 6.11: Full names and the extracted fiirst and last names.

6.7.1 LEN

The LEN function determines the length of a text string.

Task 6.6. File: Names.xlsx

1. Open the file.

2. Select cell B2 and insert the LEN function with cell A2 as argument.

3. Drag the fill handle in B2 down to B5.

Column B now displays the length of the full names.

6.7.2 SEARCH

The SEARCH function finds the starting position of a specific character (or string) within a text.
In this case, it finds the position of the space.

Task 6.7.

1. Select cell C2 and click the Insert Function button on the formula bar.

2. Click OK.

3. Drag the fill handle in C2 down to C5.

Column C now displays the position of the first space in each name.
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Figure 6.12: Arguments for function SEARCH. Enter a space in the Find-text box. Excel
surrounds this automatically with double quotes.

6.7.3 LEFT

The LEFT function extracts a specified number of characters from the beginning of a text string.
In this example, it extracts the first name.

Task 6.8.

1. Select cell D2, insert the LEFT function, and enter the arguments as shown in Figure 6.13.

INFO Note

In the Num-chars box, specify the length of the text to extract. This is one less than the
position of the space, which is found in cell C2.

Figure 6.13: Arguments for function LEFT.

2. Click OK.

3. Drag the fill handle in D2 down to D5.
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Column D now displays the first names.

6.7.4 RIGHT

The RIGHT function extracts a specified number of characters from the end of a text string. In
this example, it extracts the last name.

Task 6.9.

1. Select cell E2, insert the RIGHT function, and enter the arguments as shown in Figure 6.14.

Figure 6.14: Arguments for function RIGHT.

2. Click OK.

3. Drag the fill handle in E2 down to E5.

Column E now displays the last names.

6.8 Nested Functions

A nested function is a function within another function, where one function acts as an argument
for the other. For example:

=ROUNDDOWN(SUM(A1:A5),0)

The following exercise uses a nested function.

Task 6.10.

1. Start a new worksheet, and enter the data shown in Figure 6.15.

2. Select cell A6, and insert the ROUNDDOWN function (from the Math & Trig category).

In the function’s arguments dialog box, the cursor will be in the Number field. It’s often helpful
to specify the number of decimal places first, and then define the range of numbers.
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Figure 6.15: Data to use with nested function.

Figure 6.16: Dialoogvenster.
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3. Place the cursor in the Num_digits field, enter 0, Then, move the cursor back to the
Number field.

4. Click the arrow in the name box on the worksheet.

A drop-down list appears, showing the names of the most recently used functions. At the bottom
of this list, you’ll see More Functions.

5. Click on More Functions. The familiar Insert Function dialog box will appear.

6. In the Math & Trig category, select the SUM function and click OK.

The Function Arguments dialog box appears. The Number1 argument already contains the value
A1:A5.

7. Click OK.

The result appears in cell A6, and the formula used is displayed in the formula bar.

Figure 6.17: Result nested function.

INFO Note

1. If you hadn’t entered the number of decimals after step 3, you would have received a
warning during nesting indicating that too few arguments were entered. You would
have had to correct this manually in the formula.

2. A faster way to work is to type the formula directly into the formula bar. As you type,
you’ll receive assistance with entering the formula. However, this method requires you
to know the names of the functions you want to use.

6.9 COUNTIF

The COUNTIF function is very useful for creating frequency tables. Figure 6.18 shows a list of
camping sites and their categories. Column E will contain the number of campsites in each
category.

Task 6.11. File: Campsites.xlsx

1. Open the file.
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Figure 6.18: Campsites by category.

Figure 6.19: Arguments for the function COUNTIF.
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2. Select cell E2, insert the COUNTIF function, and specify the arguments as shown in Fig-
ure 6.19.

INFO Note

Specifying the entire column B as the range allows you to add new rows of data to the
bottom without needing to change the formulas.

3. Click OK.

4. Select cell E2 and drag the fill handle down to E5.

6.10 SUMIF

The SUMIF function allows you to add numbers based on specific conditions. The spreadsheet
contains a list of yields for different coffee types, organized by month and region. You’ll use it to
determine the total yields per region.

Task 6.12. File: Coffee.xlsx

1. Open the file.

2. Select cell H2, insert the SUMIF function, and enter the arguments as shown in Figure 6.20.

Figure 6.20: Arguments for function SUMIF.

3. Click OK. The total yield for North region, 743140, now appears in cell H2.

4. Select cell H2 and drag down the fill handle to H5.

5. Format the numbers in H2:H5 as currency.

INFO Note

In this case, a pivot table would be an easier way to create this summary.
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6.11 Calculating Annuities

There are several ways to calculate loan repayments. This example calculates the monthly
repayment amount for a $250,000 loan with a 6% fixed annual interest rate over 15 years, using
an annuity. We’ll use the Excel function PMT, which calculates the payment for a loan based on
constant periodic payments and a constant interest rate.

Figure 6.21: Data to use for loan repayment.

Task 6.13. File: Repayment.xlsx

1. Open the file and format the cells as shown in Figure 6.21.

2. Select cell B4, insert the PMT function (from the Financial category) and enter the arguments
as shown in Figure 6.22.

Figure 6.22: Arguments for function PMT.

INFO Note

Because the period in this example is in months rather than years, the annual interest rate
must be divided by 12, and the number of years must be multiplied by 12.

3. Click OK.

INFO Note

The result -2109.64 appears. Because this is an amount to be paid (a debt), Excel displays
it as a negative number, shown in red font and with a minus sign.
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4. To change this to a positive number, insert a minus sign after the = sign in the formula.
The formula will then be =-PMT(B2/12,B3*12,B1).

6.12 Calculating Number of Periods

Suppose you take out a personal loan of €4,000 and agree to pay a monthly amount of €125.
Calculate the number of months it will take to repay the loan at a 6% fixed annual interest rate.
For this calculation, we’ll use the Excel function NPER. This function calculates the number of
periods for an investment based on periodic, constant payments and a constant interest rate.

Exclamation Important

Payments are entered as negative numbers.

Figure 6.23: Calculation of the number of periods.

Task 6.14. File: Payment_Periods.xlsx

1. Open the file.

2. Select cell B4, insert the NPER function (from the Financial category) and enter the
arguments as shown in Figure 6.24.

Figure 6.24: Arguments for NPER function.
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INFO Note

Because the period is in months and not years, the annual interest rate has been divided by
12.

3. Click OK. The result 34,95778166 appears, indicating almost 35 months.

6.13 Vertical Lookup

The VLOOKUP function searches for a specified value in the first column of a list (table) and
returns the corresponding value from another column.

Syntax: VLOOKUP(lookup-value, table-array, col-index-num, [range-lookup])

The last argument is optional and can be set to FALSE or TRUE.

• FALSE: Searches for an exact match with the specified lookup value.
• TRUE: Returns the closest match below the lookup value if an exact match is not found.

INFO Note

In most cases, it’s best to search for an exact match; otherwise, you might get incorrect
results. If you allow an approximation, the leftmost column of the table array must be in
ascending order.

Figure 6.25 shows an overview of hard drives, with the article number in the first column. Using
the VLOOKUP function, you can find the capacity, type, and price of an item by entering its article
number.

Cell D2 is the input cell for the article number you want to search for. Cells D4:D7 will contain
the lookup formulas.

Task 6.15. File: Harddisks.xlsx

1. Open the file.

2. Select cell D4 and enter the formula: =VLOOKUP($D$2,$B$11:$E$22,1,FALSE).

The error #N/A appears in the cell because there is no search value in cell D2 yet.

3. Enter the value 208 in cell D2. Now, 208 (the article number) appears in cell D4.

4. Enter the correct lookup formulas in the other three cells:

• D5: =VLOOKUP($D$2,$B$11:$E$22,2,FALSE).

• D6: =VLOOKUP($D$2,$B$11:$E$22,3,FALSE).

• D7: =VLOOKUP($D$2,$B$11:$E$22,4,FALSE).
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Figure 6.25: Overview of hard drives.

Figure 6.26: Results of VLOOKUP.
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6.14 Horizontal Lookup

The HLOOKUP function searches for a specified value in the first row of a list (table) and returns
the corresponding value from another row.

Syntax: VLOOKUP(lookup-value, table-array, row-index-num, [range-lookup])

The last argument is optional and can be set to FALSE or TRUE:

• FALSE: Searches for an exact match with the specified lookup value.
• TRUE: Returns the closest match to the left of the lookup value if an exact match is not

found.

INFO Note

It’s generally best to search for an exact match; otherwise, you might get incorrect results.
If you allow an approximation, the top row of the table array must be in ascending order.

Figure 6.27 shows an overview of shoe sizes for several people, with their names in the first row.
You can use the HLOOKUP function to find the corresponding age, height, and shoe size when you
enter a name.

Figure 6.27: Overview of shoe sizes.

Cell C2 is the input cell for the name to be searched. Cells C4:C6 will contain the lookup
formulas.

Task 6.16. File: Shoe_Sizes.xlsx

1. Open the file.

2. Select cell C4 and enter the formula =HLOOKUP($C$2,$C$8:$E$11,2,FALSE).

The error #N/A appears in the cell because there is no search value in cell C2 yet.

3. Enter the value Pietersen in cell C2. Now, 42 (the age) appears in cell C4.

4. Enter the correct lookup formulas in the other two cells:

• C5: =HLOOKUP($C$2,$C$8:$E$11;3,FALSE).

• C6: =HLOOKUP($C$2,$C$8:$E$11;4,FALSE).
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Figure 6.28: Results of HLOOKUP.

6.15 Exercises

Exercise 6.1. Computer Company Results (form001)

File: Form001.xlsx

The following table shows the results of a computer company for 2010. The company’s goal is to
achieve a gross profit per product of more than $5,000 and a realized margin of more than 15%.
The operating result is considered “good” only if both targets are met; otherwise, it’s considered
“bad.”

Create this model in a worksheet. Use formulas to calculate the gross profit, the margin, and
the result. The result should update automatically if the gross profit and margin targets are
changed.

Exercise 6.2. Lookup Article Details (form002)

File: Form002.xlsx

A computer store has the following article information in a table: article number, name, and
price. To quickly find data for a specific article, the article number can be entered in a cell. The
corresponding name and price are then automatically looked up in the table.
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Enter the data in a worksheet and use formulas (VLOOKUP) to retrieve the search results.

Exercise 6.3. Calculating with Dates (form003)

File: Form003.xlsx

In the following table, you can enter your date of birth and the retirement age (67 years). The
date you reach retirement, the current date, and the number of days until your retirement date
should be calculated using formulas.

Create this model in a worksheet and use formulas to calculate the output results.

Exercise 6.4. Determining Commission (form004)

File: Form004.xlsx

A company with three salespeople has a target of $150,000 in sales per year for each person.
If a salesperson reaches that amount, their commission is 6.25% of their sales. If not, their
commission is only 5.5%. The following figure shows a model for calculating the commission for
each salesperson.

Create this model in a worksheet and use formulas for the calculation of the commissions.
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Exercise 6.5. Birth Dates (form005)

File: Form005.xlsx

A mother-child center at a hospital wants a daily overview of babies born too early, on time, and
too late. For babies born too early or too late, they also want to know how many days early or
late. For babies who are yet to be born, they want to know how many days overdue they are.

Create this model in a worksheet. Also, create a similar layout.

Exercise 6.6. VAT Return (form006)

File: Form006.xlsx

A company buys goods from suppliers and pays sales tax (VAT) to those suppliers. The company
then sells the goods to customers, who pay VAT to the company. Every quarter, the company
must submit a tax declaration. The difference between the VAT received (from sales) and the
VAT paid (to suppliers) must be paid to the tax authority. If this difference is negative, the
company receives a refund. Small businesses may be eligible for a reduction in VAT through the
Small Businesses Regulation (SBR). This regulation is outlined in the following table.

1. Create a model with cells for entering the total sales and prepaid VAT, and cells for the
constants (the thresholds and VAT percentage). Calculate the initial VAT to be paid, the
reduction, and the final amount to be paid or received in other cells. Use a single VAT
rate of 21%. The final amount should automatically be labeled as a payment or a receipt.
All amounts must be formatted as whole euros.
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2. Thoroughly test the model with all possible scenarios.

Exercise 6.7. Ticket Price (form007)

File: Form007.xlsx

The following table shows the ticket prices for a sports game. There are two categories: children
and adults. There’s also a cell for entering the age (in whole years). After entering the age, the
ticket price is automatically calculated.

Create this model in a worksheet. Use an IF function for the price calculation. Test the solution
with different ages.

Exercise 6.8. Property Tax (form008)

File: Form008.xlsx

The property tax has two parts: an owner’s portion and a user’s portion. If the owner occupies
the property themselves, they must pay both portions. The rate for both portions depends on
the assessed value according to the WOZ Act. The property tax for 2010 in a certain community
is 0.1064% of the WOZ value for the owner and 0.1224% for the user.

Create this model in a worksheet. The calculated values for the owner and user depend on the
answers “yes” or “no” to both questions.

Exercise 6.9. Savings Deposit (form009)

File: Form009.xlsx

An amount of $20,000 will be placed in a savings deposit for one year at an interest rate of 2.75%.
Create a calculation model that calculates both the interest and the total amount after one year.

Exercise 6.10. Joule’s Law (form010)

File: Form010.xlsx

The amount of heat generated by an electric current flowing through a conductor can be calculated
using Joule’s law: 𝑄 = 0.24 ∗ 𝑖2 ∗ 𝑅 ∗ 𝑡

Where:
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• Q: The amount of heat (cal)
• i: Current (ampere)
• R: Resistance (ohm)
• t: Time (sec)

Create a model in a worksheet where the current, resistance, and time can be entered, and the
amount of heat is calculated from the entered data.

Exercise 6.11. Investment Bond (form011)

A government bond with a maturity of 5 years pays an annual interest rate of 3.5%. Suppose
you want to have $300,000 after 5 years; how much do you need to invest in this bond? Use
Excel’s present value function (PV) to calculate the answer.

Exercise 6.12. Multiplication Table (form012)

First, create the following table:

Then, enter a formula in cell B2 that you can copy down and to the right to fill the rest of the
table, so that the value in each cell is the product of the number to the left of the row and the
number above the column.

Exercise 6.13. Price of Olive Oil (form013)

Olive oil can be purchased in 5-liter cans. The price depends on the number of cans:

• $45 per can for the first 20 cans
• $40 for any can beyond 20

Create a spreadsheet model where you can enter the total number of cans, and the total price
is calculated. Use separate cells for the price per can and the 20-can limit. Name all the cells
appropriately.
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OBJECTIVES

• Characteristics of tables (lists).
• Form button.
• Merge (consolidate) data.
• Convert a data range to a table.
• Sort and filter tables.
• Calculated columns in a table.
• Column totals for a table.

Much of the information in Excel is stored in data tables, which function as a sort of database
within a worksheet. While Excel isn’t a dedicated database program like MS Access, it can
handle simple databases. These databases typically consist of a single table, such as address or
phone lists. The term “database” is generally reserved for external files from specialized database
applications. In Excel, a data table was previously referred to as a “list.”

Working with well-structured tables is common, especially in data analysis. A structured Excel
table also provides an excellent foundation for creating pivot tables.

7.1 Characteristics of Tables

A table is an organized set of data.

Table 7.1: Example of a table.

customnr name date price discount

A104 Anderson 2010-10-02 400 0 %
K102 King 2010-11-03 395 5 %
S501 Smith 2010-12-04 375 8%

A table or database in Excel is composed of rows and columns. These rows are often called
records, and the columns are called fields. The column contains a specific type of data. The first
row of a table contains column headers that describe the information in each column. Column
headers are also known as field names. The field names in Table 7.1 are: customnr, name, date,
price, and discount.

For effective data analysis, it’s crucial that the data is well-structured within the worksheet. A
structured table has the following characteristics:

• Each column contains the same type of data.

• Each row contains the individual data for a single entity or item.
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• The first row of the table contains unique field names. These names are usually formatted
differently (e.g., larger font size, bold, italic) from the rest of the table.

• The table should not contain any blank rows. A row can have empty cells, but not all cells
in a row can be empty.

• The table should not contain any blank columns. A column can have empty cells, but not
all cells in a column can be empty.

A table can be located anywhere in the worksheet; it doesn’t have to start in the first row.

In Excel, a table is a rectangular range of cells used to store data. While a table looks similar to
a regular Excel range, it offers features that distinguish it.

You can create and maintain a table by simply entering data into the cells. However, for better
structure, it’s recommended to use a form for data entry. You don’t need to enter all your data
before converting a range to a table; you can add new rows and columns later. Large datasets
often originate from external files (text/csv files, web queries, databases).

In Excel, you can’t create an empty table and then populate it with data. Instead, you must
first create a range that includes at least some of the data and then convert that range into a
table. Converting a data range to a table changes its appearance and enables built-in features
for filtering, sorting, and adding a total row with various aggregation functions.

By default, Excel tables automatically expand and fill formulas down to the last row. For
example:

• If you add new data in the row directly below the last row of the table, or in the column
immediately to its right, the table will automatically expand to include the new data.

• When you enter a formula in the first cell of a new blank column and press Enter, the
formula automatically fills down to all the remaining rows in that column.

7.2 Form Button

Accurate data entry is essential when working with tables. Excel provides a built-in form for
this purpose. However, the command button for this form isn’t on the ribbon by default. The
following steps explain how to add the Form button to the Quick Access Toolbar. This is a
one-time setup.

Task 7.1.

1. Click the Customize Quick Access Toolbar arrow at the end of the Quick Access Toolbar.

2. Select More Commands ….

3. In the Choose commands from dropdown menu, select Commands Not in the Ribbon.

4. Scroll through the alphabetical list of commands and select Form….

5. Click Add and then click OK.

The Form button is now visible on the Quick Access Toolbar.
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Figure 7.1: Customize Quick Access Toolbar.

Figure 7.2: Dialog box Quick Access Toolbar Commands.

Figure 7.3: Options for Excel > opdracht formulier.
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Figure 7.4: Button Form on Quick Access Toolbar.

7.3 Data Entry Form

To complete this task, the Form button must be available on the Quick Access Toolbar (see
Figure 7.4). If the button is not visible, follow the steps in Task 7.1 to enable it.

Using a data entry form is the easiest and most effective way to add records to a table. Excel can
automatically generate a form if you provide the column field names and enter the first record.
The following figure shows an example of a purchase list. The data for the first item, including
the formulas in cells F2, G2, and H2, has already been entered.

Figure 7.5: Purchase list with first record.

Task 7.2. File: Purchases.xlsx

1. Open the file.

2. Enter the following formulas:

• F2: =D2*E2
• G2: =21%*F2
• H2: =F2+G2

3. Select any cell within the list.

4. Click on the Form button on Quick Access Toolbar.

The data form appears, displaying the eight field names on the left. Entry boxes are provided for
five of the field names, allowing you to enter or modify data. The fields total excl., vat, and total
incl. display values because they are calculated using formulas.

5. Click New and add two new records (see the example in Figure 7.7). Click Close after
entering the last record.

INFO Note

Use the Tab key or the mouse to navigate between fields. Pressing the Enter key moves you
to the next record, or creates an empty form for adding a new record if there are no more
records.
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Figure 7.6: Form purchases.

Figure 7.7: Purchase list with 3 records.
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7.4 Searching Data with a Form

A data form is also useful for searching a range or table for records that meet specific criteria.
The following task demonstrates this. Examples of how to apply criteria are provided at the end
of the task.

Task 7.3. File: Personnel.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Click the Form button. The data form appears.

Figure 7.8: Form personnel.

4. Click Criteria. The form clears and is ready for you to enter search criteria.

5. Search for the “Accounting” department and the “Printers” division (see Figure 7.9).

Figure 7.9: Form personnel with search criteria.

6. Click Find Next. The data of the first person matching the criteria is displayed.
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7. Use the Find Next and Find Prev buttons to browse through the list. There are five people
who meet the criteria.

7.4.0.1 Examples of Search Criteria

Table 7.2 provides examples of search criteria. Try these examples to confirm that the found
records match the criteria. You can also combine multiple criteria. Remember to clear the
criteria list before starting a new exercise.

Table 7.2: Examples of search criteria.

Field Value Explanation

Last name Ja Searches for people whose last name starts
with “Ja”.

Last name *os Searches for people with “os” in their last
name.

Salary >70000 Searches for people with a salary greater
than 70000

Start date <1/1/1990 Searches for people with a start date
before 1/1/1990

7.5 Consolidating ranges

You can summarize (consolidate) similar data from different ranges into a new range. In practice,
the source ranges are often in separate worksheets, and the consolidated range is placed in a new
worksheet.

When you consolidate source data, you apply a summary function (SUM, AVERAGE, COUNT, etc.)
to create the summary data. The columns must have a heading or label to consolidate ranges.

Task 7.4. File: Consolidation.xlsx

1. Open the file.

2. Select cell A1 in the “Total” worksheet.

The lists to be summarized are in the “PRA” and “PRB” worksheets. The consolidated data will
be placed in the “Total” worksheet.

3. Go to Data > Consolidate (Data Tools group).

4. Ensure that the SUM function is selected. If not, select it.

5. Click in the Reference box.

6. Select worksheet PRA > range A1:B7 > Add and click Add.

7. Select worksheet PRB > range A1:B7 > Add and click Add.

8. Check the Top row and Left column boxes under “Use labels in.”

9. Click OK.
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Figure 7.10: Dialog box consolidate.

Figure 7.11: Dialog box consolidate.

Figure 7.12: Result after consolidation.
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Exclamation-Triangle Warning

Consolidation is static. If the source data changes, the consolidation results will not update
automatically. You’ll need to perform a new consolidation. Using pivot tables is often a
better approach for summarizing data.

7.6 Convert Range to Table

Converting a range or list to an Excel table unlocks the additional features and capabilities of
tables.

Task 7.5. File: Candyboxes.xlsx

1. Open the file and select any cell within the data range.

2. Go to tab Insert > Table

The Create Table dialog box appears. If you previously selected a cell with data, the range to be
converted is automatically filled in. If not, or if the range is incorrect, select the correct data
range, including the headers.

Figure 7.13: Dialogbox Create Table.

INFO Note

• If your range includes labels that you want to use as column headers, check “My table
has headers.” If there are no labels, uncheck this option. Excel will automatically add
headers with generic names: Column1, Column2, etc.

• It’s strongly recommended that you provide your own descriptive headers.

3. Click OK.

After converting a range to a table, you’ll notice the following changes:

• A table format (style) is applied. You can change this to a different format if desired.

• Each column header now has dropdown arrows for filtering and sorting.

• A Table Design tab is added to the ribbon. This tab is only visible when a cell within the
table is selected.
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Figure 7.14: The data in an Excel table.

7.6.1 Table Design

The Table Design tab allows you to manage various table settings.

Figure 7.15: Table design on the ribbon. What you see may depend on the screen width.

Each table is automatically assigned a Table Name. The default names are Table1, Table2,
Table3, etc. It’s best practice to change the default name to a meaningful name that reflects the
table’s data. This name is used when referencing the table and in table operations.

You can change the name in the Table name box.

7.7 Table Operations

7.7.1 Selecting Rows/Columns in a Table

1. Right-click a cell in the row or column you want to select.

2. Choose Select, and then select one of the following options:
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• Table Column Data
• Entire Table Column
• Table Row

7.7.2 Inserting a Table Row/Column

1. Right-click a cell.

2. Choose Insert and then select one of the options:

• Table Columns to the Left
• Table Rows Above

If you select a cell in the last row or last column, you’ll also have the options:

• Table Column to the Right
• Table Row Below

If you select the last cell (bottom right), you’ll have both options.

A quick way to add a new row is to select the bottom-right cell and press the Tab key.

7.7.3 Deleting a Table Row/Column

1. Right-click a cell in the row or column you want to delete.

2. Choose Delete, and then select one of the options:

• Table Columns
• Table Rows

7.7.4 Convert a Table to a Range

1. Select any cell inside the table.

2. Go to tab Design (Table Tools) > Convert to Range ( Tools group) and confirm the
operation.

7.7.5 Apply a Table Style

1. Select any cell inside the table.

2. Go to tab Design.

3. Choose a style from the Table Styles gallery.

7.8 Sort a Table

Sorting is a common operation with lists. If you select a cell in a column and click the sort
button, the entire table will be sorted. It can be sorted in ascending or descending order based
on the values in that column.
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Exclamation-Triangle Warning

The only way to restore the table to its original order is by using the Undo button on the
Quick Access Toolbar. Alternatively, before sorting, you can insert a temporary column
with sequential numbers. Sorting by this column later will return the table to its original
state.

Task 7.6. File: Personnel.xlsx

1. Open the file.

2. Convert the data range to a table (see Section 7.6).

3. Click the arrow next to the Department field name and select Sort A to Z.

The table is sorted in ascending order of the column Department.

4. Click on the arrow next to the Division field name and select Sort Z to A .

The table is sorted in descending order of the column Division.

You can sort a table on multiple levels, based on the values in different columns. One of the
columns will be the first level where you sort on. After that, you can add new levels of sorting.
Another column provides the second level of sorting, etc.

5. Select any cell in the table and go to Home > Sort & Filter (Editing group) > Custom Sort
….

The Sort dialog box appears, where you can specify the sort conditions.

6. Choose to sort by Division.

7. Click Add Level and then choose to sort on Department.

Figure 7.16: Dialog box sort with two levels.

8. Click OK.

First, the values in the column Division are sorted in ascending order, and then the values in the
Department column are sorted..
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7.9 Filter a Table

When you filter a table, only the records that meet specific conditions are displayed. The other
records are hidden.

Task 7.7. File: Personnel.xlsx

1. Open the file.

2. If it isn’t already, convert the data range to a table (see Section 7.6).

3. Click the arrow next to the Division field name, select only “Copiers,” and then click OK.

Only the records for the Copiers division are now displayed. The arrow in the Division column
header changes to the filter symbol

4. Now, refine your selection by filtering for the Accounting department.

The status bar at the bottom displays the number of records found.

5. Clear the filter by going to Data > Clear (Sort & Filter group).

7.9.1 Number Filter

When a field contains numbers, you can use specific filter actions. These filters are in the Number
Filters category. The following example demonstrates how to find the top 10 salaries.

Task 7.8.

1. Click the arrow next to the Salary field name and select Number Filters > Top 10….

Figure 7.17: Dialog box for top 10 autofilter.

INFO Note

You can change 10 to a different number. You can also change Top to Bottom.

2. Click OK. The 10 records with the highest salaries are now displayed.

3. Clear the filter by going to Data > Clear (Sort & Filter group).
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7.9.2 Custom Filter

For number field filters other than the default filters, use a custom filter. The following example
shows how to display records for people with salaries from $20,000 to $25,000.

Task 7.9.

1. Click the arrow next to the Salary field name and select Number Filters > Custom Filter….

The Custom AutoFilter dialog box allows you to specify filter conditions.

2. Create the two salary conditions as shown in Figure 7.18.

Figure 7.18: Dialog box for custom autofilter with two conditions.

3. Click OK. 10 records are found.

4. Clear the filter by going to Data > Clear (Sort & Filter group).

7.9.3 Date Filter

When a field contains dates, you can use specific filter actions for dates. These filters are in the
Date Filters category. The following example shows how to find records with a start date in
September.

Task 7.10.

1. Click the arrow next to the Start date field name and select Date Filters > All Dates in the
Period > September.

11 records are found.

2. Clear the filter by going to Data > Clear (Sort & Filter group).
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7.9.4 Slicers

A slicer is an Excel object that you can use to filter data. It displays all the unique values from
a selected column, with each value as a button. Slicers are faster to use than traditional filters,
and they provide immediate visual feedback on what is being filtered.

Slicers can be used with both tables and pivot tables (see Section 13.5.2). They appear to float
above the spreadsheet, making them readily accessible.

Task 7.11.

1. Select any cell in the table.

2. Go to tab Table Design > Insert Slicer (Tools group).

The Insert Slicer dialog box opens and displays the column headings (fields) for which you can
insert a slicer. You can select one or more fields.

3. Select the Department and Division fields and click OK.

Two slicers are inserted. If they overlap, move them so that they are next to each other, as shown
in Figure 7.19. Both slicers display all the unique values for their respective fields.

Figure 7.19: Two slicers for the Department and Division fields.

4. In the Department slicer, click the Marketing button. Only the data for Marketing is now
displayed.

5. Clear the filter by clicking the Clear Filter button (the button with the “x”) in the top right
corner of the Department slicer.

6. In the top right corner of the Department slicer, click the Multi-Select button. Now, filter
for both Administration and Marketing.

INFO Note

The buttons act like toggles. Clicking a button repeatedly turns the filtering for that value
on and off.

7. Now, select Printers in the Division slicer.

8. Experiment with the slicers. You can optionally add a third slicer for the Function column.
When you’re finished, clear all filters.
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Figure 7.20: Multiple selection applied in the Department slicer.

7.10 Calculated Column

When you enter a formula into an empty table column, that formula automatically extends
to the rest of the column. You don’t need to use Fill or Copy. This type of column is called
a calculated column. If you change a formula, the change automatically applies to the entire
calculated column.

The easiest way to create a new calculated column is to start typing in the column immediately
to the right of the table. The table will automatically expand to include the new column.

Task 7.12. File: Personnel.xlsx

1. Open the file.

2. If it isn’t already, convert the data range to a table (see Section 7.6).

3. Select cell I2 and enter the formula =ROUND([@Salary],0). A new table column with the
calculated values is created.

INFO Note

References like [@Salary] are called structured references, which are unique to Excel
tables. Structured references allow the table to use the same formula for each row.

4. Change the column header to Rounded Salary.

5. Select a numeric cell in the new column, then Right-click > Select > Table Column Data.

6. Change the cell format to Accounting, 0 decimals.

7. Select cell J2 and enter the formula
=YEAR(NOW())-YEAR([@[Start date]]).

8. Change the column header in Age.
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7.11 Task: Total Row

You can summarize numeric data in a table using a subtotal that appears at the bottom of
the table. Although the term “subtotal” suggests summing numeric values, Excel uses it more
broadly. A subtotal can be a sum, average, maximum, minimum, standard deviation, variance, or
count of the values in a field. The calculation is based on the visible cells in the table’s column.

Task 7.13. File: Personnel.xlsx

1. Open the file.

2. If it isn’t already, convert the data range to a table (see Section 7.6).

3. Go to Table Design tab> Check the Total Row box (Table Style Options group)

A “Total” row is inserted at the bottom of the table, and a SUBTOTAL function is added below the
last column. In this case, the function is irrelevant because the last column is a date column.

4. In the “Total” row, select the cell below the Start date column, click the dropdown arrow
and choose “None”.

5. In the “Total” row, select the cell below the Salary column, click the dropdown arrow
and choose “Sum”.

The total salary is $ 4,874,037.39.

7.12 Exercises

Exercise 7.1. Filtering (list001)

File: List001.xlsx

The following table lists the grades of some students.

Apply a filter to display only the rows for students with no grade or a grade of 3 or lower. This
exercise uses a small table. Your solution should work for much larger tables.

Exercise 7.2. Consolidating Examination Results (list002)

File: List002.xlsx

The following table shows the results of a group of students for an examination and a re-
examination. It also shows the final result, which is the highest grade.
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Enter the examination and re-examination data in a worksheet. Determine the final result using
consolidation.

Exercise 7.3. Consolidating Sales Data (list003)

File: List003.xlsx

The following table lists the sales numbers of bread types in the North and South branches of a
store. It also shows the total sales numbers obtained by consolidation.

Enter the data for the two branches in a worksheet. Determine the totals using consolidation.

Exercise 7.4. Filtering Car Data (list004)

File: Car.xlsx

In a worksheet, you can find some data of cars. A customer is interested in cars that meet the
following conditions:

• 6 cylinders
• Top speed of at least 180 km/hour
• Petrol (regular or premium) fuel type

Create a list of all cars with their data that meet these conditions.
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OBJECTIVES

• Introduction to arrays.
• Creating array formulas.
• Create frequency distribution of data with FREQUENCY function.
• Dynamic arrays and associated functions.
• Mathematical array functions.

An array formula is a formula that can perform multiple calculations on one or more items in
an array. Array formulas used to be considered tricky because they look different from regular
formulas and required a special entry method: pressing CTRL+SHIFT+ENTER instead of just
ENTER. This is no longer the case in Excel 365.

Exclamation Important

In Excel 365, the behavior of array formulas has changed compared to other Excel versions.
Existing formulas that produce multiple results now behave like array formulas. Several
new dynamic array formulas are added to Excel 365.
Therefore, much of this chapter applies primarily to Excel 365.

8.1 What is an Array Formula

A vector is a list of numbers arranged in either a row or a column. A row of numbers is called a
row vector, and a column of numbers is called a column vector. Excel uses the term “array”
instead of “vector.”

In Excel, an array can be:

• A row of values (a row vector or a 1-dimensional horizontal array).

• A column of values (a column vector or a 1-dimensional vertical array).

• A rectangular block of rows and columns (a 2-dimensional array).

Figure 8.1 illustrates each type.

Figure 8.1: Array examples (from left to right): row vector, column vector, 2-D array.

You can create an array using constant values, as shown in the examples, by starting a cell
entry with the = symbol and enclosing a row of values in curly brackets {}. The values must be
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separated by a specific symbol. The appropriate separator depends on the language and regional
settings of your computer.

• For English language systems:

– Use a comma (‘,‘) to separate values in a row (new column).
– Use a semicolon (‘;‘) to separate rows.

• For Dutch language systems:

– Use a backslash (‘\‘) to separate values in a row (new column).
– Use a semicolon (‘;‘) to separate rows.

Additionally, 2-dimensional arrays must follow these rules:

• List values in row order.
• All rows must have the same number of columns.

Here are some examples:

Example 8.1. Row vector

={1,2,3,4,5} returns 1 row with 5 columns.

Figure 8.2: 1-dimensional horizontal array.

Example 8.2. Column vector

={1;3;6} returns 3 rows with 1 column.

Figure 8.3: 1-dimensional vertical array.

Example 8.3. 2-dimensional array

={1,2,3,4,5;3,5,7,9,11;6,9,12,15,18} returns 3 rows with 5 columns.
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Figure 8.4: 2-dimensional array.

Exclamation Important

For all the above examples, only the first cell where you entered the array formula is editable.
When you select any other cell within the array’s range, the content in the formula bar
appears grayed out, and you cannot change its value.

8.2 Simple Array Formulas

An array formula performs calculations on arrays, and the result is also an array. When using
array formulas, you need to determine in advance how many results to expect and how those
results should be arranged (in a single cell, row, column, or table).

In Figure 8.5, you can see the sum and product of two numbers calculated multiple times. This
can be done with simple formulas. For instance, the formula in cell D2 could be =A2+B2, and the
formula in E2 could be =A2*B2. Copying these formulas down would apply the correct formulas
to D3:E4.

Figure 8.5: Sum and product of two numbers using regular Excel formulas.

However, these calculations can also be performed using array formulas, which is a good practice
for understanding how they work.

Task 8.1. File: Array1.xlsx

1. Open the file.

2. Select cell D2 and enter =A2:A4+B2:B4, then press ENTER. The results appear in cells
D2:D4, with a box around them indicating an array.

INFO Note

• Selecting cell addresses with the mouse is easier than typing them.

• Since the addition results in a column of three numbers, Excel automatically spills the
results into cells D3:D4. Ensure these cells are empty beforehand to avoid a #SPILL!
error.
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Figure 8.6: Sum of two columns using an array formula.

3. Select cell E2 and enter =A2:A4*B2:B4, then press ENTER. The results appear in cells
E2:E4, with a box around them indicating an array.

Figure 8.7: Product of two columns using an array formula.

Task 8.2. Multiplying a row vector by a constant

Figure 8.8 shows a row of three numbers multiplied by 4. The result is a row of three numbers.
Try this example yourself.

Figure 8.8: Multiplying a row vector by a constant.

Task 8.3. Multiplying a 2-dimensional array by a column vector

Figure 8.9 shows a 4x3 array multiplied by a column of numbers. The result is a 4x3 array.

Try this example yourself. You can use the practice file Array2.xlsx.

8.3 Calculating a Single Result

This section explains how to use a single array formula in situations that might otherwise require
multiple formulas.

Use an array formula when you need to perform several calculations to get one result. This
simplifies the worksheet by replacing multiple formulas with a single array formula.
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Figure 8.9: Multiplying a 2-dimensional array by a column vector.

Figure 8.10 shows a stock portfolio with prices. To calculate the total value of the shares at a
given price, you would typically calculate the value for each stock and then sum those values.
An array formula can perform this calculation without intermediate steps.

Figure 8.10: Stock prices.

Task 8.4. File: Array3.xlsx

1. Open the file.

2. Select cell C6 and enter the formula =SUM(B2:B5*C2:C5).

3. Repeat for cell D6; the formula is =SUM(B2:B5*D2:D5).

Question

How can you modify the formula in C6 so that it can be copied to D6?

Task 8.5. File: Array4.xlsx

In this exercise, calculate the weighted average of four test scores for each student using an array
formula. Start with a formula for Jan and make it suitable for copying down.

Figure 8.11: Weighted averages of test scores.
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Task 8.6. File: Array5.xlsx

Figure 8.12 shows the gender and height (in cm) of several students. The average height for male
and female students is calculated in cells C11 and C12.

Figure 8.12: Average height by gender.

The array formula here is more complex because it needs to select heights based on gender. The
IF function can achieve this.

1. Open the file.

2. Select cell C11 and enter the formula =AVERAGE(IF(B2:B9="m",C2:C9)).

3. Create a formula for cell C12 by adjusting the formula for female students.

8.4 Frequency Distribution

Use the FREQUENCY function to create a frequency distribution.

Syntax: FREQUENCY(data_array,bins_array).

The first argument is the array of values. The second argument is the array of bin boundaries
for grouping the values. The result is an array of frequencies.

Task 8.7. File: Array6.xlsx

Figure 8.13: Frequency distribution.

1. Open the file.
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2. Enter the formula =FREQUENCY(A2:A11,B2:B5) in cell C2.

INFO Note

The result is a frequency table. Figure 8.14 explains how the interval boundaries are handled.

Figure 8.14: Explanation of frequency distribution intervals.

8.5 Dynamic Array Formulas

An array formula entered in one worksheet cell can output results into multiple cells. This is
called spilling, and the output occupies a spill range. The number of cells in the spill range
depends on the formula’s result. When the source data changes, the results update dynamically,
and the spill range adjusts accordingly. A #SPILL! error occurs if other data obstructs the spill
range.

To refer to a spill range, append a hash symbol # to the address of the first cell in the range. For
example, if the spill range is J2:N4, refer to it as =J2#. This ensures that the reference adapts if
the spill range’s size changes.

LIGHTBULB Tip

Naming arrays used in formulas can be very helpful. You can name them the same way
you name individual cells.

Several new functions support dynamic array behavior: RANDARRAY, FILTER, SEQUENCE, SORT,
SORTBY, UNIQUE, XMATCH and XLOOKUP.

8.5.1 RANDARRAY

Returns an array of random numbers. All arguments are optional.

Syntax

RANDARRAY([rows],[columns],[min],[max],[integer])

• rows: The number of rows in the returned array (default is 1).
• columns: The number of columns in the returned array (default is 1).
• min: The smallest number to return (default is 0).
• max: The largest number to return (default is 1).
• integer: TRUE for integers, FALSE for decimals (default is FALSE).

Example 8.4. =RANDARRAY(3,4,10,50,TRUE)
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Figure 8.15: Generates a 3x4 array with random integers between 10 and 50.

8.5.2 FILTER

Returns filtered values from an array or range.

Syntax

FILTER(array,include,[if_empty])

• array: The range or array to filter.
• include: An array of Boolean values (TRUE to keep a row/column, FALSE to exclude it).
• if_empty: The value to return if no items are retained.

Example 8.5. File: Dynarray.xlsx

Extract rows where the gender is female.

Figure 8.16: Filters a list of names to show only female entries.

To filter for males or unspecified genders, replace “f” with “m” or “z” in the formula.

You can also use multiple criteria. To filter for women shorter than 170 cm, use:
=FILTER(A32:C41,(B32:B41="f")*(C32:C41<170),"None")

8.5.3 SEQUENCE

Returns a sequence of numbers based on a pattern.

Syntax

SEQUENCE(rows,[columns],[start],[step])

• rows: The number of rows to return.
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• columns: The number of columns to return (default is 1).
• start: The first number in the sequence (default is 1).
• step: The increment between numbers (default is 1).

Example 8.6. =SEQUENCE(4,3,5,10)

Figure 8.17: Generates a 4x3 matrix of integers, starting with 5 and incrementing by 10.

8.5.4 SORT

Sorts the values in a range or array.

Syntax

SORT(array,[sort_index],[sort_order],[by_col])

• array: The array to sort.
• sort_index: The row or column number to sort by (default is 1).
• sort_order: 1 for ascending, -1 for descending (default is 1).
• by_col: TRUE to sort columns, FALSE to sort rows (default is FALSE).

Example 8.7. File: Dynarray.xlsx

Sort an array by the values in column 3 (length).

Figure 8.18: Sorts an array by length (column 3).
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8.5.5 SORTBY

Sorts a range or array based on the values in another range or array.

Syntax

SORTBY(array,by_array1,[sort_order], ...)

• array: The array to sort.
• by_array1: The array to sort by.
• sort_order: 1 for ascending, -1 for descending (default is 1).

Example 8.8. File: Dynarray.xlsx

Sort names by length.

=SORTBY(A2:A11,C2:C11)

Figure 8.19: Sorts a list of names by length.

The array used for sorting doesn’t need to be included in the output.

You can also sort by multiple columns:

Example 8.9. File: Dynarray.xlsx

Sort the array by gender (ascending) and then by length (descending).

=SORTBY(A2:C11,B2:B11,1;C2:C11,-1)

8.5.6 UNIQUE

Returns an array with unique values from an array.

Syntax

UNIQUE(array,[by_col],[exactly_once])

• array: The array to extract unique rows or columns from.
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Figure 8.20: An array is sorted ascending by gender, then descending by length.

• by_col: TRUE to return unique columns, FALSE to return unique rows (default is FALSE).
• exactly_once: TRUE to return values that appear only once, FALSE to return all distinct

rows or columns (default is FALSE).

Example 8.10. UNIQUE(A1:A10)

Extracts the unique values from a list of names.

Figure 8.21: Extracts unique names from a list.

8.5.7 XMATCH

Searches for a value and returns its position within a row or column. This is a more advanced
replacement for the MATCH function.

XMATCH supports approximate and exact matches, reverse searches, and wildcard characters (*?)
for partial matches. Searches can start from the first or last value, and it also supports binary
searches.
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This function is often used with other functions. The XLOOKUP function is generally more useful.

Syntax

XMATCH(lookup_value,lookup_array,[match_mode],[search_mode])

• lookup_value: The value to search for.
• lookup_array: The array to search within.
• match_mode: Specifies the type of match: 0 for exact match, -1 for exact match or next

smaller item, 1 for exact match or next larger item, 2 for wildcard match (default is 0).
• search_mode: Specifies the search direction: 1 to search from the first item, -1 from the

last item, 2 for binary search (ascending), -2 for binary search (descending).

Example 8.11. =XMATCH(E1,A2:A11)

Finds the position of a country in the top 10 medal table from the 2016 Summer Olympics.

Figure 8.22: Finds the position of a country.

8.5.8 XLOOKUP

A modern and versatile replacement for VLOOKUP, HLOOKUP, and LOOKUP. It supports approximate
and exact matches, wildcard characters (*?), and vertical or horizontal searches.

Syntax

XLOOKUP(lookup_value, lookup_array, return_array, [if_not_found], [match_mode],
[search_mode])

• lookup_value: The value to search for.
• lookup_array: The array to search within.
• return_array: The array to return values from.
• if_not_found: The value to return if no match is found.
• match_mode: Specifies the type of match: 0 for exact match, -1 for exact match or next

smaller item, 1 for exact match or next larger item, 2 for wildcard match (default is 0).
• search_mode: Specifies the search direction: 1 to search from the first item (default), -1

from the last item, 2 for binary search (ascending), -2 for binary search (descending).
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Example 8.12. =XLOOKUP(D2,A2:A7,B2:B7,,-1)

Looks up the discount percentage based on the quantity in a discount table.

Figure 8.23: Determines the discount percentage.

LIGHTBULB Tip

Note the arguments in this formula:

• lookup_value: D2
• lookup_array: A2:A7
• return_array: B2:B7
• if_not_found: Not specified (hence the comma).
• match_mode: -1
• search_mode: Not specified (uses the default).

8.6 Tables and Array Formulas

Array formulas are often used with data lists, especially those with multiple columns. Using
Excel tables with these formulas offers advantages: you can use table and column names in
formulas, and references update automatically when rows are added or removed.

To refer to a column in an Excel table, use square brackets immediately after the table name:
table_name[column_name].

Task 8.8. File: Personnel.xlsx

1. Open the file.

2. Convert the data range to a table using the Insert tab > Table, and name the table
tblPersonnel.

3. Save the file as Personneltable.xlsx to preserve the original.

4. In a cell outside the data area (e.g., K4), enter the formula =UNIQUE(tblPersonnel[Department]).

This will create a list of department names. To sort this list alphabetically, nest it within the
SORT function.

5. Change the formula to =SORT(UNIQUE(tblPersonnel[Department])).

109



8 Array Formulas

This will give you a sorted list of department names.

Create a similar sorted list of division names.

8.7 Returning Multiple Values

XLOOKUP can return multiple values for a single match. This task demonstrates how to return
four values with one formula.

Task 8.9. File: olympic2016.xlsx

1. Open the file.

2. Convert the data range to a table using the Insert tab> Table, and name the table Medals.

3. Add a Total column to the table with a formula to calculate the total number of medals:

• Enter the text Total in cell E1 and press ENTER to create a new column.

• In cell E2, type =SUM(, select cells B2:D2, type ), and press ENTER.

The total medal counts will appear in the Total column. Excel changes the formula in E2 to
=SUM(Medals[@[Gold]:[Bronze]]).

4. Copy the texts in A1:E1 to G1:K1.

5. Enter the text Netherlands in cell G2.

6. SIn cell H2, enter the formula:
=XLOOKUP(G2,Medals[Country],Medals[Gold]:Medals[Total])

The result will look like this:

Figure 8.24: XLOOKUP returning multiple values.
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8.8 Two-Way Lookup

XLOOKUP can also perform two-way lookups by nesting one XLOOKUP function within another.

Figure 8.25 shows Starbucks coffee prices. Cell G3 should display the price based on the coffee
type in G1 and the size in G2.

Figure 8.25: Nested XLOOKUP functions for a two-way lookup.

Task 8.10. File: Tidy001.xlsx

1. Open the file.

2. Enter the data in F1:F3 and G1:G2.

3. In cell G3, enter the formula:
=XLOOKUP(G2,B1:D1,XLOOKUP(G1,A2:A10,B2:D10)).

INFO Note

• The inner XLOOKUP looks up the coffee type in the product column and returns a row
of prices.

• The outer XLOOKUP finds the correct size and returns the corresponding price.

8.9 Mathematical array functions

Linear algebra1 involves many arithmetic operations with arrays, and Excel provides specific
functions for this. Their use is beyond the scope of this textbook.

MUNIT Identity Matrix.

Returns the identity matrix for a given dimension. Primarily used with other matrix
functions like MMULT.

MMULT Matrix Multiplication.

Returns the matrix product of two arrays.

1https://en.wikipedia.org/wiki/Linear_algebra
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MINVERSE Matrix Inverse.

Returns the inverse of a matrix, used for solving systems of equations. The product of a
matrix and its inverse is the identity matrix.

MDETERM Matrix Determinant.

Returns the determinant of a matrix, also used in solving systems of equations.

8.10 Exercises

Exercise 8.1. Array Addition (matr001)

Perform the following addition using array formulas.

Exercise 8.2. Failures per District (matr002)

File: Matr002.xlsx

A public utility company records gas, water, and electricity failures by district, as shown below.
Calculate the total failures per district using array formulas.

Enter array formulas in cells C16:C19 to calculate the total failures per district.

Exercise 8.3. Random Integers (matr003)

Use the RANDARRAY function to generate random numbers. Create a new file with the following
data to experiment with dynamic array formulas:
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1. In cell B7, enter a formula to generate random integers, referencing cells B1:B4 for the
arguments.

2. In cell B6, calculate the average of the generated numbers, referencing the spill range.

3. Experiment with different values in B1:B4. The maximum value must be greater than or
equal to the minimum value.

Exercise 8.4. Random Dates and Times (matr004)

Excel stores dates and times as numbers. For example, 2020-06-30 18:00:00 is stored as
44012.75. The part before the decimal is the date, and the part after is the time. You can
generate random dates and times using the RANDARRAY function.

1. In a new worksheet, enter the data for the first three rows and apply the correct formatting.

2. In cell B5, enter a formula to generate dates, and in cell E5, a formula to generate times.
Use the data in the first three rows as arguments. Apply date/time formatting to the spill
ranges.

3. Experiment with different values in the first three rows. The maximum value must be
greater than or equal to the minimum value.

Exercise 8.5. Sorting Columns (matr005)

File: Benelux-Population.xlsx
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The figure shows the population of the Benelux countries for 2000, 2005, 2010, and 2015. Use
the SORT function to display this data with the years in reverse order.

Open the file and copy the data in columns A and B to H and I, respectively. Enter the SORT
formula in cell J1 to sort the data by year in descending order. The result should look like this:

Save the file as matr005.xlsx to preserve the original.

Exercise 8.6. Sequence of Roman Numbers (matr006)

Create an array with the numbers 1 to 100 in a new worksheet, as shown below.

Then, modify the formula to display Roman numerals.
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Save the file as matr006.xlsx.
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9 Charts

OBJECTIVES

• Parts of a chart.
• Creating charts.
• Adjustments of chart parts.
• Location and size of a chart.
• Formatting a chart.

Charts are an important tool in analyzing data. They can display information clearly, and
their power should not be underestimated. Trends and patterns can be easily visualized, and
abnormalities or fluctuations become readily apparent.

Excel offers a wide range of chart types, making it important to choose the right one. When Excel
is installed, the Grouped Column chart type is the default, but this setting can be changed.

To easily create a chart in Excel, the data should be well-organized in the worksheet, ideally in a
table format.

Charts can be located in two ways:

• As an object in a worksheet. This is called an embedded chart. The advantage is that
you can view and print the chart alongside the data.

• On a special worksheet dedicated to the chart, called a chart sheet.

The chart’s location can be changed later.

9.1 Chart Elements

A chart consists of many elements, not all of which are included by default in Excel. They can
be added, moved, or deleted as needed.

The most important parts of a chart are:

Chart area (1) The entire chart, including all its elements.

Plot area (2) The rectangular area bounded by the axes, containing all data series. In the figure,
this is the area with the light-colored background.

Data series (3) A row or column of numbers from your worksheet that are plotted in the chart.
The example chart has two data series: the blue and brown colored sets. Data series have
names (here, “2009” and “2010”), which form the legend.

Data point (4) An individual value (bar, column, point, etc.) in the chart. Each column in the
chart is a data point, with a total of eight data points shown.

Category axis (5) The horizontal axis or X-axis. The text labels along this axis come from cells
in the worksheet. In the example, the categories are “Q1,” “Q2,” “Q3,” and “Q4.”
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Figure 9.1: Elements of a chart.

Horizontal axis title (6) This title identifies the type of data along the horizontal axis. For
example, if it’s not clear that “Q1, Q2, Q3, Q4” represents quarters, you can add a title to
clarify.

Value axis (7) The vertical axis or Y-axis, which usually contains numbers.

Vertical axis title (8) This title is important for identifying the units along the axis.

Chart title (9) A short text that indicates the chart’s subject. It usually appears in a larger
font near the top of the chart.

Legend (10) A box that identifies the patterns or colors assigned to the data series or categories.

Gridlines (11) Horizontal or vertical lines in the plot area.

Data labels (12) Numbers associated with data points, providing their actual values.

9.2 Creating a Recommended Chart

Excel offers many chart types, and choosing the most appropriate one can be challenging. The
Recommended Charts command can help by suggesting suitable charts for your data. Always
select the data first to use this feature effectively.

Task 9.1. File: Bakery.xlsx

Figure 9.2: Sales bakery per year by quarter.

1. Open the file.

2. Select any cell in the data area A1:D5.
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INFO Note

If the data area is contiguous (like A1:D5 here), selecting any cell within it allows Excel to
automatically recognize the entire data area. If the area is not contiguous, you must select
the whole data area.

3. Choose Insert > Recommended Charts (Charts group).

The Insert Chart dialog box appears. The left side displays a list of Excel’s recommended charts
for your data, and clicking on a chart shows a preview on the right.

Figure 9.3: Recommended charts. The selected chart type is highlighted in the left column.

4. Choose Clustered Column > OK.

The chart is embedded in the worksheet, and the Chart Design and Format tabs appear on the
ribbon. These tabs are only visible when the chart is selected.

A frame surrounds the chart to indicate it is selected. In the upper-right corner, three buttons
allow you to add or change::

• Chart Elements

• Chart Styles

• Chart Filters
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INFO Note

An alternative, often quicker, method to insert a recommended chart is:

1. Select the data, including the headings.

2. Click the Quick Analysis button at the bottom right corner of the selected
range.

3. Click Charts and select the desired chart.

9.3 Chart Operations

You can perform various operations on chart elements, depending on the specific element. For
text elements, you can change the size, font, color, etc. To perform an operation, you must
first select the element and then choose the operation from the menu or the right-click shortcut
menu.

Selecting a chart element

This is usually straightforward, but it can be tricky when elements are close together.

After selecting the chart, you can select a chart element in the following ways:

• Click on the chart element.
• Use the menu Format tab > Chart Elements arrow (Current Selection group).

Figure 9.4: Current selection on the ribbon (tab Format). With the arrow you can select the
desired chart part.

INFO Note

1. The Current Selection always displays the selected element. In Figure 9.4, the Chart
Area is selected.

2. Selected parts are marked with sizing handles.

Moving an element

Select the element, hover the mouse pointer over its edge (not on a sizing handle), and drag it to
the desired location.

Changing dimensions

When a resizable element is selected, it is surrounded by sizing handles. Drag a handle to change
its height or width.
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Formatting an element

Select the element and choose Format tab > Format Selection (Current Selection group). A task
pane appears on the right with formatting options.

You can also access the task pane by right-clicking on the element and selecting Format ….

Applying a chart style

Excel provides predefined formats called styles. You can apply a style using the button.

Deleting a chart

Both embedded charts and chart sheets can be easily removed.

Choose one of the following options:

• Embedded chart: Select the chart and press the Delete key.

• Chart Sheet: Right-click on the chart sheet’s tab and select Delete from the shortcut menu.

9.4 Switching Rows/Columns

The source data for a chart can be arranged either with data series in columns or rows. You can
easily switch between these arrangements.

In the bakery’s sales data (Figure 9.2), the annual data is in columns, and the quarterly data is in
rows. You can compare years, with each year as a data series (Figure 9.3), or compare quarters,
with each quarter as a data series. When creating the chart, Excel tries to guess whether the
columns or rows should be the data series. If Excel’s choice is incorrect, you can easily change
it.

Task 9.2. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the chart by clicking within the chart area.

A double border appears around the chart, and the mouse cursor changes to a cross with arrows

.

3. Choose Chart Design > Switch Row/Column (Data group).

9.5 Changing Chart Location

You can create a chart on the same worksheet as the data (an embedded chart) or on a
separate sheet that contains only the chart (a chart sheet). You can move an embedded chart
by dragging it or move it to a chart sheet. This task demonstrates both methods.

Task 9.3. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the chart by clicking within the chart area.
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Figure 9.5: Sales bakery, now with quarters (rows) as data series.

A double border appears around the chart, and the mouse cursor changes to a cross with arrows

.

3. Press the left mouse button and drag the chart to the desired location.

LIGHTBULB Tip

Holding down the Alt key while dragging snaps the chart to the worksheet’s gridlines.

4. Click outside the chart in the worksheet to deselect it.

5. elect the chart again and choose Chart Design > Move Chart (Location group).

Figure 9.6: Dialog box Move Chart.

6. Select New sheet, name the new sheet, and click OK.

You can also move a chart from a chart sheet to embed it in a worksheet.

7. Select the chart in the chart sheet.

8. Choose Chart Design > Move Chart (Location group).
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9. Select Object in, choose the worksheet, and click OK.

The worksheet with the embedded chart is displayed and the chart sheet is deleted.

9.6 Resizing Charts

You can change a chart’s size by dragging its sizing handles. These handles may appear as small
circles, squares, or dots. When an object is selected, a rectangular frame outlines it, and sizing
handles appear at each corner and the middle of each side. Corner handles allow dragging in any
direction, while middle handles restrict dragging to horizontal or vertical directions. You can
enlarge or shrink the chart or specify exact dimensions.

Task 9.4. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the chart by clicking within the chart area.

3. Hover the mouse pointer over a corner point until it turns into a double-headed arrow .

4. Click the left mouse button and drag to the desired size.

LIGHTBULB Tip

Holding down the Alt key while dragging snaps the chart to the worksheet’s gridlines.

To specify exact dimensions:

5. Select the chart.

6. Choose Format > Height / Width (Size group).

Figure 9.7: Height and width of a chart.

7. Enter the desired dimensions.

8. Click outside the chart in the worksheet to deselect it.

9.7 Chart Title

When you create a chart, the title appears above it by default. You can select the title text and
type your desired title, hide the title, or change its location.

Task 9.5. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the chart.
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Figure 9.8: Options chart title.

3. Choose Chart Design > Add Chart Element (Chart Layouts groep) > Chart Title.

4. Choose Above Chart.

5. Double-click the title text “Chart Title” and replace it with your own text for example “Sales
Bakery”.

INFO Note

• Selecting None removes the chart title.

• You can move the chart title by dragging it.

• You can format the title by selecting it, right-clicking, and choosing Format Chart
Title.

Task 9.6. Faster method

1. Select the chart.

2. Click the Chart Element button next to the chart to see a list of chart elements.

3. Check Chart Title to immediately add the title to the chart.

INFO Note

• An arrow next to a chart element indicates a drop-down menu with more options.

• Checked elements are present in the chart. Unchecking an element removes it.

The following tasks will primarily use this faster method.
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Figure 9.9: Selecting and deselecting chart elements .

9.8 Legend

A legend identifies the patterns or colors representing data series in a chart. By default, if
applicable, the legend appears on the right. You can remove it or drag it to another location.

Task 9.7. File: Bakery_Chart.xlsx

The Chart elements button provides the following legend options:

• Right
• Top
• Left
• Bottom
• None (by deselecting)

Like the chart title, you can drag and format a legend.

Experiment with the options.

9.9 Axis Titles

Axis titles are labels along the horizontal and vertical axes that help explain the data.

Task 9.8. File: Bakery_Chart.xlsx

The Chart elements button provides the following options for Axis Titles:

• Primary Horizontal
• Primary Vertical

1. Add titles for both axes.

2. Change the horizontal title in “Time”.

3. Change the vertical title to “Sales (x 1000)”.
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9.10 Data Labels

Data labels are numbers at the data points that display the actual values.

Task 9.9. File: Bakery_Chart.xlsx

The following options are available for data labels:

Figure 9.10: Options for data labels.

Experiment with these options. In Figure 9.11) you see the display for the Outside End option.

Figure 9.11: Data labels outside the columns display the sales for each quarter.

9.11 Gridlines

Gridlines are horizontal and vertical lines that extend from the axes across the chart’s plot area.
They make the data easier to read by providing visual guides. You can display gridlines for
major or minor intervals on the axes.

Task 9.10. File: Bakery_Chart.xlsx

The following options are available for gridlines:

Hover the mouse over the options to preview the results in the chart.
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Figure 9.12: Options for grid lines.

9.12 Plot Area

The plot area is the rectangular area of the chart that displays the charted data. It is bounded
by the axes and includes the axes but not the titles. You can format the plot area with a colored
background and border.

Task 9.11. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the plot area, right-click, and choose Format Plot Area. The Format Plot Area task
pane appears.

3. Open the Fill option and select Solid fill with a light gray color.

4. Open the Border option and select Solid line with a black color

Figure 9.13: Plot area with a background and border.
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9.13 Adding and Removing Data Series

It’s common to add a new data series to an existing chart or remove an old one. The procedure
depends on whether the data to be added or removed is directly adjacent to the existing data
set. You can easily determine this by selecting a chart; Excel will highlight the corresponding
source data in the worksheet with colored boxes.

New series joins the highlighted area Expand the data range by dragging the selection.

Delete a series at the beginning or end of the highlighted area by dragging.

New series does not join the highlighted area Use the Select data source dialog box.

Both techniques are covered in this section.

Task 9.12. File: Bakery_Chart.xlsx

Add a new 2011 data series by dragging

1. Open the file.

2. Add the new data for year 2011 in the range E1:E5, as shown in Figure 9.14).

Figure 9.14: Bakery turnover data supplemented for the year 2011.

3. Select the chart. The source data is selected on the worksheet, showing the sizing handles.

Figure 9.15: Marked data source of the chart.

4. Drag the lower-right sizing handle to include the new data.

Task 9.13. Delete the 2008 dataset by dragging

1. Select the chart.

The source data is selected on the worksheet, showing the sizing handles.

2. Drag the lower-left sizing handle to exclude the data for 2008.

Task 9.14. Add the 2008 series and delete the 2011 series via the dialog box

1. Right-click on the chart and choose Select Data….
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Figure 9.16: Bakery sales, extended with 2011 data.

Figure 9.17: Marked data source 2008-2011.

Figure 9.18: Chart with data series 2009-2011.
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INFO Note

An alternative is Chart Design tab > Select Data (Data group).

Figure 9.19: Select Data Source.

2. Click the Add button.

Figure 9.20: Dialog box for adding a new series.

• Series name: The cell that contains the name of the data series.
• Series values: The cell range that contains the data values.

3. Place the cursor in the Series name box and then select cell B1 in the worksheet.

4. Select the contents of the Series values box and then select the range B2:B5 in the worksheet.

5. Click OK.

The 2008 data series is added to the chart and the Select Data Source dialog box. However, it’s
added at the end, making the order illogical.

6. In the dialog box, select the 2008 series and click the Move Up arrow three times to make it
the first series.
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Figure 9.21: Dialog box data source. Here you can change the order of the data series.

7. In the Select Data Source dialog box, select the 2011 series and click the Remove button.

The 2011 data series is removed, restoring the initial situation with the 2008-2010 data series.

9.14 Task: Changing Chart Type

You can easily change the chart type. This task demonstrates changing a column chart to a line
chart.

Task 9.15. File: Bakery_Chart.xlsx

1. Open the file.

2. Select the chart.

3. Choose Chart Design > Change Chart Type (Type group).

4. Choose the Line with Markers type and click OK.

9.15 Case Share Prices

File: Stocks.xlsx

Figure 9.24 shows the average monthly share prices of four companies for January through
March:

Create a line chart from this data.

Later, the entries for April are published:

Add this data to the chart.
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Figure 9.22: Change chart type.

Figure 9.23: Line chart with markers.
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Figure 9.24: Average monthly share prices.

Figure 9.25: Average prices for April.

The final result should look like this

Figure 9.26: Chart with average monthly share prices.

9.16 Exercises

Exercise 9.1. Third-degree chart (graf001)

Create the following chart. Make the layout as similar as possible.
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Exercise 9.2. Travel bookings (graf002)

File: Graf002.xlsx

The following table lists the travel booking data for the years 2008-2010.

Enter the data in a worksheet and use formulas for the totals. Then, create the following chart.

Exercise 9.3. Sales figures (graf003)

File: Graf003.xlsx

The following table shows the estimated and actual sales figures per quarter for 2010, as well as
the difference between them. The average percentage of the differences is also calculated.
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Enter the data in a worksheet and use formulas for the differences and the average. Then, create
the following chart.

Exercise 9.4. Age structure (graf004)

File: Graf004.xlsx

The following table lists the percentages of the Dutch population’s age structure for the years
1950-2010, divided into nine age classes (source: CBS).

Create the following chart from this data.

Exercise 9.5. Relationship between production time and cost (graf005)

File:Graf005.xlsx
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A toy manufacturing company suspects that the price of toys largely depends on production time.
To investigate this, they measured the production time of the toys. The results and associated
costs are shown in the following figure.

1. Create a chart that plots cost against production time (the independent variable).

2. Add a linear trend line to the chart, and include the trend line’s equation.

Exercise 9.6. Counting agarics (graf006)

File: Graf006.xlsx

The number of agarics in a given area is counted annually. The following table shows the number
of agarics per hectare for several years.

Create the following chart from this data.
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OBJECTIVES

• Chart types.
• Line chart vs Scatter chart.

Charts are used to visualize data and easily compare numbers. Excel offers a wide variety of
chart types. This section does not discuss which type is best suited for each situation.

Despite the large number of chart types, there are essentially only a limited number of basic
types.

Figure 10.1: Basic chart types.

All these basic types have many variants, which can initially cause confusion. Choosing a good
chart type for visualizing data is important. Ask yourself questions like:

• What should the chart convey?
• What facts are being compared?

10.1 Column Chart

Column charts are most suitable if the data includes time units like years, quarters, months,
weeks, and days. Avoid using too many data points; a maximum of five to six values is ideal. If
you have more than six values on the horizontal axis, a line chart is preferable.

Figure 10.2 shows the market shares of some supermarket chains in the Netherlands from 2012
to 2016 (source: Distrifood).

Figure 10.2: Market shares for some supermarket chains from 2012-2016.

This data is best displayed in a column chart, as shown in Figure 10.3.
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Figure 10.3: Column chart of market shares for some supermarket chains.

Task 10.1. File: Chart_Column.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Insert Column or Bar Chart (Charts group) > Clustered Column.

4. Change the titles:

• Chart title: Market shares of supermarket chains
• Vertical axis title: Market share (%)

5. Choose Insert > Text Box (Text group).

6. Draw a rectangle in the bottom right corner with the mouse, and then type the text “Source:
Distrifood”.

7. Select the text, Right mouse click > Font > tab Font > Size 9 > OK.

10.2 Bar Chart

Bar charts are widely used to clearly show differences in ranking. They can effectively express
the importance (priority) of certain items at a specific moment.

The results are usually sorted from highest to lowest, so the highest result is displayed as the
first bar.

Figure 10.4 shows the percentage of smokers by age group in 2009 (source: CBS).

The data should be displayed in a bar chart, as shown in Figure 10.5.

Task 10.2. File: Chart_Bar.xlsx

1. Open the file.

2. Sort the table by the percentage of smokers, from highest to lowest.
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Figure 10.4: Percentage smokers in 2009.

Figure 10.5: Bar chart of the percentage of smokers in 2009.

Figure 10.6: Percentage of smokers in 2009, sorted from highest to lowest.
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3. Select any cell in the data area.

4. Choose tab Insert > Insert Column or bar Chart (Charts group) > Clustered Bar.

The bar chart appears in the worksheet with the longest bar at the bottom. This is Excel’s default
setting, but the order and the title need to be changed.

Figure 10.7: Default bar chart with the longest bar at the bottom.

5. Select the vertical axis, Right mouse click > Format Axis. The Format Axis task pane
appears.

6. In Axis Options select Categories in reverse order.

7. Change the chart title to “Percentage of Smokers in 2009”.

10.3 Pie Chart

Pie charts are mainly used to display the percentage distribution of data within a group, such as
election results. Too much information can make a pie chart cluttered. For clarity, a pie chart
should have at most six or seven sectors.

Table 10.1 shows the results of a survey asking 150 pupils about their favorite pet.

Table 10.1: Favorite pet survey results.

Pet Frequency

Cats 70
Dogs 38
Birds 22
Fish 13
Others 7

The data should be displayed in a pie chart, as shown in Figure 10.9.
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Figure 10.8: Format Axis task pane.

Figure 10.9: Pie chart of favorite pets.
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Task 10.3. File: Chart_Pie.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Insert Pie or Doughnut Chart (Charts group) > Pie.

4. Add data labels and position them Outside End.

5. Select the data labels, right-click and select Format Data Labels. The Format Data Labels
task pane appears.

6. In the task pane, select Category Name and Percentage, and deselect Value.

Figure 10.10: Formatting label options.

7. Remove the legend.

8. Change the chart title in “Favorite Pet of 150 Pupils”.

INFO Note

Choosing Data Call Out instead of Outside End for data labels immediately displays the
category names and percentages. Try it.

10.4 Line Chart

Line charts visualize trends in data over time. In line charts, the time unit is plotted along the
horizontal axis (the category axis), and the measured variable is plotted along the vertical axis.
A line connects the points on the graph to visualize the trend in data over time.

Figure 10.11 shows annual temperature data (°C) for Amsterdam Airport Schiphol (source:
https://en.tutiempo.net/climate/ws-62400.html).

• T = Average annual temperature
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• Tmax = Annual average maximum temperature
• Tmin = Average annual minimum temperature

Figure 10.11: Average annual temperature at Amsterdam Airport Schiphol.

The data is to be displayed in a line chart, as shown in Figure 10.12.

Figure 10.12: Line chart of average annual temperature for Schiphol.

Task 10.4. File: Chart_Line.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Recommended Chart (Charts group) > Line.

4. Change the titles:

• Chart title: “Annual Temperatures Amsterdam Schiphol Airport”
• Vertical axis title: “Temperature (°C)”.

5. Select the chart and change the style using Chart Design > Chart Styles. Choose a style
you like.
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10.5 Scatter (XY) Chart

A scatter chart (or XY diagram) is suitable for analyzing and showing the relationship between
two numeric variables. It also allows you to determine a trend line. The chart plots the values of
two numeric variables against each other, with each pair forming a point in the chart.

Figure 10.13 shows data from an investigation into the relationship between body length and
weight for 10 students.

Figure 10.13: Investigation of body length vs. weight.

The data should be displayed in a scatter chart, as shown in Figure 10.14.

Figure 10.14: Scatter chart of length vs. weight.

Task 10.5. File: Chart_Scatter.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Insert Scatter (XY) or Bubble Chart (Charts group) > Scatter.

4. Change the titles:

• Chart title: “Relationship between Body Length and Weight”
• Horizontal axis title: “Length (cm)”
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• Vertical axis title: “Weight (kg)”

5. Change the scale of the horizontal axis to run from 160 to 190, with increments of 5.

6. Change the scale of the vertical axis to run from 40 to 80, with increments of 5.

10.6 Doughnut Chart

A doughnut chart is an extension of the pie chart. It can contain one or more rings, with each
ring representing a data series. Use a doughnut chart to show the percentage distribution of
multiple data series.

Figure 10.15 shows the quarterly sales of a company for 2008 and 2009.

Figure 10.15: Sales by quarter.

This data should be displayed in a doughnut chart, as shown in Figure 10.16.

Figure 10.16: Doughnut chart of sales by quarter.

Task 10.6. File: Chart_Doughnut.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Insert Pie or Doughnut Chart (Charts group) > Doughnut.

Some adjustments are still needed. In this example, some of the formatting will be applied using
a predefined chart style.
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4. Change the chart title to “Sales 2008-2009 by quarter”.

5. Select the chart and change the style using Chart Design > Chart Styles. Choose a style
you like.

10.7 Area Chart

Area charts are based on line charts. The area between the axis and the line is typically
emphasized with colors or hatching. Like a line chart, an area chart plots the size of a variable
against time. In a stacked area chart, multiple data series are placed on top of each other,
showing the sum of the data. Area charts effectively visualize trends.

A company sells three products: A, B, and C. Figure 10.17 shows the sales quantities during the
first half-year.

Figure 10.17: Sales quantities by month.

The data is to be displayed in a stacked area chart, as shown in Figure 10.18.

Figure 10.18: Stacked area chart of sales quantities by month.

Task 10.7. File: Chart_Area.xlsx

1. Open the file.

2. Select any cell in the data area.

3. Choose Insert > Recommended Charts (Charts group) > Stacked Area > OK.

4. Change the chart title in “Number of items sold”.

5. Select the legend, then right-click and choose Format legend. Change the legend’s position
from Bottom to Right.
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10.8 Bubble Chart

A bubble chart can display the relationship between three numeric variables.

It is an extension of the scatter chart. While a scatter chart plots two numeric variables (X and
Y) against each other, a bubble chart adds a third variable (Z). The point in the scatter chart is
replaced by a bubble (or circle). The center of the bubble is determined by the X and Y variables,
and the bubble’s size (radius) is determined by the Z variable. Other bubble characteristics, such
as color, can indicate additional qualitative, non-numeric differences.

Figure 10.19 shows the relationship between market share, turnover, and the number of prod-
ucts.

Figure 10.19: Market shares.

The data is to be displayed in a bubble chart, as shown in Figure 10.20.

Figure 10.20: Bubble chart of market shares.

Task 10.8. File: Chart_Bubble.xlsx

1. Open the file.

2. Format the values for turnover and market share appropriately.

INFO Note

Proper formatting of the source data ensures proper formatting in the chart.
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3. Select any cell in the data area.

4. Choose Insert > Insert Scatter (XY) or Bubble Chart (Charts group) > 3-D Bubble.

5. Make the following changes:

• Chart title: “Market shares”
• Horizontal axis title: “Number of products”
• Vertical axis title: “Turnover”
• Scale the vertical axis: 0 to 70000 (set the minimum to fixed 0 and the maximum to

fixed 70000)
• Color bubbles: orange/golden
• Data labels: position centered, display the percentage of market share

The added data labels are not the desired ones. By default, the Y value (turnover in this case) is
displayed. Change this to the bubble size, which represents the market share.

6. InLabel Contains, select only Bubble Size.

10.9 Radar Chart

A radar chart plots multiple data series (categories) along separate axes that start from a central
point (the origin). The chart resembles a spider web and is also called a spider chart or star chart.
The angles between the axes are equal, and the data points on the axes are usually connected by
a line.

Figure 10.21 shows the scores of a self-evaluation on a 5-point Likert scale.

The data should be displayed in a radar chart, as shown in Figure 10.22.

Task 10.9. File: Chart_Radar.xlsx

1. Open the file.

2. Select any cell in the data area.
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Figure 10.21: Self-evaluation on a 1-5 scale.

Figure 10.22: Radar chart of self-evaluation.
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3. Choose Insert > Insert Surface or Radar Chart (Charts group) > Radar.

4. Change the chart title in “Self-evaluation”.

10.10 Pareto Chart

A Pareto chart combines a column chart and a line chart. The column chart displays values
sorted from largest to smallest, while the line chart, placed on top of the columns, shows the
cumulative percentage. The column chart uses the regular Y-axis on the left, and the line chart
uses a second Y-axis on the right with values from 0% to 100%.

Pareto charts are often used in quality control to identify the most significant factors.

Figure 10.23 shows the main causes of death in the Netherlands in 2009 (source: CBS).

Figure 10.23: Causes of death in the Netherlands in 2009.

The data should be displayed in a Pareto chart, as shown in Figure 10.24.

Figure 10.24: Pareto chart of causes of death in 2009.

Task 10.10. File: Chart_Pareto.xlsx

1. Open the file.

2. Select any cell in the data area.
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3. Choose Insert > recommanded charts > tab All Charts > Histogram > Pareto.

4. Change the chart title and add data labels.

10.11 Control chart

Control charts are used in statistical process control (SPC) to verify that a process variable is
under control. The value of such a variable must remain within certain limits. A control chart
is essentially a line chart of the variable’s measurements with horizontal lines for the control
limits.

Limits

• UCL: Upper Control Limit

• LCL: Lower Control Limit

The control limits are calculated from the data and are typically set at 2-3 standard deviations
from the mean, depending on the process type. Often, a horizontal line representing the mean
(CL - Central Line) is also included in the control chart.

Task 10.11. File: Chart_Control.xlsx

For example, consider a continuous chemical process where the temperature of the reaction mixture
is monitored hourly. Proper control of this process requires the temperature to remain within 2
standard deviations of the mean.

Figure 10.25: Control chart for the temperature in a chemical reactor.
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1. Open the file. The file contains a table with hour and temperature data.

2. Enter formulas in cells H1 and H2 to calculate the mean and standard deviation of the
temperature data.

3. Enter the following formulas

• In column CL: =$H$1

• In column UCL: = $H$1 + 2*$H$2

• In column LCL: = $H$1 - 2*$H$2

4. Select all data in the table and insert a line chart with markers.

5. Adjust the layout as desired.

LIGHTBULB You can find extensive information about SPC and control charts online. A useful article
is Control Limits and Specifications: The Four Process Statesa

ahttps://www.spcforexcel.com/knowledge/variation/four-process-states

10.12 Line or Scatter Chart?

Line charts and scatter charts appear quite similar, especially when a scatter chart is displayed
with connecting lines. However, there are significant differences in how data is plotted along the
horizontal axis (x-axis) and the vertical axis (y-axis). Therefore, it’s crucial to make the right
choice to avoid misinterpretations.

Example 10.1. Annual Sales Data

Figure 10.26 tshows the annual sales data of a company plotted with a line chart and a scatter
chart.

Figure 10.26: Sales per year. Line chart on the left, scatter chart on the right.

The difference in scaling can lead to incorrect conclusions. The line chart suggests strong growth
in the early years and stagnation in recent years, which is misleading. The scatter chart accurately
represents the growth.

Line chart

• Vertical: value axis
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• Horizontal: category axis

The horizontal axis has evenly spaced categories of data (text or dates). A date axis displays
dates in chronological order.

Line charts are suitable for displaying the change of a variable over time. Examples include sales,
turnover, profit, price, etc., by day, week, month, quarter, or year. The time unit is always on
the horizontal axis, and the value of the measured variable is on the vertical axis.

Scatter chart

• Vertical: value axis
• Horizontal: value axis

The horizontal axis can display numeric or date values, and you can change the scaling options
of both axes. The chart displays points at the intersection of the x-value and the y-value.

Scatter charts are used to examine the relationship between two variables. They help determine
how one variable changes in response to changes in the other. The data values are displayed as
separate points on the chart.

While you can connect the points with lines, it’s generally not recommended because it implies
that the changes follow those lines. It’s better to represent the relationship with a trendline,
which is a line that best reflects the relationship between the two variables. The measured points
may lie on or be distributed around the trendline.

Scatter charts are commonly used in science and technology. Management reports may also
include scatter charts, for example, to analyze the correlation between price increases and sales.

10.13 Translation of Chart Type Names

Table 10.2: Dutch, English, and German names of some chart types.

NL EN DE

Bellendiagram Bubble chart Blasendiagramm
Cirkeldiagram Pie chart Kreisdiagramm
Kolomdiagram Column chart Säulendiagramm
Lijndiagram Line chart Liniendiagramm
Ringdiagram Doughnut chart Ringdiagramm
Radardiagram Radar chart Netzdiagramm
Spreidingsdiagram Scatter (XY) chart Punktdiagramm
Staafdiagram Bar chart Balkendiagramm
Vlakdiagram Area chart Flächendiagramm
Watervaldiagram Waterfall chart Wasserfalldiagramm
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OBJECTIVES

• What is a scenario.
• Create a scenario.

A scenario is a what-if model. It allows you to explore and calculate different potential future
situations (scenarios) without directly changing the values in your worksheet.

In a scenario, you assign different values to specific variable cells (known as changing cells)
and then calculate the resulting effect of those changes on your designated result cells. The
result cells contain formulas that reference the changing cells.

For example, you might want to compare best-case and worst-case scenarios for a coffee shop’s
annual profit, based on varying costs. In this case, the result cell would be the cell where the
profit is calculated, and the changing cells would be the cells containing the cost values.

Identifying the changing cells and the result cells is crucial when creating scenarios.

Using Excel’s Scenario Manager, you can create different sets of input data to calculate the
corresponding outcomes. You can save each set as a named scenario (e.g., “Most Optimistic,”
“Most Pessimistic,” etc.). Then, you can easily compare the different outcomes using a generated
summary report. This report displays both the input values for the changing cells and the
resulting values of the result cells.

INFO Note

It is recommended to always save the current situation in a scenario, for example under the
name Current.

11.1 Coffee Bar

Figure 11.1 shows a calculation model for a coffee bar. The gray cells represent the variable
cells.

In addition to analyzing the current situation, the owner of “The Brown Bear” coffee bar wants
to explore two other scenarios to understand their potential impact on profit:

Higher prices, less salary and advertising: This scenario involves a 10% increase in prices, a
$30,000 reduction in salary expenses, and a $5,000 reduction in advertising expenses.

Higher prices, less order costs and more advertising This scenario features a 5% increase in
prices, a 5% decrease in order costs, and a $2,000 increase in advertising expenses.

Task 11.1. File: BrownBean.xlsx

1. Open the file.
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Figure 11.1: Calculation model for a coffee bar.

Examine the model carefully. Identify the cells that will change and the cell that shows the final
result. Review the formulas used and note that all cells have defined names.

INFO Note

Using meaningful names for your cells, rather than just cell addresses, will make the summary
report easier to interpret.

2. Go to tab Data > What-If Analysis (Forecast group) > Scenario Manager.

3. Click Add.

4. Complete the Add Scenario dialog box as shown in Figure 11.3. When selecting the Changing
cells, use the CTRL key to select multiple ranges.

5. Click OK. The Scenario Values window will appear, pre-filled with the current values of
the changing cells.

6. Click Add to enter a new scenario.

7. Name the scenario “Higher prices, less salary and advertising”. Add a brief description if
you’d like, and then click OK.

The Scenario Values dialog box will reappear, still displaying the current values of the changing
cells.

8. Now, enter the new values for the cells that will change in this scenario. Instead of manually
calculating these values, you can enter formulas, and Excel will automatically calculate the
result.
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Figure 11.2: Scenario Manager dialog box.

Figure 11.3: Dialog box to record the current situation in a scenario.
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Figure 11.4: Dialog box showing current values for the “Current” scenario.

• Yield_per_Order: =1.1*2.5
• Salaries: =300000-30000
• Advertisement: =20000-5000

9. Click OK.

Exclamation-Triangle Warning

If you’ve used formulas, a warning message will appear, indicating that the entered formulas
will be replaced by their calculated results.
Confirm by clicking OK

10. In the same way, create another scenario named “Higher prices, less order costs and more
advertising” and adjust the cell values accordingly.

After you’ve added the last scenario, you’ll be taken back to the Scenario Manager dialog box,
which will now list all three scenarios (Figure 11.5).

11. Select each scenario one at a time, and then click Show.

In the worksheet, the values in the changing cells, and the cells that are dependent on them, will
be updated to reflect the selected scenario.

12. Click Summary to generate a report.

A dialog box will appear (Figure 11.6), allowing you to choose the type of summary you want.
The result cell (containing the profit calculation) will already be filled in by Excel.

13. Click OK.

A summary report will be created in a new worksheet. Notice that the left column displays the
assigned cell names, rather than cell addresses, making the report easier to understand.

11.2 Exercises

Exercise 11.1. Profit Margin - Sales Price (scen001)

File: Scen001.xlsx
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Figure 11.5: Dialog box displaying the three scenarios.

Figure 11.6: DialogScenario Summary dialog box.

Figure 11.7: Summary report.
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Create the following table as accurately as possible. Use formulas to calculate the margin, VAT,
and selling prices.

Use the Scenario Manager to determine the selling prices (including VAT) for profit margin rates
of 15%, 20%, 25%, and 30%. The output should resemble the following:

Exercise 11.2. Budget - Sports Club (scen002)

File: Scen002.xlsx

The figure below shows a simplified budget for a sports club. The rent is a fixed amount. For
the other items, reasonable estimates of the lower and upper limits are provided:

• Subscription revenues range from $1,800 to $2,400.
• Canteen revenues range from $600 to $800.
• Material costs range from $500 to $800.
• Miscellaneous costs range from $400 to $700.

Enter the model in a worksheet. Create with the Scenario Manager the most positive and most
negative scenario. The output should look like the following:
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Exercise 11.3. Scenarios business profit (scen003)

File: Scen003.xlsx

A company makes three products (A, B en C). To manufacture each product a different number
of working hours and materials is needed. In the following figure, you see the rates for labor
and material costs as well as the quantities needed to make these products. Also, the costs and
revenues are calculated for the current production quantities.

Enter the model in a worksheet. Provide the right formulas in the cells in which values have to
be calculated.

Management wants a prediction of the operating profit, but there is still some uncertainty about
the amount of labor and material costs. For the prediction are therefore three scenarios available:
the favorable case, the bad case, and the current (most likely) case. The different rates are listed
in the following table.

scenario wages material costs

favorable $ 60 $ 114
bad $ 76 $ 124
current $ 68 $ 118

Create a summary report for these three scenarios using the Scenario Manager.
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Exercise 11.4. Automation Company Earnings(scen004)

File: Scen004.xlsx

The revenues and expenditures of an automation company for 2010 are shown in the figure
below. The executive board wants to create a profit forecast for 2011 and 2012. The revenues
and expenditures for these two years are influenced by the following factors:

• All revenues increase by a growth factor, currently 10%.
• All expenditures, except interest, increase by an inflation factor, currently 3%.
• The interest rate is currently 8%.
• The tax percentage is currently 35%.

Create this model in a worksheet. The revenues and expenditures for 2010 are fixed and these
should be calculated for 2011 and 2012. Provide the right formulas in the cells whose values have
to be calculated.

Management wants a prediction of the profit forecast, but there is still some uncertainty about
the development of some factors that affect the profit. The central planning bureau has released
predictions of these factors. Based on these predictions three scenario’s are computed:

Create this model in a worksheet. The revenues and expenditures for 2010 are fixed, and the
values for 2011 and 2012 should be calculated using formulas.
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OBJECTIVES

• Understand the layout and operation of a data table with one input variable.
• Understand the layout and operation of a data table with two input variables.

A data table is a tool for “what-if” analyses. It allows you to quickly calculate results for formulas
with one or two variables, using different values for those variables. This helps you track how
small changes in input values affect the results of formulas that depend on those inputs. For
example, you can analyze how changes in an item’s price affect the company’s sales. This type of
analysis is often called sensitivity analysis. The only limitation is that you can use a maximum
of two variables in the formulas.

Excel offers two types of data tables:

• One-variable data table: Uses one input variable and one or more formulas.
• Two-variable data table: Uses two input variables and one formula.

Both types of data tables operate in a similar way:

• Define a set of input values for the variables.
• Identify the formulas that depend on these variables.
• Execute the Data Table command.

Excel then substitutes each input value into the formulas, calculates the results, and displays
them in a table format.

12.1 One-Variable Data Table

If you want to calculate the result of a formula with one variable for various values of that
variable, you can do so by creating two columns: one for the variable’s values and the other for
the formula’s results.

Figure 12.1 illustrates this for the formula 𝑦 = 2 ∗ 𝑥 − 1.

Figure 12.1: Example with formulas in each cel.
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However, in such cases, it’s much more convenient to create a data table with one input cell.

In a column-oriented table, your variable values are arranged in a column, and the formula is
placed one row above and one cell to the right of the column of values. You can enter additional
formulas in the cells to the right of the first formula.

In a row-oriented data table, the variable values are in a row, and the formula(s) are in the cell
one column to the left of the first value and one cell below the row of values. You can enter
additional formulas in the cells below the first formula.

Figure 12.2: General layout of a data table with one input cell.

INFO Note

1. The input cell can be any cell on the worksheet. Excel uses this cell as a temporary
storage location. The formulas must reference this input cell. The values for the
variable are sent to this input cell, the result is calculated, and then it’s placed in the
table.

2. Instead of formulas, you can also use references to formulas.

12.2 Rental Cottage

Here’s a simple example of a data table with one input cell.

A summer cottage can be rented for $450 a week. The weekly expenses are $175. Use a data
table to calculate the revenue for 5, 10, 15, …, 50 weeks.

The data table will be in the range A7:B17. The formula referencing the input cell B5 will be
in B7. The values for the variable will be in the range A8:A17, and the results will go into
B8:B17.

Task 12.1. File: Rental_fixed.xlsx

1. Open the file.
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Figure 12.3: Rental cottage with a fixed price.

2. In cell B7, enter the formula =B5*(B3-B4).

3. Select the range for the data table, A7:B17.

4. Choose Data tab > What-If Analysis (Forecast group) > Data Table.

Figure 12.4: Input cells for Data Table.

5. Click inside the Column input cell box, and then click on cell B5.

Excel will change the cell address to $B$5.

6. Click OK.

TThe data table will be populated with the calculated values.

The formula in the result cells is an array formula: {=TABLE(,B5)}. You can verify this.

12.3 Calculating Multiple Formula Values

Here’s an example using a data table with one input cell to calculate values for multiple formulas.

The task is to calculate the y-values of four functions for different x-values.
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Figure 12.5: Calculation model for 4 formulas.

The input cell will be B1. This is where the different x-values will be entered. The formulas used
are shown in cells C2:F2, and the formulas themselves are in cells C3:F3. The x-values are in
cells B4:B9.

Task 12.2. File: Function_values.xlsx

1. Open the file.

2. Enter the correct formulas in cells C3:F3:

• C3: =2*B1-1
• D3: =-3*B1+2
• E3: =B1^2
• F3: =B1^2-2*B1+1

3. Select the range for the data table, B3:F9.

4. Choose tab Data > What-If Analysis (Forecast group) > Data Table.

5. Click inside the Column input cell box, and then click on cell B1.

6. Click OK.

Figure 12.6: Results of the formulas in a data table.

The formula in the result cells is an array formula: {=TABLE(,B1)}. You can verify this.

164



12 Data Tables

12.4 Two-Variable Data Table

The two-variable data table uses a formula that contains two sets of input values. The formula
must refer to two different input cells: the row input cell and the column input cell.

Figure 12.7: General layout of a data table with 2 input cells.

The overall layout resembles a data table with one input cell, but there are some important
differences:

• A data table with one input cell can evaluate multiple formulas, while a table with two
input cells can only calculate the results from one formula.

• The values for the variables are arranged in both a column and a row.
• The upper-left cell must contain the formula (or a reference to the formula).

12.5 Rental Cottage with Variable Price

Here’s an example of a data table with two input cells.

A summer cottage can be rented for $350-$600 per week, with the price varying by season. The
weekly expenses are fixed at $175. Use a data table to calculate the revenue for 5, 10, 15, …, 50
weeks and rental prices of 350, 400, 450, …, 600.

The data table will be in the range A7:G17. The two input cells are B3 (rental price) and B5
(number of rental weeks). Cell A7 contains a formula that references the two input cells. The
values for input cell B3 are in row B7:G7. The values for input cell B5 are in column A8:A17.

Task 12.3. File: Rental_variable.xlsx

1. Open the file.

2. In cell A7, enter the formula =B5*(B3-B4).

3. Select the range for the data table, A7:G17.

4. Choose Data tab > What-If Analysis (group Forecast) > Data Table.

5. Click inside the Row input cell box, and then click on cell B3.
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Figure 12.8: Rental cottage with a variable price.

6. Click inside the Column input cell box, and then click on cell B5.

7. Click OK.

The formula in the result cells is an array formula: {=TABLE(B3,B5)}. You can verify this.

12.6 Revenues from an Advertising Campaign

Here’s an example of a two-variable data table used to calculate the effect of an advertising
campaign.

A company wants to run an advertising campaign by sending direct mail flyers to potential
customers. We’ll use a calculation model to calculate the expected profit of this campaign.

The calculation model uses two variables: the number of flyers sent and the response percentage.
The printing and shipping costs, as well as the expected revenue per response, are fixed values.
The number of responses, total revenue, costs, and profit are calculated using formulas.

The range for the data table is B14:I23. The two input cells are B1 and B2. The values for
input cell B1 are in column B15:B23. The values for input cell B2 are in row C14:I14. Cell B14
contains a reference to the total profit formula, which in turn references the two input cells.

File: Advertising_Campaign.xlsx

1. Open the file.

2. Select the range for the data table, B14:I23.

3. Choose Data tab> What-If Analysis (Forecast group) > Data Table.

4. Click inside the Row input cell box, and then click on cell B2.
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Figure 12.9: Calculation model for an advertising campaign.

5. Click inside the Column input cell box, and then click on cell B1.

6. Click OK.

Figure 12.10: Results of the advertising campaign.

The formula in the result cells is an array formula: {=TABLE(B2,B1)}. You can verify this.

12.7 Exercises

Exercise 12.1. Loan Repayment (tabl001)

A loan of $10,000 must be repaid over a certain number of months at an annual interest rate of
5%. The monthly repayment amount is calculated using the PMT function. The figure below
shows an example for a repayment period of 36 months.
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Figure 12.11: Calculation of monthly loan repayment.

1. Create the model shown above in a new worksheet, and create a formula for the monthly
repayment.

2. Create a data table that shows the monthly repayments for repayment periods of 12, 18,
24, 30, …, 72 months.

3. Create a new data table that shows the monthly repayments for repayment periods of 12,
18, 24, 30, …, 72 months, and annual interest rates of 3%, 3.5%, 4%, 4.5%, …, 6%.

Exercise 12.2. Sales Forecast (tabl002)

A worksheet contains a forecast of sales in 2014, based on sales in 2013 and an estimated sales
growth rate.

Figure 12.12: Sales Forecast.

1. Create the model shown above in a new worksheet, and create a formula for the sales
forecast for 2014.

2. Create a data table that shows the sales forecast for growth rates of 1%, 2%, …, 10%.
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OBJECTIVES

• Understand the features of a PivotTable.
• Learn how to create PivotTables.
• Identify source data from a PivotTable.
• Group date/time data.
• Filter a PivotTable using report filters, slicers, and timelines.
• Create PivotCharts.

A PivotTable is a powerful data summarization tool. It’s an interactive, dynamic table that
allows you to quickly and easily summarize, combine, and compare large amounts of data. For a
PivotTable to function correctly, the data must be well-organized in a worksheet.

PivotTables are particularly useful when you need to analyze variables in relation to other
variables, helping you answer questions such as:

• Which product contributes the most to profit?
• Which salesperson generates the highest revenue?
• Which department incurs the most costs?
• …

Example 13.1. Sales by Category

The PivotTable in Figure 13.1 allows for an easy comparison of revenue across three product
categories.

Figure 13.1: Example of a PivotTable showing product categories plotted against locations.

A PivotTable plots at least two types of data against each other. One data type is placed in the
column field (here, productcategory), and the other in the row field (here, town). Additionally, a
data type for which you want to see results must be placed in the value field (here, Sales).

Since these results are summarized, you also need to specify the calculation method; in this case,
Sum is the default choice.

A PivotTable has four areas where you can place fields:
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Table 13.1: Areas in a PivotTable.

Area Description

Values Fields with numeric information you want to summarize, typically for
calculating totals and averages.

Rows Fields used to create distinct groups, with information for each group
displayed in a separate row.

Columns Fields also used to create distinct groups, often for subdividing data
within rows. These groups are displayed in separate columns. Choose
fields with a manageable number of groups to prevent the table from
becoming too wide.

Filters Fields used to filter the data.

13.1 Creating PivotTables

The file for this task contains the monthly sales in 2016 for three supermarkets across different
products, as shown in Figure 13.2. These products are categorized into three groups: PVF
(potatoes, vegetables, fruit), meat, and dairy. This data will be analyzed using a PivotTable.

Figure 13.2: Table displaying sales data.

Information needed: What are the total sales per town per product category?.

Task 13.1. File: Supermarket.xlsx

1. Open the file.

2. Select any cell within the table. Choose tab Insert > PivotTable (Tables group) > From
Table/Range.

The Create PivotTable dialog box will appear, with the table range already populated.
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Figure 13.3: Selecting the data range for the PivotTable.

3. For this task, the PivotTable should appear in the existing worksheet. Select Existing
Worksheet and click on an empty cell in the worksheet, for example, cell G3.

Figure 13.4: Specifying the PivotTable location.

4. Click OK.

An empty PivotTable will be created on the worksheet, and a task pane will appear on the right
side with the PivotTable Fields, where you can add fields to the report.

INFO Note

The task pane with the field list is shown when a cell in the PivotTable is active. If you
click on a cell outside the PivotTable, the task pane disappears. It reappears when you click
on any cell within the PivotTable.

5. In the task pane, drag the town field to the Rows area, the productcategory field to the
Columns area, and the sales field to the Values area. When the sales field is added to Values,
the Sum calculation method is applied automatically.

LIGHTBULB Tip

You can remove a field from the PivotTable by dragging it out of its area.

The PivotTable in the worksheet will be populated with the data.
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(a) Empty PivotTable on the worksheet.

(b) PivotTable Fields task pane.

Figure 13.5: Creating a PivotTable.
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Figure 13.6: Fields selected for the PivotTable.

Figure 13.7: PivotTable report showing sales per month per product.
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Task 13.2. Formatting Values as Accounting Numbers

1. Select any numeric value in the PivotTable. Choose tab PivotTable Analyze > Field Settings
(Active Field group.

Figure 13.8: Value Field Settings dialog box.

INFO Note

The Value Field Settings dialog box is crucial when creating PivotTable reports. Here,
you can configure various options, such as:

• The name to be displayed, using the Custom Name box.
• The calculation method (default is Sum). Other options include: Count, Average, Min,

Max, Product, Stdev, Stdevp, Var, Varp.
• How you want to display the values, for example, as percentages of the row or column

total.

2. Click the Number Format button. The Format Cells dialog box will be displayed.

3. Choose the category Accounting > Decimal places: 0 > Symbol: $.

4. Click OK > OK.

The value fields in the PivotTable will now appear in the specified format.

Task 13.3. Changing Column Labels and Row Labels to Field Names

Select any cell in the PivotTable. Choose tab Design > Report Layout (Layout group) > Show in
Outline Form.

Task 13.4. Analyzing Products Within Each Product Category

1. Drag the productcategory field from Columns to Rows and the town field from Rows to
Columns. Then, drag the product field to Rows, placing it below the productcategory field.
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Figure 13.9: Formatting the Sum of Sales field.

Figure 13.10: Formatted PivotTable: Sales per town per product category.

Figure 13.11: Fields used in the PivotTable.
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Figure 13.12: PivotTable report with two row fields.

Instead of total sales, you can also calculate other values, such as the average monthly sales.

2. Select any numeric value in the PivotTable and, using Field Settings (see Figure 13.8),
change the calculation type to Average.

Task 13.5. Top 3 products

Now try to answer the following question using PivotTables:

Which three products generate the most sales?

13.2 Finding Data Sources

A PivotTable contains summarized data. In this task, you will learn how to find the source of
this data.

A worksheet contains employee data such as sales, expenses, and commission per month and
per region. A PivotTable showing sales per region per employee has been created in another
worksheet.

Figure 13.13: Sales per region per employee.
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If you want to see the individual values that make up a result, Excel can show you this quickly
and easily. By double-clicking on a result, Excel creates a new worksheet containing a table with
the source data.

Task 13.6. File: Sales.xlsx

1. Open the file.

2. Select the PivotTable worksheet and double-click on the results for Jansen in the East region.

A new worksheet with a list of all information about Jansen in the East region will be created.

Figure 13.14: Data for Jansen in the East region.

13.3 Grouping Data

You can make a cluttered list of data more suitable for analysis by grouping it. This is especially
true when the data contains dates. Dates can often be grouped into years, quarters, or months.
In a PivotTable, you can view data by year, quarter, or month.

Example 13.2. Revenue per Salesperson

Figure 13.15 shows part of a PivotTable displaying revenue per salesperson. In the left image,
the revenue is in date order (ungrouped). In the right image, the revenue is grouped by quarter
and by month.

Starting with version 2016, Excel includes a time grouping feature that automatically discovers
and groups time-related fields. AutomaticallyWhen you add such a field to a PivotTable, new
relevant fields like Years, Quarters and Months are automatically created..

Which date/time fields are added depends on the level of detail of the date/time field in the data
table. For example, if the date data is in days and spans more than a year, additional fields are
created for months, quarters, and years.

Once these fields have been added, you can begin analyzing the data across different time periods
using zoom-in options, which can sometimes reveal additional insights.

Example 13.3. Quarterly Comparison by Year

For example, to get a quarterly comparison over several years, you can place the Years field in
the Columns box and the Quarters field in the Rows box.

The + button in the PivotTable indicates a collapsed level. Clicking this button expands all
elements in the PivotTable to the next level (here, Months). The + button then changes to a -
button, allowing you to collapse the group again. This is also known as zooming in or drill-down.
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Figure 13.15: Revenue per salesperson: Ungrouped (left) and grouped by quarter/month (right).

Figure 13.16: Sales per quarter per year.
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Custom grouping You can adjust the grouping by right-clicking on a date/time field in the
PivotTable and then choosing Group. In the Grouping dialog box that appears, you can
add or remove other time levels.

Ungroup You can cancel a group by right-clicking on a grouped field in the PivotTable and then
choosing Ungroup.

13.4 Grouping Example

This is an example of grouping data based on a date field.

Task 13.7. File: Invoices.xlsx

1. Open the file.

The file contains a data table named SalesData with columns Region, Salesman, InvoiceNr,
InvoiceDate, ProductCategory, and InvoiceAmount.

First, a PivotTable with sales per salesman per product category will be created.

2. Select any cell in the table. Choose tab Insert > PivotTable (Tables group).

Figure 13.17: Specifying the data range and location for the PivotTable.

INFO Note

• Since the data area here is a table named SalesData, this name is automatically filled
in instead of cell addresses.

• To have the PivotTable appear on a new worksheet, accept the default option New
Worksheet.
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3. Click OK.

4. Create a PivotTable according to the design in Figure 13.18 and format the amounts as
currency. The result can be seen in Figure 13.19.

Figure 13.18: PivotTable design layout.

Figure 13.19: Sales per salesperson per product category. Note the significant differences by
seller.

5. Drag the InvoiceDate field to the Rows area, placing it below the Salesman field. Excel’s
automatic time grouping feature will create two calculated fields, Years and Quarters, in
the Rows area.

In the PivotTable (Figure 13.21), sales are now grouped by year. This also shows that Brown
started as a seller in 2011, not 2010, which could explain the lower amounts.

6. Click the + (plus) button next to any seller for the year 2010. This will expand the year to
quarters for all sellers.

7. Click the + (plus) button for Q1 next to any seller. As a result, the quarter will unfold to
months for all sellers.

8. Experiment with unfolding and folding levels again.

9. Drag the ProductCategory field out of the Columns box. Drag the Quarters field from Rows
to Columns, and drag the Years and InvoiceDate fields out of Rows. The design will now
look like Figure 13.23. The result can be seen in Figure 13.24.
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Figure 13.20: Adding Invoice Date automatically generates the Quarters and Years fields.

Figure 13.21: Sales per seller per product category, grouped by year.
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Figure 13.22: Expanded levels for the year 2010 and Quarter 1.

Figure 13.23: PivotTable design for sales per salesperson per quarter.

Figure 13.24: Sales per salesperson per quarter.
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To easily compare values, you can also choose to display percentages (of row total, column total,
or grand total).

10. Select a numeric value in the PivotTable and choose tab PivotTable Analyze > Field Settings
(Active Field group). In the dialog box, select the Show Values As tab and choose % of Row
Total.

Figure 13.25: Setting values to display as percentages of the row total.

11. Click OK.

Figure 13.26: Percentage of sales per salesperson per quarter.

12, Then display the values as % of Column Total.

Questions

Use the PivotTable capabilities to answer the following questions. There are multiple ways to
find the answers.

183



13 PivotTables

1. Which seller sold the most in December 2010?

2. In which month of which year were software sales the highest?

3. View hardware and software sales percentages by region. What is the percentage for
software in the South region?

4. In what quarter of what year were Anderson’s sales lowest?

5. Check out Brown’s sales in Q2 2011. Do you notice anything special?

13.5 Filtering

To filter data in a PivotTable, you can place one or more fields in the Filters box in the task pane.
However, when filtering on multiple items, it can be difficult to see what you are filtering on.

A more user-friendly way is to use slicers. These contain several buttons that allow you to quickly
filter data in a PivotTable. For filtering time data specifically, you can also use timelines, which
are similar to slicers.

Slicers and timelines are often used in dashboards because they can be linked to multiple
PivotTables and PivotCharts.

Three subtasks discuss creating report filters, slicers, and timelines. The file Supermarket.xlsx
is used for this, the same file as in Section 13.1, which contains the monthly sales data in 2016
for several products, classified into three product groups: PVF (potatoes, vegetables, and fruits),
meat, and dairy.

13.5.1 Report filters

Task 13.8. File: Supermarket.xlsx

1. Open the file.

2. Insert a PivotTable for the data on a new worksheet.

3. Place the productcategory field in Columns, the sales field in Values, and the date field in
Rows.

INFO Note

Excel’s automatic time grouping adds the calculated field Months to Rows. No other fields
like quarters and years are added because all dates are only the last day of the month within
a single year.

4. Drag the date field from Rows so that only the Months field is shown.

5. Place the town field in the Filters box. This will create a report filter in the PivotTable.

6. Click the drop-down arrow and select “Amsterdam”.

7. Click the drop-down arrow, check the Select Multiple Items box, and then select “Amsterdam”
and “Rotterdam”.
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Figure 13.27: PivotTable report with a filter for town (default showing all values).

Figure 13.28: PivotTable report with data filtered for Amsterdam (filter symbol indicates active
filter).

The data for both towns will be displayed. Unfortunately, the filter only indicates that multiple
items are selected, but not which specific items. For this scenario, slicers are a better alternative.

Figure 13.29: PivotTable report with data filtered for multiple towns (specific towns visible via
selection arrow).

8. Click the drop-down arrow and re-select the (All) option.

9. Remove the town field from the Filters box.

13.5.2 Slicers

Task 13.9. Continue with the file from Task 13.8.

1. Right-click on the town field in the PivotTable field list and select Add as Slicer.

A slicer will be created in the worksheet.

185



13 PivotTables

Figure 13.30: Slicer for the ‘town’ field.

2. Experiment with the slicer by selecting an item. You can select multiple items by holding

down the Ctrl key or by using the button.

Another way to create slicers is through the menu. This method allows you to add multiple slicers
at once.

3. Click anywhere in the PivotTable report and choose tab PivotTable Analyze > Insert Slicer
(Filter group).

Figure 13.31: Insert Slicers dialog box.

4. Select Months and click OK.

With the Slicer tab on the ribbon, you can format a slicer, such as changing its appearance,
settings, colors, etc.

5. Experiment with filtering the data using the two slicers.

6. Delete all slicers by first selecting a slicer and then pressing the Delete key.

13.5.3 Timelines

Timelines are similar to slicers. They also allow you to filter data, but they are specifically
designed for use with date/time fields. The dates appear in a horizontal line from oldest to
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newest as you move from left to right on the timeline.

Task 13.10. Continue with the file from Task 13.9.

1. Click anywhere in the PivotTable report and choose tab PivotTable Analyze > Insert
Timeline (Filter group).

The Insert Timeline dialog box only shows the date field because it is the only date/time field.

2. Select date and click OK.

INFO Note

Figure 13.32: Timeline for the ‘date’ field.

• A scroll bar for the visible period.
• Handles to select the period to filter on.
• Choice of the time period to be displayed (Years, Quarters, Months, Days).
• When you select a timeline, handles appear on the edges, allowing you to resize the

area.

3. Select some months to see the results.

4. Click on the period selector in the upper right corner and select Quarters.

Figure 13.33: Timeline displaying quarters.

5. Select some quarters to see the results.

6. Delete the timeline by selecting it and then pressing the Delete key.
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13.6 Pivot Charts

A PivotChart displays data series, categories, and chart axes in the same way a standard chart
does. However, it also provides interactive filtering, allowing you to quickly analyze a subset of
your data. You can also use slicers for filtering data in a PivotChart.

Task 13.11. File: Sales.xlsx

1. Open the file.

2. Select the PivotTable worksheet and then select any cell in the PivotTable on this worksheet.

3. Choose tab Insert > PivotChart (Charts group) > Clustered Column > OK.

Figure 13.34: Column chart, linked to a PivotTable.

The PivotChart has filters for Region and Salesman. When you use a filter in the chart, the data
in the PivotTable will also be filtered.

4. Experiment with filtering by a salesman and observe the results. End by displaying the data
for all salesmen.

5. Add a slicer for Month and experiment with it.

13.7 PivotTables Options

There are various setting options for PivotTables. To access them, select any cell in a PivotTable
and then choose tab PivotTable Analyze > Options (PivotTable group). You will find several
setting options organized into tabs (see below).
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Figure 13.35: Layout & Format options for PivotTables.
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Figure 13.36: Totals & Filters options for PivotTables.
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Figure 13.37: Display options for PivotTables.
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Figure 13.38: Printing options for PivotTables.
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Figure 13.39: Data options for PivotTables.
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Figure 13.40: Alt Text options for PivotTables.
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13.8 Exercises

Exercise 13.1. Salary Averages (pivo001)

File: Personnel.xlsx

Create a PivotTable to calculate the average salary per department and division. The table
should look as follows:

Exercise 13.2. Salary Totals (pivo002)

File: Personnel.xlsx

Create a PivotTable to calculate the total salary per function and per division. Furthermore, it
should be possible to filter by department. The table should look as follows:

Exercise 13.3. Revenue, Travel Expenses, and Commission (pivo003)

File: Pivo003.xlsx

For each salesman, the following information is stored in the worksheet: Month, Region, Salesman,
Sales, Expenses, and Commission.

Create one PivotTable to get an overview of the total sales, expenses, and commission per month
and per salesman, with the ability to filter by region. All values should have a currency format
with no decimals.

Exercise 13.4. Average Rating (pivo004)

File: Pivo004.xlsx

The following table shows the Information Technology (IT) marks for some students from two
different classes.
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Using a PivotTable, determine the average mark by class and by gender.

Exercise 13.5. Frequency Distribution Figures(pivo005)

File: Pivo005.xlsx

The following table shows the marks of some students.

Create a frequency distribution of the grades using a PivotTable.

Exercise 13.6. Clothing Sales by Region (pivo006)

File: Pivo006.xlsx

The following table shows menswear and ladieswear sales in four regions for the years 2009 and
2010.

Enter and format the data in a worksheet. Using a PivotTable, determine the total annual sales
per region and per type.
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Exercise 13.7. Shop Opening Hours (pivo007)

File: Pivo007.xlsx

By order of the shopkeepers’ association, a survey was conducted on the evening opening hours
of shops. The results from the interviewees can be seen in the following table:

Enter the data in a worksheet. Using a PivotTable, determine the number of supporters and
opponents by age and by sex.

Exercise 13.8. Own Home and Average Home Value (pivo008)

File: Pivo008.xlsx

The following table shows, for some people, how many years of study they have, whether or not
they own their own home, and, if applicable, the value of the house.

Enter the data in a worksheet. Using a PivotTable, determine the number of people who own
their own house and the average value of the house as a function of the number of years of study.
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Exercise 13.9. Transport Research (pivo009)

File: Pivo009.xlsx

Market research was performed among visitors to the city center. The following table shows data
from respondents who were questioned about their means of transport to the center for shopping.
The table indicates whether they went by car or by bus, how far they live from the center (in
km), and their travel time (in min).

Enter the data in a worksheet. Using a PivotTable, determine the average travel time by car for
residents living more than 15 km from the city center.

Exercise 13.10. Coffee Yield per Region (pivo010)

File: Coffee.xlsx

A worksheet contains the yields of some types of coffee per month and per area. Management
would like to determine the total yield of the products for each region. Create a PivotTable for
the monthly yields per coffee type. The region should be selectable through a report filter.

Exercise 13.11. Fuel Consumption Cars (pivo011)

File: Car.xlsx

Using a PivotTable, determine the minimum and maximum fuel consumption per car brand and
fuel type.

Exercise 13.12. Hobby Club (pivo012)

File: Pivo012.xls

In a worksheet, the last two columns show the number of visited club meetings in 2009 and 2010.
Create the following reports using PivotTables:

1. The number of club members by domicile and by gender.
2. The percentage of members by hobby and by gender.
3. An overview of attendance in 2010 by gender, with the number of visited club meetings

divided into three groups as shown in the following figure:
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OBJECTIVES

• Understand the Goal Seek method.
• Identify applications for Goal Seek.
• Learn tips for using Goal Seek effectively.

A formula consists of one or more variables. Typically, you want to know the result of the formula
for specific variable values. However, sometimes the reverse is true: you have a desired outcome
and need to find the variable values that achieve it.

When a formula’s outcome depends on only one variable, you can use the Goal Seek method.
This method iteratively changes the variable’s value until the formula produces the desired
result.

LIGHTBULB Tip

If a formula’s outcome depends on multiple variables, you should use Excel’s Solver add-in.

Goal Seek Dialog Box

Goal Seek can be accessed via Data tab> What-If Analysis (Forecast group) > Goal Seek.

Figure 14.1: Goal Seek Dialog Box.

In the dialog box, you need to specify three values:

Set cell The cell address containing the formula for which you want a specific result.

To value The desired outcome of the formula; in other words, your goal.

By changing cell The cell address whose value Excel should change to achieve the target. This
cell contains the variable.
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14.1 Break-Even Analysis for a Coffee Stand

Suppose you want to operate a coffee stand in a soccer stadium. You know the monthly costs
for rent, staff, and miscellaneous expenses, as well as the cost and selling price of a cup of
coffee. A calculation model has been created to determine the monthly profit or loss, as shown
in Figure 14.2, based on the number of cups of coffee sold.

Figure 14.2: Calculation model for a Coffee Stand.

Information needed How many cups of coffee do you need to sell per month to break even?

In this simple example, you could easily calculate the answer manually. However, Goal Seek is
well-suited for such problems.

Task 14.1. File: Stadium_Coffee.xlsx

1. Open the file.

2. Choose Data tab> What-If Analysis (Forecast group) > Goal Seek.

3. Specify the values for Goal Seek.

Figure 14.3: Values for Goalseek.

4. Click OK.

Excel will start calculating and find the value 562.5. Since you cannot sell half cups of coffee,
you will need to round the answer up to 563.
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14.2 Tips for Using Goal Seek

It’s possible that the formula is structured such that the desired answer doesn’t exist. It’s also
possible that an answer exists, but Excel cannot find it. In such cases, a dialog box will appear
indicating this.

If a solution exists but Excel cannot find it, check the following:

1. Verify in your model that the result cell (Set cell) actually depends on the changing cell.
The result cell must always contain a formula or function.

2. Ensure that the cell to be changed (By changing cell) contains only a value, not a formula
or function.

3. Try different initial values in the cell to be changed.

4. Increase the maximum number of iterations (default is 100) via File > Options > Formulas,
as shown in Figure 14.4.

Figure 14.4: Calculation options for Goal Seek.

14.3 Exercises

Exercise 14.1. Freelancer Earnings (goal001)

Suppose you want to work as a freelancer but only if you can earn at least $5,000 per month.
You receive a commission of 7.8% for each project.

1. Create a model in a worksheet where you can enter total sales and the commission percentage.
Calculate the commission amount.

2. Use Goal Seek to determine the total sales required to achieve a commission of $5,000.

Exercise 14.2. Loan Payment Calculation (goal002)

Using the PMT function, you can calculate the periodic payment for a loan based on constant
payments and a constant interest rate. The following illustration is an example of such a
calculation. Payments are made at the beginning of each period, and the loan is fully paid off
after the last term.

Figure 14.5: Model for calculating loan payments using the PMT function.
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1. Recreate this model in a worksheet.
2. Use Goal Seek to determine how much you can borrow if your maximum monthly payment

is $750.

INFO Note

Because payment is a cash outflow, the outcome is seen as a negative number.
Since a payment is a cash outflow, the result of the PMT function is typically a negative
number.

Exercise 14.3. Break-Even Point Analysis (goal003)

An entrepreneur faces costs and revenues that depend on the production quantity, Q. The
relationships are as follows:

Total Costs (TC): 𝑄2 + 8𝑄 + 15

Total Revenues(TR): −5𝑄2 + 80𝑄

The following chart plots TC and TR as a function of Q.

Figure 14.6: Chart showing Total Costs (TC) and Total Revenues (TR) as a function of production
quantity (Q).

1. Recreate this chart.
2. Determine the break-even point(s). This is the quantity Q where costs equal revenues (TC

= TR). The chart shows two such points. Use Goal Seek to find both solutions, providing
answers to four decimal places.

Exercise 14.4. Savings Account Growth (goal004)

On January 1, 2010, an amount of $1,000 is deposited into a savings account. The account earns
2.7% annual interest, which is added to the principal. The following table shows the growth of
the savings account balance over the first ten years.
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Figure 14.7: Model showing the growth of a savings account balance over ten years.

1. Create this model in a worksheet.
2. Use Goal Seek to determine the initial deposit required to have $2,500 in the savings

account after 10 years.
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OBJECTIVES

• Learn how to activate the Solver add-in.
• Understand the applications of Solver.
• Learn how to set up a calculation model for Solver.
• Understand how to add constraints in Solver.
• Discover tips for using Solver effectively.

Solver is an Excel add-in used for optimization calculations. In such calculations, you aim to
find an optimal value (usually a minimum or maximum, but sometimes a specific value) for a
formula in a particular cell.

Objective Cell (Target Cell) This is the cell containing the formula for which you want to find
an optimal outcome.

Variable Cells (Changing Cells, Decision Variables) These are the cells whose values determine
the outcome of the formula in the objective cell. Changing these values alters the formula’s
result.

Constraints (Restrictions, Preconditions) These are limitations or conditions that apply to the
variable cells. Variable cells often cannot take on any possible value and are bound by
these limits.

INFO Note

Solver offers more extensive “What-If” analysis capabilities than Goal Seek and is much
more versatile. Solver adjusts the values in the changing cells, within the defined constraints,
to find the optimal solution for the objective cell.

15.1 Enabling Solver

Solver is an add-in and is not activated by default in Excel’s menu. If Solver is not present on
the Data tab of the ribbon, it must be activated first. This is a one-time action.

Exclamation-Triangle Warning

First, check if Solver is available on the ribbon. If it is, you can skip this task. Select the
Data tab and check if the AnalyzeAnalyze group exists and if Solver is present within it.
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Figure 15.1: The Analyze group with Solver on the Data tab of the ribbon.

Task 15.1.

1. Choose File > Options > Add-Ins. A list of Microsoft Office Add-ins will be displayed.

2. In the Manage box at the bottom, select Excel Add-ins.

Figure 15.2: Selecting ‘Excel Add-ins’ to manage.

3. Click on Go…. A list of available Add-ins will be displayed.

4. Select the checkbox for Solver Add-in and click on OK.

Figure 15.3: List of available Excel add-ins with Solver Add-in selected.

5. Repeat the check above to ensure Solver is now visible.

15.2 Defining an Optimization Model

To perform an optimization calculation, you must first set up a suitable calculation model. This
is often more challenging than using Solver itself. The process of creating such a model will be
explained using the WeatherLeather case study.
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15.2.1 Case Description

WeatherLeather, a manufacturer of high-end leather jackets, has designed two styles for the new
season: a long jacket and a short jacket. Manufacturing a short jacket requires 1 hour in the
cutting department and 3 hours in the sewing department. A long jacket requires 2 hours and 4
hours, respectively. Labor hour availability is limited: the cutting department has 32 hours per
week, and the sewing department has 84 hours per week. Market demand for long leather jackets
is also limited; no more than 12 long leather jackets can be sold per week. For short jackets, all
manufactured jackets can be sold. Production is not to stock. The profit for a short jacket is
$90, and for a long jacket, it is $144.

The question is: How many jackets of each type should be made per week to achieve the highest
possible profit?

15.2.2 Understanding the Problem

This step might seem obvious, but it’s crucial to fully understand the problem before formulating
the objective cell, variable cells, and constraints. Misunderstanding the problem can lead to an
incorrect model. In this example, the problem is relatively straightforward:

How many short and long jackets should be produced weekly to maximize profit, given that no
more than 32 hours of cutting time and 84 hours of sewing time are available, and the market
for long jackets is limited to 12 per week?

15.2.3 Decision Variables

Identify the decision variables. These are the variables for which you need to determine values
that yield the optimal result. In the Excel model, these correspond to the variable cells. In this
example, there are two decision variables, conveniently denoted by letters:

• 𝑆 = number of short jackets per week
• 𝐿 = number of long jackets per week

15.2.4 Objective Function

You must establish a formula that represents the value you want to optimize. The decision
variables are included in this formula. In this example, the objective function is the weekly profit,
which depends on the number of short jackets (𝑆) and long jackets (𝐿) produced:

𝑃𝑟𝑜𝑓𝑖𝑡 = 90 × 𝑆 + 144 × 𝐿 (This function should be maximized.)

INFO Note

In more complex models, it can sometimes be challenging to formulate the problem with a
single objective function. It may also happen that the decision variables are not directly in
the objective function. In such cases, the objective function contains variables whose values
depend on the decision variables.

207



15 Solver

15.2.5 Constraints

Usually, there are restrictions on the values that the decision variables can take. These restrictions
must be identified and formulated.

In this example, three constraints come directly from the case description: the limited capacities
of the cutting and sewing departments, and the market demand for long jackets.

Additionally, there are often general constraints related to the nature of the decision variables. In
this example, the two decision variables (the number of jackets produced) must be non-negative
integers.

This leads to the following constraints:

• Cutting time constraint per week: 1 × 𝑆 + 2 × 𝐿 ≤ 32
• Sewing time constraint per week: 3 × 𝑆 + 4 × 𝐿 ≤ 84
• Market demand constraint for long jackets: 𝐿 ≤ 12
• Non-negativity constraints: 𝑆 ≥ 0 and 𝐿 ≥ 0
• Integer constraints: 𝑆 = 𝑖𝑛𝑡𝑒𝑔𝑒𝑟 and 𝐿 = 𝑖𝑛𝑡𝑒𝑔𝑒𝑟

15.2.6 Model in Excel

Now it’s time to build the model in Excel and solve the problem using Solver. One possible
layout is shown in Figure 15.4.

Figure 15.4: Example of a calculation model for the WeatherLeather case.

There isn’t one single correct way to build this model in Excel, but some guidelines can help.
These guidelines are discussed based on Figure 15.4. You can build the model yourself using
these guidelines and the figure, or use the provided file WeatherLeather.xlsx.

15.2.7 Guidelines for a Solver Model in Excel

1. Organize the data logically and clearly. Add sufficient explanatory text near cells containing
numbers and formulas. Models are often used in reports later, so it must be clear what
everything represents. Highlight the cells for decision variables (e.g., B4 and C4) and the
objective function (e.g., D5) so they are easily recognizable. Place constraints in a separate
section.
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2. Put each decision variable in a separate cell and assign it an initial value. In the example,
the number of short and long jackets produced are in cells B4 and C4, respectively. An
initial value of 1 is used for both, allowing for easy verification of formulas.

3. Create a formula for the objective cell. In D5, the formula is =B5*B4+C5*C4.

4. Create a formula in a separate cell for the left-hand side of each constraint. In an adjacent
cell, place the limit (right-hand side) of the constraint.

Table 15.1: Formulas in the WeatherLeather Excel model.

Cell Formula Explanation

D8 =B8*B4+C8*C4 Total cutting time calculation
D9 =B9*B4+C9*C4 Total sewing time calculation
D10 =C4 Number of long jackets produced

15.2.8 Solver Constraints

The dialog box in Solver used to add constraints is shown in Figure 15.5.

Figure 15.5: Dialog box for adding constraints in Solver.

Every constraint in Solver consists of three parts: a cell reference, a relationship operator, and a
constraint value.

Cell Reference he cell address or name of the cell range whose values you want to constrain.
You can use a single cell or a contiguous cell range, but not multiple disconnected ranges
in a single constraint entry.

Relationship Possible operators: <=, =, >=, int, bin, or dif.

• int: The values in the cell reference(s) must be integers (within a certain tolerance
defined by the “Constraint Precision” in Solver options).

• bin: The values in the cell reference(s) must be binary (either 0 or 1). This can be
used for “yes/no” decisions.

• dif: The values in the specified cell references must all be different from each other.

Constraint A number, a cell reference (or name), or a formula that the cell reference must adhere
to based on the relationship.
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15.3 Implementing the Model

In the WeatherLeather case, the profit must be maximized.

Task 15.2. File: WeatherLeather.xlsx

1. Open the file.

2. Select the objective cell, D5.

3. Choose tab Data > Solver (Analyze group). The Solver Parameters dialog box will appear.

Figure 15.6: Initial Solver Parameters dialog box for WeatherLeather.

4. Verify the following:

• Set Objective: $D$5
• To: Max
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5. Click in the By Changing Variable Cells box and select the cell range B4:C4 in the worksheet.
Excel will convert this to $B$4:$C$4.

6. In the Subject to the Constraints section, click Add. The Add constraint dialog box will
appear (see Figure 15.5)

7. Add the constraint D8 <= E8 (Cell Reference: D8, Relationship: <=, Constraint: E8) and
click OK.

The Solver Parameters dialog box will reappear, showing the first constraint as $D$8 <= $E$8.

8. Click Add again.

9. Add the constraint D9 <= E9 and this time click Add (instead of OK).

The empty Add Constraint dialog box will remain displayed. You won’t see the second constraint
added to the main Solver Parameters dialog box yet, but it has been registered.

INFO Note

By clicking Add instead of OK after entering a constraint, you can add multiple constraints
more efficiently without repeatedly returning to the Solver Parameters dialog box.

10. Add the constraint D10 <= E10 and click Add.

11. Add the constraint B4:C4 >= 0 and click Add.

12. Addt the constraint B4:C4 = integer (select int from the dropdown).

13. All constraints have now been added. Click OK in the Add Constraint dialog box.

The Solver Parameters dialog box will now show all specified constraints.

14. Click Solve. After a short time, the Solver Results dialog box will appear.

15. Select Keep Solver Solution (this is usually the default). In the Reports section, select
Answer and then click OK.

The solution found by Solver will now be displayed in your worksheet.

A new worksheet named Answer Report … will also be created.

INFO Note

• The names used in the Answer Report are not always perfectly descriptive. Excel
attempts to derive these names from text in adjacent cells in your model. To ensure
clear names in the report, it’s highly recommended to define meaningful names for
the relevant cells in your worksheet (using the Name Box or Name Manager) before
running Solver.

• In the Constraints section of the Answer Report, the Status column indicates which
constraints are Binding. A binding constraint means its limit has been reached, and
there is no slack. In this example, you can see that all available cutting time and
sewing time are used. For the long jackets, the market demand limit is not reached;
there is a slack of 6 (meaning 6 more could potentially be sold if other constraints
allowed).
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Figure 15.7: Solver Parameters dialog box with all constraints specified for WeatherLeather.
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Figure 15.8: Solver Results dialog box showing a solution was found.

Figure 15.9: Worksheet showing the optimal solution found by Solver for WeatherLeather.
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Figure 15.10: nswer Report generated by Solver for the WeatherLeather problem.

The WeatherLeather problem is now solved. A maximum profit of $2,664 per week can be achieved
by producing 20 short jackets and 6 long jackets.

15.4 No Solution Found. What Now?

Frequently, Solver reports that no feasible solution could be found:

There are two main possibilities:

1. No solution actually exists for the problem as formulated.
2. A solution does exist, but Solver was unable to find it.

In most cases, it’s not immediately certain which situation applies. Here are a few guidelines to
investigate if Solver can find a solution:

15.4.1 Changing Initial Values of Variable Cells

Solver’s ability to find a solution can depend on the initial values of the variable cells. Experi-
menting with different starting values can sometimes help Solver find a solution, especially for
non-linear problems.

15.4.2 Changing Solver Options

Finding a solution also depends on how Solver operates. The search for a solution is an iterative
process (repeated recalculations until a specific condition is met). Solver has several settings for
this iteration process. Clicking the Options button in the Solver Parameters dialog box opens a
window for changing these settings.

This dialog box offers extensive control over the solution process. Specifications for certain
problem types can be saved as a model and reloaded. Some key settings are:
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Figure 15.11: Solver message indicating no feasible solution was found.

Table 15.2: Explanation of selected Solver options.

Option Explanation

Max Time The maximum time Solver is allowed to spend on the solution process.
Iterations The maximum number of iterations (recalculations) Solver will

perform.
Constraint Precision The degree of precision required for a constraint to be considered

satisfied. A smaller number means higher precision. (Note: The
original table had ‘Precision’ and ‘Constraint Precision’ - this is a
common point of confusion. ‘Constraint Precision’ is the key one for
how closely constraints must be met).

Integer Optimality (%) The maximum percentage difference from the true optimal integer
solution that is acceptable. A value of 0 means Solver must find the
exact optimal. A small percentage (e.g., 1%) can speed up complex
integer problems. (Original table had ‘Tolerance’ which is related but
‘Integer Optimality’ is the standard term here).

Assume Linear Model Check this if all relationships in your model are linear. This can speed
up the solution process. Using it with non-linear models may prevent
Solver from finding a solution or lead to an incorrect one. Show
Iteration Results Select this to pause Solver after each iteration and
see the trial solution. Not typically used unless debugging a difficult
problem.

Additional information:
Visit the support site of Frontline Systems, the developers of Solver, for the most comprehensive

215



15 Solver

Figure 15.12: Solver Options dialog box.

216



15 Solver

information.1

15.5 Exercises

Exercise 15.1. Bonbon Box Assortment (solv001)

A renowned bonbon manufacturer wants to offer an assortment box with two types of chocolates
(cherry bonbons and hazelnut chocolates) to maximize profit. The following information is known:

• A cherry bonbon takes up 16 cm2 of space, and a hazelnut bonbon takes up 8 cm2. The
bonbons are separated by paper. At least 320 cm2 of the box must be covered with bonbons.

• A cherry bonbon weighs 2 grams, and a hazelnut bonbon weighs 1 gram. Market research
indicates the ideal weight of the box’s contents is between 40 grams and 60 grams (inclusive).

• Market research also revealed that the box must contain at least 35 bonbons in total, with
at least 10 of them being cherry bonbons.

• The profit on a cherry bonbon is $0.28, and on a hazelnut bonbon is $0.20 .

1. What are the decision variables?
2. What is the objective function?
3. What are the constraints?
4. Build the model in Excel using the guidelines from this chapter. An example layout is

shown below. Formulas need to be placed in the empty cells for calculated values (like
total space, total weight, total bonbons, total profit). Both decision variables (number of
each bonbon type) have an initial value of 10. These starting values allow you to easily
check if your formulas are correct.

Figure 15.13: Example model layout for the bonbon box problem.

5. Enter the model into Solver and determine the optimal number of each bonbon type for
the box.

Exercise 15.2. Supermarket Branch Expansion (solv002)

A supermarket chain plans to open new branches with a maximum investment of $14 million.
The chain is considering four types of shops: A, B, C, and D. The following figure shows the
setup costs for each store type and their expected sales in the next financial year.

Figure 15.14: Data for supermarket branch expansion (costs and expected sales).

1http://www.solver.com
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All newly built branches can be operational for the next financial year. Potential locations are
comparable in terms of population. The executive board wants to maximize the total expected
sales from the new branches in the next financial year. How many branches of each type should
be built?

1. What are the decision variables?
2. What is the objective function?
3. What are the constraints?
4. Build the model in Excel. An example layout is provided below. Formulas are needed for

calculated values (total investment, total sales). Initial values for the number of each store
type are set to 2 for formula checking.

Figure 15.15: Example model layout for the supermarket expansion problem.

5. Enter the model into Solver to determine the optimal number of branches of each type and
the expected total sales.

Exercise 15.3. Running Shoe Production (solv003)

A company in Hong Kong manufactures American running shoes. The company produces three
models: Runner, Lady T, and Super A, and wants to maximize profit.

• Manufacturing 1 pair: Runner requires 0.31 hours, Lady T requires 0.20 hours, and Super
A requires 0.25 hours. The maximum number of production hours is 150 per week.

• Capital investment per pair: Runner $16, Lady T $12, and Super A $10. A total of $8,000
per week is available for capital investment.

• Due to limited machine capacity, weekly production is limited to: 300 pairs of Runner, 400
pairs of Lady T, and 400 pairs of Super A.

• Profit per pair: Runner $6, Lady T $5, and Super A $4.

Calculate the optimal production numbers and the maximum profit per week using Solver.

1. What are the decision variables?
2. What is the objective function?
3. What are the constraints?
4. Build the model in Excel. An example layout is below. Initial values for production

quantities are set to 100.

5. Enter the model into Solver to determine the optimal number of each model and the
maximum weekly profit.

Exercise 15.4. Aluminum Ladder Production (solv004)
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Figure 15.16: Example model layout for the running shoe production problem.

Figure 15.17: Production times (hours/ladder) and profit ($/ladder) for three ladder types.

A manufacturer produces three types of aluminum ladders. The production process involves
sewing the material, then assembling, and finally finishing. Production times and profit per
ladder are listed below:

The total available production capacity per period is: 80 hours for sewing, 100 hours for
assembling, and 120 hours for finishing.

Use Solver to determine how many ladders of each type should be produced to maximize profit.

Exercise 15.5. Dog Food Mix (solv005)

Two types of dog food are available: ordinary and special.

• A bag of ordinary food contains 3 units of minerals, 2 units of protein, and 3 units of fat.
It costs $8.

• A bag of special food contains 8 units of minerals, 2 units of protein, and 1 unit of fat. It
costs $14.

• Over a certain period, a dog must consume at least 72 units of minerals, 36 units of protein,
and 36 units of fat.

Determine the quantity of each bag type to be bought to meet these nutritional requirements at
minimum cost.

Exercise 15.6. Vitamins for Cattle Feeding (solv006)

A farmer uses three types of cattle feed: Type 1, Type 2, and Type 3. The nutritional composition
(vitamins A, B, C in mg/kg) and cost per kg of each type are shown below:

Figure 15.18: Nutritional composition and cost for three types of cattle feed.
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A magazine has published the minimum daily requirements (MDR) per animal for vitamins A,
B, and C as 120 mg, 180 mg, and 100 mg, respectively. Furthermore, an animal cannot eat more
than 7.5 kg of Type 1, 5 kg of Type 2, and 2.5 kg of Type 3 per day.

How many kilograms of each feed type should the farmer provide daily to meet the MDR at the
lowest possible cost, while respecting the maximum consumption limits?

Exercise 15.7. Vitamin Pill Consumption (solv007)

A nutritionist recommends a patient consume a minimum daily requirement of 400 units of
vitamin B and 800 units of vitamin C. The local pharmacy provides two vitamin brands: Y and
Z.

• A vitamin pill of brand Y contains 75 units of vitamin B and 100 units of vitamin C and
costs $0.10.

• A vitamin pill of brand Z contains 50 units of vitamin B and 200 units of vitamin C and
costs $0.08.

How many vitamin pills of each brand must be consumed daily to meet the requirements at the
lowest possible cost?

Exercise 15.8. Minimizing Transport Costs (solv008)

File: Solv008.xlsx

A company has stores in 6 cities (Amersfoort, Eindhoven, Enschede, Lelystad, Tiel, Zwolle).
Stores are supplied from 3 distribution centers (DCs) in Coevorden, Venlo, and Woerden. Each
week, stores forecast sales for the next week and submit the required number of products to the
head office. The head office creates a transport plan based on available stock in the DCs and the
required product numbers.

Figure 15.19: Model structure for transport cost minimization. The top table shows transport
costs per unit. “Number Needed” is store demand. “Number transported from”
will be determined by Solver. “Initial stock” is DC availability.

Explanation:
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• The upper table shows the transport costs per product unit from a DC to a store. For
example, transporting 1 product from DC Coevorden to the store in Amersfoort costs $100.

• The “Number Needed” column indicates the number of products each store requires.
Amersfoort needs 225 products.

• The “Number transported from” area (the main grid in the lower section) should display
the number of products transported from each DC to each store. Solver should determine
these numbers.

• The “Initial stock” row contains the number of products available at each DC.

Create the cheapest transport plan using Solver.

Exercise 15.9. Solving a System of Linear Equations (solv009)

Solve the following system of equations using Solver:

6, 1𝑥1 + 4, 5𝑥2 + 5, 7𝑥4 + 7, 5𝑥5 = 5, 7
2, 4𝑥1 + 5, 5𝑥2 − 5, 7𝑥3 + 4, 7𝑥4 + 5, 6𝑥5 = 5, 6
2, 4𝑥1 − 5, 0𝑥2 − 4, 6𝑥3 + 3, 6𝑥4 + 9, 7𝑥5 = 9, 7
4, 3𝑥1 − 5, 3𝑥2 + 3, 4𝑥3 − 8, 4𝑥4 − 5, 6𝑥5 = −5, 6
1, 1𝑥1 − 3, 0𝑥2 + 2, 4𝑥3 − 13𝑥4 + 3, 5𝑥5 = 3, 5

Exercise 15.10. Savings Bank Investment Strategy (solv010)

A savings bank has 3 million euros to invest. The investment portfolios include personal loans,
mortgages (first and second), and car leasing. The bank association’s articles stipulate certain
conditions for fund allocation:

• At least 30% of the total loaned amount must be invested in mortgages.
• At least 50% of the amount designated for mortgages must be invested in first mortgages.
• No more than 25% of the total loaned amount can be allocated to personal loans and car

leasing combined.
• No more than 15% of the total loaned amount can be invested in personal loans.

The annual yield for each loan type is listed below:

Table 15.3: Annual yields for different loan types.

Loan Type Yield

Personal loan 18%
First mortgage 12%
Second mortgage 14%
Car leasing 16%

Determine, using Solver, how much money (in multiples of €1,000) should be invested in each of
the four loan types to maximize the total annual yield.
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OBJECTIVES

• Understand what macros are and how they are used.
• Learn how to activate the Developer tab.
• Learn how to record a macro using the macro recorder.
• Learn how to modify a macro.
• Learn how to create a command button to run a macro.
• Understand macro security settings.

You can automate repetitive tasks in Microsoft Excel using macros. A macro consists of a series
of commands and functions that are executed sequentially with a single command or the press of
a button.

Macros are primarily intended for frequently performed actions or complex operations. Using
macros can increase efficiency and reduce the chance of errors.

Simple macros, consisting of a sequence of actions, can be recorded using the built-in macro
recorder. More complex macros are programmed in the VBA (Visual Basic for Applications)
programming language. This chapter focuses on simple macros, for which you do not need any
programming knowledge.

INFO Note

The language used for Excel macros is Visual Basic for Applications (VBA). Macro com-
mands and functions are stored in a Visual Basic module. The Visual Basic Editor allows
you to edit macros, copy macros between modules or workbooks, and rename modules and
macros.

16.1 Developer Tab

To record, edit, and run macros, the Developer tab must be visible on the ribbon.

Several Excel functions, including those for Macros and VBA, are located on the Developer tab.
This tab is not shown by default when Excel is installed and therefore needs to be made visible
first. This is a one-time action.

INFO Note

First, check if the Developer tab is already present on the ribbon. If so, you can skip this
task.
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Figure 16.1: The Developer tab on the Excel ribbon.

Task 16.1.

1. Choose File > Options > Customize Ribbon.

Figure 16.2: Excel options showing how to enable the Developer tab.

2. Under Main Tabs on the right, check the Developer box and click OK.

The Developer tab should now be visible on the ribbon (see Figure 16.1).

16.2 Macro Security Settings

Macros can potentially be used for malicious purposes, such as installing a virus. Excel’s security
settings can block such threats. However, if the settings are too restrictive, you won’t be able to
run legitimate macros; if they are too lenient, you won’t be protected. A good compromise is the
setting that prompts you to decide whether to allow macros, which is also the default setting.

Change Settings

To view or change macro security settings, click on Developer tab > Macro Security (Code
group).

The Trust Center dialog box will appear.
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Figure 16.3: Macro Security button on the Developer tab.

Figure 16.4: Macro Settings within the Trust Center dialog box.
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Table 16.1: Overview of Macro Settings.

Setting Explanation

Disable macros without
notification

Choose this option if you do not want to allow macros. All macros in
documents are disabled, along with security alerts about macros.
Documents containing macros that you trust can be saved in a trusted
location; documents in trusted locations run without security checks.

Disable macros with
notification

This is the default setting and generally the best choice. With this
setting, you will receive a security alert allowing you to choose
whether or not to run macros on a case-by-case basis.

Disable macros except
digitally signed macros

A macro creator can digitally sign a macro. If you designate this
creator as a trusted publisher, their signed macros will run without
warnings. All unsigned macros will be disabled without notification.

Enable all macros (not
recommended)

Choose this option if you want to run all macros. This option is not
recommended because it leaves your computer vulnerable to
potentially malicious code.

16.3 Recording Macros

Simple macros can be created by recording your actions using the built-in macro recorder. After
starting the recorder, all actions are recorded and converted into VBA code in the background.
This continues until you stop the recorder.

INFO Note

To ensure a properly working macro, it’s important to first perform the actions manually
and write them down step-by-step. You can then use this script to record the actions
accurately with the macro recorder.

The button to start recording macros is on Developer Tab in the group Code, see Figure 16.1.

When you click this button to start recording a macro, a dialog box appears where you can enter
several properties for the macro.

Figure 16.5: Record Macro dialog box.

Macro name
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Each macro must have a unique name. Excel suggests a default name like “Macro1”. You can
change this by typing a different name.

The first character of a macro name must be a letter. Subsequent characters can be letters,
numbers, or underscores. Spaces are not allowed in macro names. Always use meaningful names
that indicate what the macro does. The underscore can be used as a word separator (e.g.,
Format_Cell_Red).

Shortcut key

Macros can be run from the menu or via keyboard shortcuts. These are typically CTRL combined
with a letter key (e.g., Ctrl+Shift+A if you use an uppercase letter, or Ctrl+a if you use lowercase).
If you want to assign a shortcut key, enter a letter in the box. For example, entering ‘a’ (lowercase)
will assign Ctrl+a.

Assigning a shortcut key is not required but can be very useful for frequently used macros. Be
careful not to overwrite existing Excel shortcuts.

Store macro in

You can choose where to store the macro:

• This Workbook: The macro will only be available in the current Excel file.
• New Workbook: The macro will be stored in a new, blank workbook that is created. (This

option is rarely used for general macros).
• Personal Macro Workbook: The macro is stored in a special hidden workbook

(Personal.xlsb) that opens automatically when Excel starts. Macros in this workbook
are available in any Excel file you open.

Think carefully about this. If the macro is specific to the active workbook, choose This Workbook.
If you want the macro to be available globally in Excel, Personal Macro Workbook is the best
choice. The default is This Workbook.

Description

It’s recommended to provide a brief description of what the macro does. While you’ll remember
its purpose when you create it, a description is helpful for future reference. This is optional.

INFO Note

All these choices (name, shortcut, storage location, description) can be changed later.

16.4 Macro Cell Format

Objective

Create a macro named CellFormat that formats the selected cell’s text to Comic Sans MS font,
bold, italic, 16 pt, and red. The column width should also be adjusted to fit the cell’s content.

Task 16.2. Record macro

1. Start with an empty worksheet and enter some text in a cell (e.g., cell A1).

2. Select the cell containing the text.

3. Go to Developer tab > Record Macro (Code group).
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4. In the Record Macro dialog box, enter the following:

• Macro name: CellFormat
• Shortcut key: (leave empty)
• Store macro in: This Workbook
• Description: Formats selected cell to Comic Sans MS, 16pt, Bold, Italic, Red, and

autofits column.

Figure 16.6: Properties for the CellFormat macro.

5. Click OK.

6. Perform the following actions on the selected cell:

• Right-click on the cell and choose Format Cells….
• Go to the Font tab
• Set Font: Comic Sans MS
• Set Font style: Bold Italic
• Set Size: 16
• Set Color: Red
• Click OK.

7. With the cell still selected, go to Home tab > Format (Cells group) > Autofit Column
Width.

8. Go to Developer tab > Stop Recording (Code group).

Figure 16.7: Stop Recording button on the Developer tab.

Now, test the macro to ensure it works correctly.

Task 16.3. Testing the Macro

1. Enter some text in a different cell and select this cell.
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2. Go to Developer tab > Macros (Code group).

3. In the Macro dialog box, select CellFormat and click Run.

Figure 16.8: Running the CellFormat macro from the Macro dialog box.

4. Verify that the cell is formatted correctly according to the macro’s actions.

5. Save the workbook. Since it contains a macro, you must save it as an Excel Macro-Enabled
Workbook (*.xlsm). Name it CellFormat.xlsm.

Exclamation-Triangle Warning

When saving a workbook containing macros, Excel might default to saving it as a standard
Excel Workbook (*.xlsx). This format cannot store macros. You must manually change
the “Save as type” to Excel workbook with macros with the extension *.xlsm.

16.5 Editing Macros

This task requires the CellFormat macro created in the previous section (Task 16.2).

You can modify a macro without re-recording it. Both the macro’s options (like shortcut key)
and its underlying VBA code can be viewed and edited.

Objective

Make the following changes to the CellFormat macro:

• Assign the shortcut key “Control t”.
• Change the font size to 18 pt.

Task 16.4. Continue with the file CellFormat.xlsm from Task 16.3.

1. If necessary, open the CellFormat.xlsm file. (Enable content/macros if prompted).
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2. Go to Developer tab > Macros (Code group). The Macro dialog box will appear (see
Figure 16.8).

3. Select the CellFormat macro and click Options.

Figure 16.9: Macro Options dialog box for CellFormat.

4. In the Shortcut key box, enter t (lowercase). And in the Description box, change “16pt” to
“18pt”. Then click OK.

5. With the CellFormat macro still selected in the Macro dialog box, click Edit.

The Microsoft Visual Basic for Applications (VBA) editor will open, displaying the macro’s code.
In this code you will find text size 16 on two places:

Format cell in Comic Sans, 16pt, bold, italic and red
.Size = 16

6. Change 16 to 18 in both places.

7. Close the Microsoft Visual Basic for Applications window (click the X in the top-right
corner of the VBA editor window).

8. Test the modified macro: Select a cell with text and press Ctrl+t. Verify the font size is
now 18pt.

9. Save the workbook.

16.6 Creating a Command Button

You can run a macro in one of the following ways:

• Via the menu Developer tab > Macros > select macro > Run.
• Via an assigned shortcut key.
• Via a command button on the worksheet.

This task demonstrates how to create a command button on the worksheet for the CellFormat
macro.

Task 16.5. Continue with the file CellFormat.xlsm from Task 16.4.

1. If necessary, open the file.

229



16 Macros

2. Go to Developer tab > Insert (Controls group).

3. In the Form Controls section, click on Button (Form Control)

Figure 16.10: Form Controls dropdown, with Button (Form Control) highlighted.

The mouse cursor will change to a small crosshair (+).

4. Click and drag on the worksheet to draw a rectangle where you want the button to appear.
Release the mouse button. The Assign Macro dialog box will immediately appear.

Figure 16.11: Assign Macro dialog box, linking CellFormat to the button.

5. Select the CellFormat macro from the list and click OK.

The rectangle you drew will become a button, typically with default text like “Button 1”.

6. Right-click on the button and choose Edit Text. Select the default text and change it to
something more descriptive, for example, “Format Cell”.

Figure 16.12: Command button on the worksheet linked to the CellFormat macro.

7. Click anywhere outside the button to deselect it.

8. Test the button: Enter text in a cell, select the cell, and click your new Format Cell button.

9. Save the workbook.

16.7 Tips

16.7.1 Relative vs. Absolute References

By default, recorded macros use absolute cell references. This means the exact cell addresses
(e.g., A1, C5) are hardcoded into the macro. The macro will always affect those specific cells,
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regardless of which cell is active when you run it (unless the recorded actions inherently refer to
Selection).

If you want a macro to operate relative to the currently active cell (e.g., “move one cell to the
right of the active cell”), you need to enable Use Relative References before you start recording
those specific steps. This button is located on the Developer tab (Code group).

Figure 16.13: Use Relative References button on the Developer tab.

Exclamation Important

The “Use Relative References” mode is a toggle. It stays active (or inactive) until you click
the button again to change its state. Always check its status before recording if reference
type is important.

16.7.2 Deleting Macros

To delete a macro:

• Go to Developer tab > Macros (Code group).
• Select the macro you want to delete from the list.
• Click the Delete button.
• Confirm the deletion.

16.8 Exercises

Exercise 16.1. Background Color Macro (macr001)

Record a macro that applies a light gray background color to the currently active cell.

Exercise 16.2. Percentage Formatting Macro (macr002)

Record a macro named PercentageFormat that formats a numeric value in the selected cell as a
percentage with one decimal place and also centers the content horizontally within the cell.

Exercise 16.3. Formatting Cell A1 (macr003)

Record a macro that performs the following actions specifically on cell A1 (or related row/column):

• Sets the height of row 1 to 18.
• Sets the width of column A to 3.
• Formats the text in cell A1 to Tahoma font, size 14, bold, and blue color.

Exercise 16.4. Printing Gridlines Macro (macr004)

Create a macro that ensures gridlines will be printed for the active sheet.
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INFO Note

This setting can be found underPage Layout tab > Page Setup group (dialog launcher) >
Sheet tab.
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17 Measurements

OBJECTIVES

• Explain of linear relations.
• Add a linear trendline to a scatter plot.
• Use of the SLOPE and INTERCEPT worksheet functions.

Researchers often want to know whether the value of one variable depends on another. To
determine this, they conduct measurements. During these measurements, one variable is changed
(independent variable), while another variable is measured (dependent variable).

These measurements produce a series of data points that can be plotted on a chart. The shape
of the chart often provides an initial indication of whether a relationship exists between the
variables—and if so, what kind: linear, exponential, logarithmic, etc.

A relationship between variables is represented by a mathematical function and described by an
equation. If the relationship is linear, the chart will display a straight line.

When plotting measurement results, there usually isn’t a single line that fits all data points
perfectly. Using statistical methods, applications like Excel can determine the best-fitting line,
known as a regression line. The method used to calculate this line is called the least-squares
method. The underlying statistical techniques are beyond the scope of this chapter. If you’re
interested in learning more, consult additional literature.

17.1 Linear Relationship

If there is a linear relationship between two variables 𝑥 and 𝑦, it can be expressed by the
equation:

𝑦 = 𝑎𝑥 + 𝑏

• 𝑦: the dependent variable
• 𝑥: the independent variable
• 𝑎: the slope (a constant)
• 𝑏: the intercept (a constant)

Example 17.1. 𝑦 = 2𝑥 + 3

The graph of 𝑦 = 2𝑥 + 3 is a straight line. The slope of the line, 𝑎, is 2, and the intercept (where
the line crosses the y-axis), 𝑏, is 3.

With measurement results, you can use Excel to

• plot the data points.
• draw a trendline (best-fitting line).
• display the trendline equation.
• calculate the slope and intercept using Excel functions.
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Figure 17.1: Straight line in a linear relationship

17.2 Linear Trendline

This section explains how to add a linear trendline.

At a timber factory, large numbers of similar items are produced, primarily differing in size and
weight. To investigate whether production time depends on item weight, several measurements
are taken. A linear relationship is assumed.

Task 17.1. File: Prodtime_Weight.xlsx

1. Open the file.

2. Select the range A2:B11, which contains the measurements.

3. Go to Insert tab> Recommended Charts (Charts group) > Scatter > OK.

4. Add a linear trendline.

5. Select the trendline and Right-click > Format Trendline.

6. In the Format Trendline pane, check Display equation on chart.

7. Make the following adjustments (see the example in Figure 17.3):

• Add a chart title and axis titles.
• Adjust the axes scales.
• Remove decimal places from axis labels.
• Set the trendline color to solid red.
• Move the equation to a visible location.

From the trendline equation, you can determine the relationship between the variables:

𝑃𝑟𝑜𝑑𝑢𝑐𝑡𝑖𝑜𝑛𝑡𝑖𝑚𝑒 = 2, 955 × 𝑊𝑒𝑖𝑔ℎ𝑡 + 41, 99

Worksheet functions

You can use Excel’s statistical functions SLOPE and INTERCEPT to find the slope and y-intercept
of the trendline.

8. In an empty cell, insert the SLOPE function with the following arguments:

• Known_ys: B2:B11

234



17 Measurements

Figure 17.2: Trendline options.
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Figure 17.3: Scatter plot of the measurements with linear trendline.

• Known_xs: A2:A11

9. In another cell, use the INTERCEPT function with the same ranges.

The slope is 2.95503212 and the intercept is 41.99036403, which correspond to the trendline
equation.

17.3 Exercises

Exercise 17.1. Height and Weight (meas001)

File: Meas001.xlsx

The height and weight of several schoolchildren are shown below.

Figure 17.4: Height and weight results.

Assume a linear relationship and determine the equation where weight is a function of height.

Exercise 17.2. Study Time and Exam Grade (meas002)

File: Meas002.xlsx

The study time and exam scores of several students are shown below.

Figure 17.5: Study time and exam scores.

Assume a linear relationship and determine the equation where score is a function of study time.
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Exercise 17.3. Shrinkage and Temperature (meas003)

File: Meas003.xlsx

A synthetic fiber manufacturer investigates whether fiber shrinkage relates to the washing
temperature. Eight experiments are conducted at different temperatures. Shrinkage is expressed
as a percentage of the original length.

Figure 17.6: Shrinkage percentage vs washing temperature.

1. Assume a linear relationship and determine the equation where shrinkage percentage is a
function of temperature.

2. Predict the shrinkage at a temperature of 65oC.

Exercise 17.4. Resistance and Temperature (meas004)

File: Meas004.xlsx

The resistance of a metal block is influenced by temperature. The figure below shows resistance
at various temperatures.

Figure 17.7: Resistance at various temperatures.

1. Assume a linear relationship and determine the equation where resistance is a function of
temperature.

2. Predict the resistance at a temperature of 400oC.
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